16n is a bank of faders [release thread] [current version:1.33]


Wondering how to assign faders to the ER301 via i2c. Is it possible to say have the 16n set as 9-24? I’m running polyES with the ER301 and that’s using ports 1-8.

Also how difficult would it be to move the i2c jack to the side?

1 Like

Polyphonic earthsea for trilogy/ansible and er-301/just friends/txo

I bought some Jarrah laserply to get some panels lasercut. But before sending it away to get lasercut i decided to cut one on my homemade CNC mill to verify sizing. Came up pretty nice despite the unavoidable splintering. This has a bit of guitar fretboard oil applied. Excited for the finished product neatly cut :slight_smile:

@cosmicsoundexplorer rather than move the I2C jack to the side it would be quite easy to invert the fader values in firmware and use the unit upside down. Not convinient for the CV outs but might be neater if youre primarily using I2C



There’s not enough room on the top-side of the board - currently, where all components are mounted - without doubling the margin of the board on that side around the faders. However, you might be able to mount it on the underside as it’s a slimline part. I was trying to keep everything to the topside for simplicity’s sake.

So, to do that, you’d need to move the part in EAGLE, and reroute the traces. The latter isn’t too hard - there’s only two, and a quick eyeball says there’s definitely enough room to do it.

1 Like


dang you all are fast i know there was talk of people building a unit for other members is anyone still up to do that?



There’s a couple threads linked in the top post:

(world) https://llllllll.co/t/16n-faderbank-group-buys/18672

(uk/eu) https://llllllll.co/t/16n-eu-uk-group-buy-thread/18657

I think @MichiganSynthWorks is building units for people (info in the “world” thread).



I’m using the same configuration and am wondering about this too.

1 Like


Thank you! This helps a lot.



Brandon, Just wrapping my head around the 16n. Do I understand correctly that if I already have a Teletype with backpack that the TelexB won’t work in my setup? If not, what’s the best way to integrate the 16n into my setup? (Teletype/backpack–>ER301, Telexi,TelexO, Ansible x 2)

1 Like


IANB but: The keys are short cable runs (to reduce capacitance) and only having one set of pull-ups active on the SDA & SCL lines (multiple would draw too much current). The TT backpack already has pull-ups. Just don’t power the TXb and it will still function as a cable-to-jack adapter for use with the 16n.

Looks like there are unpopulated pull-ups on the 16n itself in case anyone wants to use it in master mode without something like the TXb.

1 Like


[don’t want to derail this thread too much but since we’re talking about it]

so for the i2c bus to function properly it should have only one power source and one set of pull-up resistors. so what happens with the following 2 scenarios?

  • teletype with a backpack - do both tt and the backpack provide power in this case? it works but i’m curious why this isn’t considered problematic

  • if you use a powered i2c board (like the backpack or TXb) but don’t power it, and you use it simply as a multiple to connect to teletype, i assume the fact that it also has pull-ups doesn’t matter since they’re not connected to anything?

re: polyearthsea - will reply in the polyes thread to not derail (quick answer is that i’ll make it work for such scenario)



The issue of multiple pull-ups is that parallel resistors have a lower total resistance. Lower resistance means more idle current draw (maybe overwhelming the MCU I/O current source per pin ratings) and bigger voltage divider (maybe raising your “low” voltage above the needed threshold). I haven’t run the numbers, hence the “maybe”.

The reason for the backpack wasn’t simply to add pull-ups, it was to add more pull-ups to bring the effective resistance down. TT’s were apparently not suitable until the most recent hardware Rev.

Unpowered backpacks or TXb would be fine for simple distribution. You shouldn’t use either one powered up with the new TT hardware.



I’m having problems compiling the code. 1.8.8/1.45 on win10 64bit.

_16n_faderbank_firmware:27: error: expected constructor, destructor, or type conversion before ‘;’ token


Might I also recommend a compiled binary somewhere and the actual library files in the repo for future proofing. There is INVARIABLY some incompatibility issue because of platform, libraries, whatever for someone (usually me for some reason).



Compiled releases exist already.

Library files in repository: no, that’s a can of worms around licensing and I won’t do that.

I am running 1.8.5/1.40, which is clearly not latest, so am going to upgrade to see if I can reproduce your issues. I’ve also opened an issue on Github.



I tried it on 1.8.5 initially and had the same issue



I would prefer to conduct issue resolution around something like this on Github to save churn but screw it, let’s at least try here:

can you confirm your settings in the Tools menu? The bottom of your Arduino IDE should look like this:


I’m currently unable to reproduce on 1.8.8/1.45 although I’m not on Windows, and don’t have access to a Win10 machine.



yeah, settings confirmed. In my experience, errors like these tend to be mac/pc things (case for instance). pick this up on git and mods can clean this up



QUICK UPDATE: there’s a bug in the DXF files: the four holes at the corners are all 5.5mm (ie, the countersink size) rather than 2.5mm (the drill size).

I’m going to try to fix this asap, but am a little busy at work so it may be a day or two.



Just had a similar problem last night with different code.

FWIW the arduino midi libs (as used by teensy) changed significantly in Arduino 1.8.5

It should be solved in Arduino 1.8.8 + teensyduino 1.45

(You’ve probably already did this but…) You do need to be sure the board is set to Teensy 3.2 and USB Type is set to MIDI or Serial + MIDI (under the Tools menu)



I used the teensyduino ones and that sorted the compiling issue.



I’m testing the i2C connection between a 16n and a Teletype, without success so far :

FB 1 or any other fader always returns 0

The 16n is connected to a TT busboard on the back of a Teletype (not the latest revision).
The other modules connected to the backpack work properly, I mean that I can send I2C commands from Teletype, as usual. There’s an ER-301 on its own header, and two TXo in series connected to another header.
No issue with USB and CV. The Pull up resistors are not placed on the 16n. The firmware has not been modified.

The cable connecting the 16n to the teletype is very short (see photo), 15cm outside + 20cm inside. I double checked the connections with a multimeter: tip SDA, sleeve ground, ring SCL.

Am I missing something here ? I’m gonna try to connect the 16n to one of the TXo maybe

Each test failed :frowning:

Should I open an issue on Github @infovore ?

I’ve enabled “debug”, but nothing is printed in the serial monitor when I type FB 1 on the Teletype.

I’ve checked the connections again between the busboard and the Teensy.

I used 1N4148WQ-7-F diodes instead of 1N4148W-7-F but the specs are nearly identical.

I anybody has an idea…

Edit: issue created on GitHub, probably more handy :wink:

Edit 14/01/19 : Fixed