2host - a DIY USBMIDI host-to-host adapter

Hey thanks! And sorry - was dumb settings mistake on my end. Enjoy the traveling :slight_smile:

Hey! I am trying to use this as a substitute for the Sevilla Soft device, but I am having trouble with getting it connected. It works perfectly with the Sevilla Soft, but I am trying to put it on multiple devices and need an alternative.

The project I am using it with is the LED Piano Visualizer by onlaj and the program Synthesia.

Is there a way to make this product work with Synthesia? When I connect, the device is recognized as QT-2host in the Synthesia settings, but it doesn’t recognize any input. Maybe I’m wiring it wrong? I tried soldering the ground pinout and the RX-TX of each QTPy.

Hardware/Software info:
MacOS 12.6
QTPY rp2040

LED Visualizer:
raspbery pi zero 2
mio iconnect midi-usb interface

Note: I am using data cables, not USB power cables.

I should also mention that I did not have much success flashing the firmware uf2 file to the board, so I just uploaded the ino file from the Arduino IDE.

Any help is greatly appreciated! Thanks!

1 Like

I’ve not tested with the QTPy RP2040. Might need to be some code adjustments. The existing UF2 def won’t work since that’s for the samd21.

I’ll try to test over the weekend

thats a cool project :thinking:

Thank you! If I am able to get this up and running, I can share the whole project with you. I made this project for the school I work for and put it on 8 keyboards in our piano lab. The only issue has been connecting the RPI and PC via MIDI USB-USB.

Ok - i think i got it figured out. Best I can tell, the QTPy RP2040 has the default UART pins on Serial2 not Serial1 so the setup was incorrect.

Give this UF2 a try. This is working for me between 2 computers with QT RP2040s on the 2host

qt_2host_firmware_rp2040.ino.uf2 (154 KB)



is the hardware BOM the same between the QT version and the teensy version? I managed to accidentally knock off one of the (diodes?) from the back of the board and need to get a replacement and solder it on.

1n4148 - package SOD-123

arrow/marker is obscured by the via there, but the arrow points to the outside of the board. (so the cathode is the outer edge pad)

1 Like

Hijacking this thread a little bit, but figured this is where folks with experience in this area might be…

I’ve got Norns (Fates actually) and Ableton (on Mac) communicating via MIDI with Sevilla Soft’s MIDI USB-USB and it’s working but every 20-30 seconds or so Ableton freezes up and I get a pinwheel for 10-20 seconds and then everything returns to normal. Bitwig does not have this issue, so it seems to be an Ableton thing. Just wondering if anyone’s ever experienced similar behavior with any other MIDI devices or if anyone has any ideas about how best to troubleshoot.

sounds like a MIDI feedback loop.

MIDI Out is disabled on Norns and even when I uncheck every single track / sync / remote option in Ableton MIDI settings it’s still occurring. EDIT: Also, no lights on the MIDI USB-USB and nothing in MIDI Monitor app.

Sounds like a Sevilla Soft support question?

Do you have 2 regular computers to test between? (so you could run Midi Montior on both).

Sevilla Soft’s full response…

Hello, I’m sorry I can’t help you in this matter. It’s obviously an Ableton problem.

Strangely, it seems to have stopped (for now). If it starts up again, I’ll hook up a second computer and see how that goes.

Hey there! Still using the same design? Might be trying to have someone print this for me :slight_smile:

Hello there, newbie here !
I’m trying to connect my shield to an Akai mpc one to send MIDI out from the shield to the mpc. I tried with usb to usb (no success) also with cheap MIDI to usb (no success).
So I have a couple of questions here.
Mpc is also a host and not a device correct ?
Could be 2 host a good option for this case?
Mpc one has Ethernet and cv , maybe I can take advantage of this to communicate with the shield.
I’m testing with awake

MPC has two types of usb port, so it can be used as both a device and host.

Usb A, the slot, would be the MPC as host.

Usb B, the square, would be MPC as device.

If you’re having issues with either:

  1. Plugging in the usb A ports on norns into the usb B port on the MPC.
  2. Plugging the MPC midi ports into the midi usb cable plugged into norns.

Then there might be issues with either device or your cables as both of these modes should work.

Getting a 2host might help and it’s certainly a super useful piece of kit in general.

The CV doesn’t help, Ethernet might open up the possibility of Ableton Link for tempo sync and transport controls.


Thanks for the clear explanation, the problem was the cheap usb to midi cable.
I bought a Roland usb to midi um one mk2 today and now everything works flawlessly :grinning:.
Tested awake sending midi out to mpc one and it works.

1 Like