Ableton link and norns question

Hi,

I’ve been away from any Norns scripting for a while and just getting familiar with the new clock system. It’s pretty awesome, so thanks to everyone that worked on it!

I’m working on a script that outputs MIDI into Ableton Live 11, synced with Live’s tempo. All working as expected, except I ran into one problem and I haven’t been able to find reference to it or solve it myself.

When I run the script and start Live’s transport, norns uses the default tempo in Params and not Live’s tempo. If I nudge Live’s tempo any amount, Norns picks that up and adjusts it’s tempo to match Live. But I don’t want to have to do that every time.

Is there a way to query the tempo from the external source? Is there something I can put in my init() that will check what Live’s tempo is before I start the transport?

Thanks!

I believe if you go to Params and set the CLOCK>source to use Link, then norns will start “advertising” and should pick up changes in Abletons tempo.

What version of Live are you using? I believe the Transport start/stop stuff only works in 10 or later.

Wait… maybe I was misunderstanding your question…

FWIW - I tested just now on shield and confirming your behavior:

  • set params CLOCK>source to to link
  • Clicked Link button in Live
  • Live picks up norns tempo first
  • but then if I change the Live tempo, norns shows the new tempo at Params>CLOCK>tempo

But then if I change the norns tempo, norns seems to take over.

So perhaps the solution is to do something in your init() to set the tempo to nudge it back to norns?

Thanks for taking a look at this.

When I’ve used Link before, as soon as the connection is made the two devices automatically sync tempos, although I’m unclear on which one of tempo is the one they sync to. With norns and Live, they don’t seem to sync tempos until one of the tempos is adjusted after the connection is enabled.

Not a big deal, but I think I was expecting them to sync tempos automatically. I’d prefer to have Live be the primary tempo, so nudging the tempo in init() won’t solve this issue for me.

I’m using Ableton 11.

1 Like

fwiw, i’m definitely having less Link success with Live 11 than Live 10. on my side, it seems that Live 11 won’t always register that another Link device is on the network until a tempo change occurs. sometimes it works, though. if you’re testing Live 11, it might be worthwhile to check if this is the case with other Link-enabled apps and maybe report to Ableton.

when Link works (which seems to be more often with Live 10), Live always looks to norns for a cue on tempo.

are you connecting your computer to norns via norns-hosted hotspot? or just over your regular network? do you have the same levels of success between the two?

Thanks Dan.

I still have Live 10, so I’ll check to see if there is a difference. I did check a couple of Link iOS apps with Live 11 and didn’t notice anything unusual.

I’m connecting via wi-fi, but I can also check if I see a difference when connected via hotspot.

Hopefully this is the right place (found this thread searching Ableton + norns). Getting acclimated with norns and working through the docs and I can’t get MIDI out from norns working in Ableton (I’m still in Live 10 FWIW)

  1. I’ve got USB port 1 on norns going USB-MIDI out into Midisport 2x2 MIDI IN A

  2. norns output is set to audio + midi on MIDI out device 1, channel 1

  3. in SYSTEM > DEVICES > MIDI I’ve got USB Midi on 1

  1. Then Midisport MIDI OUT runs to my Focusrite rack MIDI IN into Ableton

I know Midisport’s working because one of my synth’s going into 2x2 MIDI IN B, and Ableton’s getting that MIDI via the Focusrite, but Ableton’s not detecting MIDI from norns.

For folks who have this working in Ableton, is there a norns step or config I’m missing?

thanks

I don’t believe you can do that because Norns is a midi host and so is your computer. I believe you need a midi host-host cable (like Sevilla Soft) to send midi from norns directly to Ableton.

Also see this thread

Which scripts are you using? The level of MIDI support is entirely dependent on the script.

I routinely send MIDI from norns to Live via a setup nearly identical to what you are describing so I’d expect it to work.

When you selected the Midisport in the norns device menu does it give you two options? One entry for the first port and one entry for the second port? If not, have you tried switching which port A/B that the MIDI cable is plugged into?

MIDI devices on norns are identified by name internally in parts of the norns code base. Many devices with multiple ports will present unique names for each port but in your picture it just says “USB Midi”.

Sending MIDI using traditional MIDI DIN interfaces as the OP is doing is fine. The only time using the Sevilla Soft adaptor or iConnectivity mio2 is required is when trying to avoid using MIDI DIN cables entirely and trying to connect two USB Hosts exclusively using USB cables.

norns doesn’t give me any options or port clarity just “USB Midi,” but your hypothesis was right for whatever reason norns will only send to 2x2 MIDI port B (and I was using A). my synth can go into A or B but norns only sends to B. thanks for helping me work through this.