Accessing cm3 that was used in norns, but now on i/o board

so i had a norns, replaced the cm3 for a cm3+, was enjoying it, but ended up selling it for financial reasons. now i’m trying to put the cm3 to use using an i/o board i picked up, but i’m totally unable to get my cm3 to respond to rpiboot, just getting the dreaded:

Waiting for BCM2835/6/7/2711...

i’m following this guide:

https://www.raspberrypi.org/documentation/hardware/computemodule/cm-emmc-flashing.md

i’m also powering it using this:

https://www.amazon.com/gp/product/B00MARDJZ4/

the i/o board i’m using is this:

again, just trying to mount it so that i can flash it and then figure out what i want to do next (e.g. install another flavor of a rpi distro, etc).

i’ve tried a number of different usb cables, tried it on a macbook air with catalina, and a manjaro linux box with the same deal on all.

any ideas?

there’s typically a switch to change into USB disk mode, so my suggestion is to contact the people who made the circuit, as it’s pretty specialized.

the emmc guide you linked is for the rpi designed io board.

1 Like

awesome, that was it…io board didn’t come with a jumper, so didn’t realized i needed to do that. couldn’t find any info on how to do it, but played around and got it working.

Hello, I’m exactly in the same situation (want to use my spare CM3 after a update of norns), with the same io board! Could you tell me what did you do?? Close to the USB2 socket there is 1.2.3 pin and i have a jumper that i put in 1.2 only > for USB boot. Same problem i have the “Waiting for BCM2835/6/7/2711…”. But nothing.
Thank you!

put it on 2.3, the docs that i provided above are for a different io board.

sadly, you can’t boot from the sd card. i went ahead and just ordered a CM3+L since i wanted more internal storage than just 4gb.

i’m gonna order another case/io board down the line and use the CM3 for a pihole (or something).

let me know if you have any other questions, i might be able to help.