Aleph-Comm ( funny ftp'fail from linux ) + twisted python OSC advisory

So I was testing Aleph-Comm…

The funniest thing happened… snort and tripwire became aware of tty0-6 and ttyv0-6 being used just before an ftp event.

I got very interesting mixed bus signals and screen havoc…

I have a weird daemon_init, but it would be funny for a mini concert or something.

Oh yeah! the twisted python seems to be a security concern on my systems that I am testing…
So far debian 8, lubuntu, freeBSD, etc…

What do you all prefer if you want to answer?

hummm - so when you say ‘Aleph-Comm’, what is your setup? Wasn’t clear from your other post whether you did manage to get hold of an aleph or not… Have you tried testing the existing aleph host software? Seems that the problems you are encountering are with a python framework providing OSC functionality? I like the low fat option - i.e oscsend / oscdump unix shell utlities! Although these tools don’t play super-nice with unix pipes, which is annoying. Planning to organise/release some of my hacks on top of this lisp OSC library

An obvious weekend hack is modify existing blackfin-module-loader C code to expose aleph params over OSC - this is definitely on my radar!

**EDIT: **sorry for not answering your question. I was using Debian 8 the first time, built up from core…Then thee notorious Ubuntu…and even Scientific Linux. I tried to virtualize freeBSD to contain it to no avail, and been retrying manual discs I know are not Amnesiac versions. So now after selling some stuff for Rent, and a Korg Poly 800 w/ moog mod - I can sress less and see if anyone wants to buy/trade up that synth if its not much my thing…I need a hardware Aleph ****

Dude its insane…
txOSC for python was my first bad/funny - I had to reinstall my system because of autossh like behavior…

Essentially I went on a Synaptic frenzy getting Csound stuff, and did the proverbial : check, check, check > on everything that seemed cool, without securing what I was working with.

Im trying to find the module, but it was able to alias the ttyv0 as USB-MODEM over rfcomm —> wlan0 as a wired connect split over the RGB.txt and GIMP simultaniously…kind of beautiful…, but annoying as how even re0 gets switched on with a fresh freeBSD…(also my last verified 10.1 defaulted to Amnesiac… I dont know if its their servers, but my STDOUT will be interesting for awhile)

Perhaps gcc with my wildcard and txOSC in the code?

I will be careful with this one:

python module :

Transport Type: UDP/TCP/None
Transport Independent
Platform: Any / Platform IndependentFeatures:
Packet Parsing (Client)Packet Construction (Server)
Bundle SupportTimetag SupportWildcard Matching Support

Bundle Support: Reads BundlesCreates BundlesSupports Nested BundlesTimetag Support: Generates “IMMEDATE” timestamp

The MD5 hash provided with files on PyPI exists only to provide some download corruption protection. It is not intended to provide any sort of security regarding tampering. Please use GPG signing for that.