Aleph not switching between scenes?

Anyone encounter a problem when switching scenes where you are unable to load a new one after clearing out the current one? Was using a simple synth made in waves and then wanted to switch to play with a scene in lines but was unable to load it… Tried clearing scene again and loading lines first but no luck. Then decided to see if holding down mode button while restarting would fix problem but still no luck. Currently will load my created scene for waves but not others like “this” and dosent load scenes from lines. Any thoughts ? @tehn @zebra

What version of Bees are you running? I used to have problems like this but it got cleared up in one of the updates.

7.1
Other thing I didn’t mention is that it’s creating new scenes at times with odd names. Curious if this to was a symptom for you ?

can you be more specific about what happens when it fails to load a scene?

also check the usual things: try formatting your sdcard and making sure it is populated with the whole directory structure from the release .zip

i’m also having a hard time visualizing the unexpected scene creation issue. maybe this is a case of filesystem corruption.

yes the on the scenes failing to load just gave went thru the fallowing.
on start plays last scene loaded called “ssyn”
switch to edit mode and cleared scene and tried loading " this" scene but didnt load / produce arpeggiator.
tried again by clearing scene and loading waves, waves produced 2 tones a fifth then tried to load " this " again but still no luck. went back to scenes page cleared loaded lines and then tried "space " with a keyboard plugged in and only received unaffected signal. Encountered this with an older version of bees but now that you mention it could be filesystem corruption possible that my sdcard is faulty perhaps ? as its happening on
different versions of bees ? And when I checked the whole directory structure was present. I believe I saw a thread about formatting new cards. Curious if you think the physical card is the case

also in this pic the last 2 scenes I didnt create and appeared on new upon start up

what i am after is, can you please tell me what (if anything) the screen displays when you switch scenes.

like, it should first say “reading…” on the top line, and then “loading dsp module” and some other stuff. does anything change on the screen? is it stlil responsive or is it frozen? etc.

what you’re doing with clearing the current scene and/or manually loading a new DSP module is not particularly recommended. it shouldn’t hurt but i can pretty much guarantee that it won’t help.

as for “ssyn”, “tsyn” and “rsyn”, it really looks like you saved the scene several times while scrubbing the first character of the scene name. this is pretty easy to do and the UI is kind of confusing. when you hit “store” from the SCENES menu it doesn’t overwrite the selected scene, it creates a .scn file with the current scene name, overwriting if it already exists. you can view/edit the current scene name by scrolling with the lower left and upper left encoders from the SCENES page.

i’m even suspicious that you may have overwritten “this.scn” and “space.scn” ? i dunno. it’s easy for this to happen: load “this”, change something, and hit “STORE” on the scenes page, and you have overwritten “this.scn” regardless of the selection.

if you can’t get any scenes based on “lines” to work as expected then i woul dbe suspicious of that module. in particular it needs to be a recent version of lines.ldr to work with recent versions of bees. i accidentally posted the bees-0.7.0 and bees-0.7.1 release archives with the wrong version of lines, but have corrected them since, so try downloading again.

i highly recommend backing up whatever you want to save from your sdcard, reformatting it to FAT32, copying the full directory structure from the release .zip, and starting over.

ah ok yes " writing scene to card… " when switching between scenes. ok I will give reformatting a shot

Ok and downloaded new version of bees. On start up it loaded up a drum beat. Went to edit screen and cleared current scene and then tried to load up “this” scene. No sound in or info displayed in play mode. Switch back to edit mode and this scene now showed. Didn’t have it on for more then a minute or so pretty sure I didn’t over right or mistakenly add a scene… Perhaps I should go get a new sd card ?