Aleph prgm and iPhone prgm


#21

@instantjuggler thanks for testing it out! sample import needs some work to make sense, suggested work around goes like this;
export/bounce to mono 32bit 48k .wav format (or 16/96k…)
convert the .wav with ffmpeg like this,
./ffmpeg -i INPUT.wav -f s32be -acodec pcm_s32be OUTPUT.anything
copy to folder ALEPH/data/samples

@bkinsman if thought of as an 8 track mixer with one mix group and two mono aux sends, this version makes more sense than previous ones, up until now the (prgm) ui was mostly puzzling…

@glia please do, hoping to get some input to make it better!

@ether thanks!


#22

Added some updates that were urgent for my own work:

  • global sample editor (start & loop points), only applies to pattern changes made after changing these parameters
  • more amp shapes; expodec, Rexpodec and tri, there is a gauss shape too in the ui but it doesn’t work yet(!)
  • loop mode now has pitch
  • added: tape mode with variable pitch and reverse, 4 point/3rd order interpolation, added a demo vid:
    https://vimeo.com/128515344
    note, this post is edited as things comes alive.

#23

documenting how i set mine up this morning

still no trig

_ redacted _


#24

thanks for the vid! your settings on track 1 (sequencer and mix) looks OK. What I can see there is one sample on the first step so if you are sending in a 16th note clock in 120 bpm it will take about 16 seconds for that pattern to loop and the vid is 19 so… you could try a higher mix send level than 6080 on track 1 and double check the level on the master fader. try testing with another cable(!), they do tend to break from time to time! if that does not do the trick I would be really interested in a audio sample of the trig you are sending, could it be that it’s an S-trig?!?


#25
  1. i will check the mix & master level to make sure those are high enough
  2. also will check the bpm or rate of the trig
  3. i’ve used various cables so I doubt that is the issue in this case

most likely there is something in the settings that I have neglected to set…I will keep tinkering with this and will also try the tape mode because it doesn’t seem to require an external trigger


#26

I really hope you get it to work and let me know if there is something I can do to help!

ps. there are some bugs on the avr32 side for the tape mode parameters that I found today, in the meantime It should work fine on track 1 though as shown in the demo vid!


#27

I hope so too!

every feature you add makes this instrument more appealing & you have been very helpful while trying to troubleshoot the issues I’m having

i’ll try again tonight


#28

tape mode bugs fixed and uploaded!


#29

trig is still not acting right but i don’t care after testing tape mode

it is absolutely AMAZING
i’m intertwining the delays and it sounds so good

gonna memorize the controls and record some stuff with this app


one request @Test2, if the tape on/off button (SW3) could be momentary that would make the mode even more awesome

momentary footswitch control of mutes would also be nice


any suggestion (aside from ffmpeg) to encode pcm_s32be files? my laptop is running an old version of OSX and ffmpeg is not working for some reason

i will upgrade if i have to but i feel like there must be a solution floating somewhere on the internet


#30

maybe you haven’t already checked, there could be something here, I’m on 10.6: http://ffmpegmac.net

I like this idea! if possible I will try to add more tape recorder feel like this, and maybe stop/start speed lags, scrub etc. the encoder response for the speed control needs some fine tuning as well.

mute is possible with sw4 but that would easy to add as a foot switch too, will add that on the to-do list.


#31

yeah i know SW4 does mutes

very playable…any future FS implementation would add a different layer of depth to performing & improvising if i wanted to use my hands on another instrument

btw found a tutorial on youtube + with your suggestions got ffmpeg to work!
just recorded a bit as a test https://soundcloud.com/glia/524up

thanks


#32

@bugaev_

try this and see if you can get the sequencer working…i’ll probably use it for the samples you sent


#33

been using this app extensively for new work…the UI feels more & more comfortable

i really find it perfect for improvised mixing

now i’m itching to figure out the sequencer again
has anybody managed to test it?


#34

just a thought, have you got cv input 1 to work with any bees scenes? it would help if that could be ruled out.


#35

i’ll try checking

if you have any suggestions on the simplest way to test in bees i’m all ears


#36

quickest is probably connect the CV operator to a BIGNUM operator and see what it reads


#37

prgm 0.1.1

(see first post for latest version!)

new stuff:

  • new structure: 8x channels, 2x groups, 1x aux, 1x MIX
  • solo/mute on tracks outputs
  • on-the-fly mute-group for channels sends, w. set/swap/reset
  • mute/solo click-free audio switching (BETA)
  • aux send pre/off/post fader
  • tape mode cue (sync/reset to clock in)

0.1.1 controls:

I/O
outputs1-2 : MIX BUSS output
outputs3-4 : DIRECT outputs
inputs1-2 : MIX CHANNEL inputs
input3-4 : EXTERNAL inputs (stereo)
cv-in1 : Clock input

MIX CHANNEL
encoder1 : AUX send
sw1 + encoder1 : AUX pre | mute | post

encoder2 : MIX | Group send
sw1 + encoder2 : MIX | Group A | Group B

encoder3 : DSP parameter a
sw1 + encoder3 : DSP parameter b
sw2 + encoder3 : DSP parameter c
sw3 : DSP switched parameter

encoder4 : channel scroll
sw1 + encoder4 : DSP mode
sw2 + encoder4 : channel input source

sw4 : MIX mute prepare
mode : flip channel | track

MIX BUSS
encoder1 : Group A level
encoder3 : Group B level
encoder2 : MIX level

sw1 + encoder1 : Direct out 3
sw1 + encoder3 : Direct out 4

sw2 : Sample trim
sw3 : Restart all tracks on step 1
sw4 : MIX mute set | swap
mode + sw4 : MIX mute reset

SEQUENCER TRACK
encoder1 : step trig | sample
encoder2 : step parameter
encoder3 : step scroll
encoder4 : track scroll

sw1 +
encoder3 : track length
encoder4 : shift step +/-

sw2 +
encoder3 : measure
encoder4 : clone step (by measure)

sw3 : track solo (mode led on/off)
sw4 : track mute
mode : flip channel | track

SAMPLE TRIM
encoder1 : start offset
encoder2 : loop offset
encoder3 : sample select

sw2 : exit

enjoy! :sound: :loud_sound: :speaker:


#38

seriously
you are amazing @Test2

HUGE


#39

This reads incredible.
Stuff like this could make me buy an Aleph again.
Looking forward to see / hear some demos of this thing.


#40

@glia @myecholalia thx :smile:

this hackathon is just about to finish… found some bugs, those got fixed and an internal clock mode (CLK) got thrown in last minute(!)

0.1.2 yey!

(see first post for latest version!)