Aleph release zip 0.7.1 cannot load scenes

I copied the contents of the zip file for version 0.7.1 on the releases page to the SD card. The powered on unit will not enter play mode, gets stuck playing a sinewave and the mode button is not functional.

Powering on while holding SW3 shows a “clean init” message and play mode is enabled with an empty scene. Changing modes and selecting the tutorial scene named “this” crashes the unit at “reading scene from flash” and all buttons, including the power switch are not functional. I have to unplug the AC adapter to reset.

The version on the SD card when I got the unit has files dated from 2014, which I backed up. Those files produce a functional tutorial scene for “this”.

you have to flash the 0.7.1 firmware if you haven’t done so

hold down the mode button while booting to access the firmware select page

you might also try the skektek branch, which has tons of features, optimizations and bugfixes

(i’m in the (slow sporadic) process of merging this with upstream… currently stuck on patch ~50 of ~150…)

thanks for the PR! nice to know it works with docker

The firmware loading mode worked. Now when the unit boots, but is stuck between two crash points on the screen

  1. “initializing gfx”. I hear a faint PWM sounding hum from the headphones
  2. The default tutorial “this” scene loads, play mod is entered but the headphones are silent. Moving a know emits a single PWM sounding pitch. When I move controllers, it sounds like the duty cycle is changing

hm…

well just to be sure i did a fresh install of the 0.7.1 release file on two units (proto and production.) was fine on both - to be expected since i’ve done that many times. (and my god, 0.7.1 is almost two years old now.)


i’m a little unclear:

  • failure state 1) is a crash. hard crash (power button stops working)?
  • failure state 2) is or is not a crash? sounds like unit remains responsive but bfin is running in an unprogrammed state.

i think both could be consistent with trying to load wrong versions of the DSP firmwares (.ldrs in /mod.)

dumb questions:

  • are you sure the sdcard was completely erased and then the entire contents of the .zip were copied?

  • do you have any devices connected to USB during boot?

  • can you try skektek’s build? (maybe you are encountering some timing-sensitive bug that has been fixed since 2015.)

oh, also you might want to try loading the aleph-mix-0.0.0.hex firmware; it is an extremely simple application that embeds the .ldr and doesn’t require the sdcard after flashing.

1 Like

The SD card was not completely erased.

Muah wah.

I was doing drag and drop copying of individual folders. I’m normally not this much of a noob. I just compiled the skektek branch though I’m not sure how to properly deploy the build artifacts.

have a look at the zip file I posted - it’s a pre-compiled binary version with the build artefacts correctly deployed, correct directory structure etc.

From memory, the build commands you’ll need are:

BEES:
make clean; make R=1;

module (e.g waves, lines):
make clean; make deploy;

1 Like

Woo hoo! Works first try. Thanks for all the help with my plumbing questions. I think I know enough now to post lower level questions as either Github issues or pull requests.

P.S. The ./install.sh script helped me understand the structure of the SD card pretty well. When I get some focused time I can get to some of the TODOs in that script. Seems like it would help new developers get up to speed.

1 Like

I lost the SD card referenced in this thread and I’ve reproduced the procedure I used last October. I cannot load any firmware.

I’ve formated a 32GB SD card with one partition as FAT32. The device recognized it but the bootloader menu shows no options to load any firmware. There are also no modules in that menu.

I’ve loaded the 0.7.1 release, the sketek branch and a compiled version of the git master branch from a few weeks ago.

None show any firmware when I hold the mode button.

:frowning:

i’m sorry but the only thing is to try a different card. if you can find one that is <4gb these tend to be more reliable with the pdca controller on the avr32

Holy shit! Wow yeah. I found a 16GB card and it just works. I know there’s a difference between the 32GB and 64GB media types but this threw me for a loop. Monome could sell obsolete capacity SD cards at a good markup :slight_smile:

For the record, here’s my scientific results. I tried four SD cards.

Failed cards

  1. 32GB Lexar Professional SDHC class 10
  2. 16GB Patriot micro SDHC class 10
  3. 64GB SanDisk Ultra micro SDXC class 10

Successful card

  1. 16GB SanDisk Ultra SDHC class 6

Here’s some pictures of the markings on the cards

The winner

The losers

2 Likes