Aleph - unable to acces bootloader

for the first time i wanted to input cv signals into the aleph. i had inconsistent results : sometimes i could read from dac0 and dac4, sometimes only from dac0 or dac4, and never from dac2 and 3. i thought something went wrong with the dsp processor. i tried to reboot and this is what happened, quoting @instantjuggler from this thread

my sd card suddenly became corrupt.

and

for whatever reason my SD literally fell apart, as in the plastic abandoned ship and started to peel and flake off in layers on the end that gets inserted!!?!? it was the card which shipped with the unit, and i never had problems with it before. no idea why in the world it would have done that, have never seen that before.

now i’m stuck : i’m not able to launch the bootloader when i power up the unit.
(since i couldn’t see the application, i thought the sd card was corrupted, but i’ve tried 5 different cards, 2 different readers, and copying or reformating 100 times at least. each time very carefully, as described here : http://www.monome.org/docs/aleph/updates/).

if i launch the aleph while holding down the mode switch, the screen looks like this :

i can use encoder 2, and get this :

the switches and the other encoder doesn’t work.

if i launch the aleph to load a scene, the screen is black and after using the mode switch, it looks like this :

and i can navigate with encoders 2 and 3 :





there’s also a grey line in the screen (which is not there when the screen is black after powering up the unit) :

i tried to launch the prgm app, but it didn’t work. i get the same screens.

i absolutely don’t know what to do now. (this is OSX 10.10.5).
thank you for your help.

it seems like the sd card is corrupted, despite the fact that you’ve tried many.

not being able to execute the bootloader seems weird, like the switch isn’t being read.

i can’t explain any of this, so if you’d like to send it in i an take a look. e-mail info@monome.org

sent.
i really appreciate, thanks.

For the record… those screens are exactly what I’d expect from running the bootloader with no sdcard inserted at power-up.

The grey line is meant to highlight the selection, but there is nothing to select.

To be clear, SD card needs to be inserted before powering up, it won’t be detected later, and it shouldn’t be removed. I don’t see an sdcard in these pictures at all…

Also, dac0 etc al. aren’t related to CV. the adc_dac module parameters control audio routing. CV output is controlled by the module params cv0, cv1, &c., and CV input is handled by the CV-IN operator in bees.

Apologies if this is already clear to you. I’m slightly unclear on what you were doing - e.g. there is nothing called dac4 that I’m aware of, and I don’t know how you were trying to read a value from a DAC - which isn’t a sensible thing to do in general.

if i don’t insert an sd card, i can see a message : ‘waiting for sd card’ repeating and covering all the screen.
if i don’t insert an sd card and hold swich mode while powering up, i see : ‘no sd card found’ /n ‘resetting…’

i think it’s because of the angle. it’s confusing but i can reassure you : there is an sd card. i put it before powering up.


regarding cv input : it’s my mistake. i’m sorry i brought another layer of confusion here.
i was trying to read a value from the CV-IN operators. i was not trying to control audio routings.

Gotcha, my mistake. So yes, somehow it is not getting any data / parsing the filesystem…

to triple check, and before sending the aleph, avoiding waste of time, etc., i bought another card reader a few minutes ago.
i’ll report back.

quite possibly the card detect pin is working, but the SD slot component has a broken solder on one of the data lines. this was the first thing i was planning to check.

it does not work.
@tehn : it looks like you’ll be able to check your intuition :wink:

(i’ve edited the title as i mistakenly assume it’s a bootloader issue. we’ll see…)

for the record
yes indeed : it was the sd card

i’ve sent the aleph with two cards, (a panasonic and a lexar) out of the five i tried, to tehn. they didn’t work. but he randomly grab a sd card he had. and it worked ! (now i know that in case of trouble, there’s a card waiting somewhere. always.)
it’s worth mentioning that tehn sent me back the aleph with his working sd card (a sanDisk micro sd if it can help) without charging on repair because, i quote : ‘it wasn’t a real repair’.