Aleph update - bees 0.6.2

updated software for the aleph is available on the releases page:

details on updating can be found here:
http://archive.monome.org/docs/aleph:updates

this release addresses three problems which came up after the bees-0.6.1 release:

  • parameter defaults weren’t getting set correctly when loading lines 0.2.2+ into a clear scene
  • dsp modules would be reloaded from the sd card (even if the module was already loaded).
  • slewing of svf parameters in lines

the dsp modules included with this release have a minor internal change related to the module reload behavior but they are otherwise functionally identical to the previous releases.

7 Likes

Do we need to rebuild our scenes? I just tried to update and my scenes from 0.6.0 seemed broken. Wont have time to properly figure out what’s going on for a few weeks (immediately switched back), but it seemed like delay1 wasn’t working at all in lines.

I would expect a scene built with any of the bees 0.6+ releases and aleph-lines-0.2.1 or earlier to work as is.

If the scene was built from scratch with lines-0.2.2+ then it is likely that the parameter defaults are all set incorrectly (either random values or zero). In that case one will have to manually set all the parameters to reasonable values or rebuild the scene.

I’m hard pressed to think of a reason why the second delay line would have stopped working in the last release. The only change in lines-0.2.2 was to uncomment the single line which clears the buffers. The only change in lines-0.2.3 was changing the name compiled into the DSP code from “aleph-lines” to just “lines” so that it matched the file name (lines.ldr).

been doing some more testing and still having a problem with the filters -
if i try this new build and start a scene from scratch I still can’t get the lo- pass filter to work on del0 (i.e. no sound seems to be passed through it) -
but if I then replace lines-0.2.2 with the aleph-lines ldr and dsc files from the 141106 release and load the same scene the filters work.
hope this helps track the bug :smile:

1 Like

This must be it! my scene was only outputting from the lpf…

Yes that does help. I think I found an old commit which might have changed the lpf behavior - it doesn’t look like it was intentional. I’m going to partly revert that change and build a new version of lines for you to try.

this is LPF mode of state variable filter?
@ngwese can you point out the commit in question? maybe i can help, as the mistake is surely mine in the first place.

oh yeah, that would do it all right.

Just opened a pull request for you to review. The commit in question is referenced in the git comment. It was a simple fix.

Okay - here is the complete fix.

speaking about filters : notch doesn’t work (waves module, i didn’t check lines). is it intended ?
edit :
thanks for the update

hm yes, notch mode is disabled in waves. waves uses its own SVF implementation, in which you only hear one mode at a time:
[ https://github.com/tehn/aleph/blob/dev/modules/waves/svf_waves.c#L38 ]

the notch mode just didn’t seem very useful so i elimintated the few operations it required to calculate. very easy to add it back if you like: uncomment the line above and change line 104 to
f->mode = &(f->low) + (mode & 4); (ugly hack i know)

in lines, the “full” version of the SVF is used: all modes can be arbitrarily blended, including the notch:
[ https://github.com/tehn/aleph/blob/dev/dsp/filter_svf.c#L46 ]

thanks for your answers
i guess enabling notch mode could be a good way to learn how to compile

(i was thinking about using notch mode in combination with bandpass mode, one for each osc)

shoot that’s a typo above, should be mode % 4

ok
thank you for the heads-up