ALEPH user STUDY GROUP


#208

It’s actually a port of the the alternative whitewhale module firmware https://github.com/monome/kria - so there are some major differences from the ansible kria. tehn’s instructions here I think are consistent with the aleph module features Kria 0.3 initial release.

As an aside, I want to look the ansible kria for a puredata version - from what I gather it seems there were some pretty significant advances for melodic sequencing. It might be even bigger (in terms of code size) than the WW alt firmware, which would make it unsuitable for BEES imo.

Also @Yann_Coppier & I worked a bit on a word doc documenting the updates - we should dump that into plain text & put it in the repo soon…

EDIT:
darn, I was trying not to clutter this thread with dev chatter…


#210

Dont feel bad at all, i’m glad this convo is happening


#211

look - a study! I won’t post the patch (yet) because it’s sitting on top of new/scene-breaking changes to BEES/lines… I want to think really hard about whether it’s possible to do do tap-timing as well as I can on my feature branch (https://github.com/boqs/aleph/tree/lines_timebase) without breaking all ye olde lines scenes…

The patch is basically a taptempo-captured casio loop (no encoder-bothering to set loop start/end points) & a single kria (2 channels) doing some variant on what ezra described above. It uses presets quite a bit for the looper functionality… Source material is like 30 secs of SK1’s stock demo rhythm - kria’s clocked @ 1/128 of the entire capture using a new ckdiv (clock-dividing-metronome) operator


#212

yup.

that.

is.

the.

one.


#213

Another study, riffing on the same theme (SK1 vs aleph). This time I used some bends to generate the source material.
https://soundcloud.com/rick_monster/casiochop-number2
had to rebuild the patch - lines doesn’t appreciate being treated this way, so the chopping line will occasionally get ‘stuck’ in a state you can’t get it to make any noise & require reloading the module. Requires the changes I pull-requested to monome/dev (BEES & lines) in order to run… https://github.com/boqs/aleph/tree/lines_timebase

captcha.scn (256.1 KB) (noone try & run that patch it’s not gonna work)

managed to record something before it blew up on today’s third attempt!


#214

I have a couple other things on my schedule this weekend but I’ll get to installing your branch in the coming week.


#215

I’ve been enjoying using lines for the past couple weeks, doing long-delay guitar pieces has never gone quite so well.

What’s the current status of dsyn? I can’t get any sound out of it with the most recent dev branch. I keep hitting the gate input but I get no sound. When I go back to 0.7.1 release to verify I get sound when hitting the gate.


#216

@Andrew_Sblendorio do you have a really bleeding-edge dev branch? dsyn & acid got broken in efforts to fix CV out, but should be fixed on monome/dev since roughly a month ago…

I’m gonna set aside time today to really thoroughly test, then assuming no regressions are discovered we could finally release 0.8.0 (like today I think!)


#217

Yes 095a11f.

Looking forward to that CV output fix as well!


#218

with 095a1ff dsyn ‘works on my aleph’… I need to get into the patching headspace for some tests then I’ll post the build, just to rule out any issues there.

in the meanwhile the recipe I use is:

make clean; make; make deploy
(then copy .dsc, .ldr, .lab to sdcard/mod) not all modules have the .lab


#219

Yes! Your recipe led to a good outcome. Dsyn is now making noise.

I was following the directions on https://www.monome.org/docs/aleph/dev/

“To build a module, run ‘make deploy’ in e.g. aleph/modules/lines. This produces lines.ldr, a blackfin executable, as well as lines.dsc, the parameter descriptor file. ‘make’ alone just builds the .ldr, which is fine if you aren’t making changes to the parameter descriptors.”

I was not running make clean, and not doing the same order. Also I was not aware of the .lab files.

Another question: After running the make commands I got three versions of the .ldr files. For example with dsyn:
dsyn.ldr
dsyn-0.0.2.ldr
dsyn-0.1.0.ldr

Which one should I be using? What are the differences? I would guess 0.1.0 is newer than 0.0.2, so then do I use 0.1.0 or just dsyn.ldr?


#220

personally, I just use dsyn.ldr. And I think the original releases also followed this - so basically we ignore version tags for the modules…

In my opinion the whole thing of having different versions of different parts of aleph firmware on the same sdccard gets very messy/confusing very quickly, when everything is so inter-dependent!

Ah crap, I’m just so close to ready to release 0.8 firmware but again I’ll be travelling for a few days.
Just sent another pull to monome, with bugfixes to the December release candidate… Barring screw-ups, it’s finally ready I think!


#221

Thank you thank you thank you… etc
(heart pounding)


#222

Could anyone help me verify that the resonance envelopes are working as expected on dsyn?

When the resonance envelope is off, I’m getting what I am expecting when I set the parameters. If I turn resonance envelope on, there is an octave jump in the resonance frequency at the end of the decay stage of the amplitude envelope. Can anyone reproduce this?


#223

merged PR. i’m travelling again too, sans aleph, zero downtime


#224

I’m a total novice. Does someone know if there’s a way to make the builds on windows? I try building bees from the dev branch with GNUMake without succes.


#225

i’ll try and look at this in a couple days, and run stuff from latest PR while i’m at it

i’m sure its possible, but dunno if anyone here has tried (maybe @scanner_darkly at a guess?) highly recommend just setting up a tiny linux system instead (usb drive or VM or whatever), so you can just follow the instructions instead of blazing your own path through the weeds - quick search isnt turning up avr32-gcc for windows so would maybe have to build your own, &c… you see, gnu make is a (minimalist) build system, it manages dependencies and runs compilers, but it is not itself a compiler. you need a compiler that targets avr32 but runs on windows (even if its mingw or another gnu-like windows system.) then you need the same for blackfin (this does exist in some form but i wouldn’t count on its robustness.)

yes. you can use a versioned file or not. bees will first search for unversioned, then most recent versioned (iirc. maybe its just random) the tagged copy is made just so you have a history to revert to if needed. for your “convenience” as a developer. not really intended to be used on the sdcard


#227

Highly recommend docker with the Blackfin toolchain. I think docker runs on Windows but I haven’t tried.


#228

Thanks for your help @zebra @lazzarello. I wanted to try linux eventually so I’ll try that.


#229

i did successfully build bees before but that was a long time ago on my old work computer. but i just tried it on my windows laptop and i can build it using bash as per @sam’s instructions listed here: https://github.com/monome/libavr32#windows