Ancient arduinome + mlrv2 assistance


I have an arduinome I built years ago, and I just fired it up for the first time in ages in an attempt to get it working with mlrv2 but am having some difficulties and was hoping you might point me in the right direction.

Last time I ran things successfully my system state was as follows:

  • Older OS X version (I can’t remember which one, probably Leopard or Snow Leopard)
  • Max MSP 5 runtime
  • Arduinome running ArduinomeFirmware3_2
  • ArduinomeSerial0.2-osx
  • mlrv.27.11.9

Current setup:

  • OS X El Capitan 10.11.6
  • Max 7
  • Arduinome still running ArduinomeFirmware3_2
  • Still running ArduinomeSerial0.2-osx

As a baseline, I referred to an old copy of monome_base_4.4 from the last time things were working. I ran monome_test.mxb and everything worked fine (buttons lit up when pressed in toggle mode, light up when clicked in the Max app, etc.). Then I tried running mlrv2 with ArduinomeSerial0.2-osx (screenshot of config attached, I was only allowed to upload one image so I consolidated the screenshots). The issue I’m having is that when mlrv2 is running, none of the lights on my Arduinome light up. If I hit a button, in the Max Console I get a message of the form: “/o0: no such object”. No sound is made when pushing the buttons.

Since this wasn’t working, I tried going back to the Max MSP 5 runtime and running the setup I had last time it was all working (ArduinomeSerial0.2-osx and Max MSP 5 runtime running mlrv.27.11.9). In this configuration, the top right button on my arduinome flashes, and the speed of the flashes change in accordance with the tempo set in mlrv, but if I press any of the buttons on the arduinome I hear drum and piano sounds that seem to be coming from an audio unit synth of some kind. When I hit DAC and try to start playing samples in mlrv, the first button in the sample-affined row will light up, and the group button at the top left of my arduinome (for group #1) associated with the sample lights up, but the samples don’t play and the lights don’t march across the sample row left to right as they used to.

I looked around the forums here a bit but I’m not sure how to proceed. It looks like perhaps I need serialOSC installed now instead of ArduinomeSerial, is that the case? Do I need new firmware on the Arduinome as well? I have an Arduino Duemilanove.

Thanks in advance to the community for any assistance that can be offered.

Yeah, so… totally answered my own question. :slight_smile: Resolved as follows for others who might be in a similar dilemma:


mlrv 2.5 standalone
max 5 runtime