(ansible) 3.0.0 release

3.0.0 is now here, thanks to tireless contributions by @csboling

  • NEW: i2c leader mode for controlling Just Friends, TELEXo, or ER-301 from ansible
  • NEW: kria: playhead shows on probability page
  • FIX: avoid some types of i2c crashes
  • FIX: kria: glitches when stopping and restarting external clock
  • NEW: compensate-shift scales by holding scale key when changing scale notes
  • NEW: supports new kria teletype ops: KR.CUE, KR.DIR, KR.DUR

See the docs.

See the update procedure.

CAUTION: All presets will be erased. If you’d like to back up your presets, see this post

53 Likes

Is there more info on the i2c leader mode for controlling JF? I couldn’t find anything in the docs, or am I just looking in the wrong place?

amazing update! just to give a sense of the amount of work involved - green is the number of lines of code added, red is the number of lines removed:

image

and it’s not just coding - testing / responding to requests / following up on bugs / documenting - this is a huge effort. @csboling - thank you! :heart:

30 Likes

Should be in the docs now on the new “advanced” page: http://monome.org/docs/ansible/advanced/

1 Like


currently says it is for 2.0.0.

Is there a new doc coming for 3 or does the doc need updating?

Thanks to @tehn and @csboling and the rest of the wonderful crew for all you do!

I’m so looking forward to getting this installed soon…

Really exciting! Thanks for all the hard work

20 chars of “Sweet! Thank you!”

I’m having a hard time getting ansible to consistently (connect to?) sequence JF’s.

Can anyone who has a ansible<crow<JF’s setup verify this is working consistently for them?

Occasionally it works but after power cycle I have to do a bunch of plugging/unplugging grid/ ansible leader pad turned on/off combos, and throw a Norns in the mix to get it going again. I’ve run the ii.pullup and reset commands in druid as well.

Sometimes it works, most of the time it’s not. Norns is running Awake and it is sequencing JF’s as normal.

Edit: Is there a way for ansible leader mode to not automatically be on after power-cycling?

I updated the docs yesterday but missed this spot.

Will investigate this shortly. Are these 3 devices all you have on the bus?

1 Like

i had similar issues with polyES and orca’s heart in leader mode with crow on the same bus:

2 Likes

Correct, just the three on the bus. I do have two ansibles and have swapped them in the bus with the same results. Thank you for your time and efforts on the new firmware!

You have my gratitude for all of the effort you’ve put into ansible and teletype @csboling! Having played with much of this during beta, I can already say they are excellent and useful improvements!

3 Likes

No problems here getting JF to connect with crow also in the i2c chain. Only issue I’m having right now is getting the er301 to take. Anyone have any luck using lets say Kria with the er301?

**edit got it sorted. Wow this is so nice. It really really changes things for how I can sequence samples on the er-301

do tell :thinking: :slightly_smiling_face:

Hi,

So you are using the JF, Crow, ER-301 and Ansible chain without anything else in the chain like a powered bus board?

Thanks

My i2c chain has ansible, crow, tt, JF, w/, ER-301

I didn’t have any issues sending to JF or ER-301 from ansible.

1 Like

I think your tt is the reason why you are not having issues. Having the crow supply the pullup resistors in the chain is maybe the problem in this chain.

I’d be curious if you separate your TT from the chain what results you would have? I know fiddling with i2c wires isn’t fun so if you aren’t up for messing with it at all I totally understand.

1 Like

In my case also having Teletype connected makes everything work fine. When I have crow, W/, Ansible, and Just Friends on the bus, the procedure that seems so far to work consistently is:

  • make sure leader mode is disabled, then tap the preset key to exit the preset page and save leader mode settings to flash.
  • reset the case (I’m using a Tiptop Mantis)
  • now enable leader mode.

This seems to work every time, at least with my current I2C wiring (all three modules are on a single 3x2-pin ribbon cable). As opposed to @scanner_darkly’s experience with multipass apps linked above, I am able to toggle leader mode off and on in this case and it still works. I am even able to send ii commands from crow simultaneously.

If I have leader mode enabled when I power Ansible on, it’s not able to communicate. In some cases I can still get crow to talk to Just Friends if I mess with the jf.mode.

If I replace JF with TXo, I can’t get it to work. If I then add either or both modules to the bus and add Teletype, it works again. I’m not too sure what’s going on here but I’m certainly intrigued, for now I would say probably a powered busboard or Teletype is the best bet. Interested to hear if the procedure above works for others or there’s something case / bus specific about this behavior.

2 Likes

Hi @csboling,

Thanks for looking into this. I am not having luck so far and have run into a strange issue with crow. Every time I restart the case now the pullups are low. I am unsure how to get crow back to starting with them high. Here is a snapshot of what I’ve been seeing. It’s funny JF’s makes a little sound like it wants to go when ansible leader mode is selected but then nothing happens. I have ordered a mini powered bus board though and hopefully that cures all of this.

i did get a short sound too at some point, i think after executing jf.mode on crow.

interesting that it works with teletype - i’m going to do a test with teletype and a test with a busboard. will also try running multipass on teletype itself.

1 Like