Ansible bug reports (official)

ansible

#1

As per instructions from @tehn I’m starting this thread to hopefully make future posts and searches simpler. GitHub is best for the deveopers, but if you don’t do github, here is the place to post ansible bug reports.


PLEASE use github if you have an account:


#2

I’ll start.
Clocking Kria or Meadowphysics externally, the short press to access presets doesn’t work if the clock is paused. Restart the clock and it works. This may also be the case for reset. I’ll do more tests and edit this post later.


#3

Ansible Meadowphysics in 2 voice mode has been losing the scale and just playing a single note for all the beats. This never happens right away at power up but it has happened mid piece at least 3 times, which is worrying, as i’m hoping to perform this piece in May. The only solution I have found, this far is a power off and on hard reset.


#4

I have this problem too. Once its happened, when switching to Kria no pitch CV works there either. I had to work an OP 1 section into a recent set so that I could power cycle mid set if needed. I think I reported this elsewhere. Its lost now so thanks for starting the thread


#5

Do you know if you’re using the latest Ansible firmware or not? If not, maybe try updating?


#6

Would it be possible to add this to the first post? https://github.com/monome/ansible/issues
If people could file there issues there that would be even better than here :slight_smile:


#7

fixed, update coming


#8

i believe i’ve also fixed this now, but i don’t have a test setup. can someone please test the attached?

@lloydcole @yoyosandshoes

ansible-1.5.2.zip (83.0 KB)

(also pushed changes to github, will wait until confirmation for new posted release)


#9

I will update my ansibles and continue working. With this particular bug it is close to impossible to be 100% sure it is fixed, but I will report back, and be sure to let you know if it happens again. Now to figure out how to annotate (save on paper) my presets…


#10

just to present my theory-- in “voice” mode on MP if a bunch of voices trigger at once i suspect it was clogging the DAC-- trying to basically update 6 times at once if 6 notes hit at once. i limited this to only update the DAC properly for expected behavior. so a test would be to have all rows banging away at the same time, trying to sound notes at the same moment.


#11

That makes sense, and on the piece I was/am working on, which is generative, it was extremely unlikely that all 6 notes (there were only 6 of the 8 used) would trigger simultaneously, but definitely possible… so the longer such a piece played, the more likely for this to eventually happen. What we should have heard was a beautiful chord! :wink: Before I update I’ll do some tests at 4* tempo and see if I can make it happen again.


#12

The 4* tempo tests didn’t yield identical results but very similar, the piece ran from 5 to 6 minutes before stalling. I think it sounds like your assumption was valid.


#13

Initial testing suggests 1.52 has fixed these two bugs. I copied the same MP preset (close enough) to the newly updated ansible and it ran at 4* speed for 15 minutes without losing the scale. I was also able to save and reset while externally clocked. Many thanks!


#14

I’ll try and get to this over the next 24hrs and report back
EDIT: saw @lloydcole has responded. Thanks for the fix!!


#15

1.5.2 is released, same as above. minor bug fixes


#16

I’m clocking Kria from Teletype. When I go into Meta-sequencing mode, things go all cattywampus. I swear it was working previously. When not in meta mode, a single pattern will play and stay in sync. But switch to meta mode, and steps get skipped and things are quite jumbled. Similar behavior when not in Meta mode and I try to cue up a synced pattern change; also loses sync.

I have an otherwise blank Scene loaded, just KR.CLK in the M script.

edit: I installed 1.5.2 When you first go into KR.CLK mode, everything works as expected, it’s when you change the metronome settings that things go haywire. And changing M to whatever setting doesn’t bring back expected behavior, nor does a restart.


#17

Hmm… not sure I totally understand what’s happening here, but the meta-sequence is always clocked by whatever Kria’s main clock is. That could be the internal clock or a clock patched into the first input jack. Same thing goes for the pattern queueing system. KR.CLK will not advance anything in the meta-sequence so perhaps that is where things are getting jumbled.

When the meta-sequence advances to its next meta-step, the parameters of each track are set to the last step of all their respective loops so that the next time each one receives a clock, it will advance and start at the first step. When all the tracks are being clocked by Kria’s master clock, they instantly hit their first step, but since KR.CLK clocked tracks are advanced by their own Teletype clocks, all their parameters will sit at their last step until they receive a clock. Does that clarify what you are experiencing at all?


#18

So in other words, queuing and meta-sequencing won’t really work when externally clocked because the meta/que clocks are always internal?

It’s strange, though, because when I first set up a sequence, without altering the metronome speed, meta-sequencing and queuing DID operate in sync while under KR.CLK-ing. It wasn’t until I altered the metronome speed. Just a happy accident because the Meta/Que clock was accidentally running at the same rate as the external clock, maybe?

Generally, I’m having a hell of a time trying to get the Teletype ecosystem to sync well with Varigate. I get a lot of skipped pulses, no matter which I designate as the master source. The one setup that is working well is if I designate a track of the Varigate as the clock source and send that into the Ansible clock in. For whatever reason, that is rock solid, but if I take the actual clock out from the variate, Ansible skips pulses. I scoped them both and the pulses are identical in their amplitude and pulse width. Weird, eh?


#19

Yea… Ansible always has a master clock that drives the pattern queuing and metasequencer. If nothing is patched into the first input, its the internal clock. Otherwise its whatever you’ve patched in. Even if you set all four tracks to be TT-clocked, the master clock is still controlling pattern queuing and the metasequencer.

Maybe use a separate master to clock Varigate and Ansible?


#20

EDIT: Brian sent me a replacement. xoxoxo.

hello all,

my ansible is non responsive to anything i do suddenly. can’t update it or get it to turn on at all.

i have dfu programmer installed and i can update my teletype and have updated my ansible a few times. but tonight i was changing cases, and installed ansible/teletype and i2c cables and was jamming for a long time just fine. then all of a sudden i noticed my monome wasn’t on. hit some buttons on ansible and it seemed dead. tried a power cycle, then realized it might need to have firmware reuploaded.

but dfu programmer just says no device present. i understand how to update, i just did it successfully to teletype cuz i was wondering if it was working at all. took a bunch of modules out the case and tried ansible again, no dice. tried another case even.

i can’t tell if it’s going into dfu mode, but some lights sometimes turn on. also, at one point when i plugged in my usb A-A cable, it made a high pitched whine. then i figured it must of fried. i’m within range on all power parameters in my case.

i reinstalled homebrew, nothing works for ansible. i followed every thread on other people having problems too. nothing is working. i did it before and can still update teletype so i’m pretty sure this thing is bricked unless you guys know something i don’t. (please know something i don’t)

HALP. plz.