Ansible bug reports (official)

ansible

#21

this probably isn’t a bug, but it was moved by a mod.


#22

Ok, i’d like to begin with the caveat that i am very much a beginner when using these powerful machines and assume that at least some of this is user error…

I have 2 Ansible, one is running the latest firmware 1.6 while the other was shipped direct from monome last week and appears to be running 1.5.2 (does not have racheting etc.)

there is some odd behavior with the 1.6 unit in both kria and MP. In Kria the issue is while meta-sequencing after a period of time the 7th row counter runs into the 8th row and then stops. nothing seems to restart the clock other than a power cycle.

In MP while in 1 voice mode CV/trigger data is not being sent. In all other voice modes CV/trigger data is sent although in all modes the CV leds are not being lit. My housemate is also running the 1.6 firmware and is experiencing the same issues in MP. The 1.5.2 has none of this behavior.

Anyone els experiencing any of this?


#23

1.6.1 fixes the MP trigger issue.

ansibles were shipped with 1.5.2 as they were built before 1.6 was out.

kria meta-sequencing needs to be investigated by the recent code contributors? @freqout?


#25

@facetimecontinuum can you provide steps to reproduce the issue?


#26

WOW! your response times are uncanny :grinning: i will report back when i am in front of my system this evening


#27

so i’ve been running the same patch as last night, when the described behavior occured, for the last hour without any of the “said” behavior :face_with_raised_eyebrow: i suppose i’ll report back if it happens again. Thanks for responding


#28

Hi,

First off, I want to begin by saying this module is amazing! It is SO nice to be able to plug my monome into something without the need for any other software for connectivity. And the applications and UI are so deep and well laid out. I have been getting lost in the modular with this guy.

Nevertheless, I think I’m noticing what might be a bug in the Ansible.

Regarding external clocks: When I clock the module externally with a square wave from the modular, what appears to be happening is that, on the rising edge of the square wave the internal clock in Ansible freezes and when the square wave reaches the lower edge it releases the Ansible internal clock. So, the result is, if your external clock is running slower than the Ansible Internal clock, then multiple note/triggers are output during the lower edge interval of that clock

I experimented with lowering the Ansible clock to it’s slowest setting and then inserting an external clock running faster, but because the two clocks are running asynchronously to each other, even with a faster external clock, every so often two note/triggers are output during a given lower edge duration.

I’m not sure if this is a bug or just the way the module clocks externally. I’m still getting amazing sequences out of it but in this one aspect I’m not seeming to be able to gain control.

Thanks!


#29

I should also mention that the Ansible firmware version that I am running is the latest. Version 1.6.1

After the recent 1CV/TR Voice mode triggering fix.


#30

hi @egon77 and welcome back!

this is very strange behavior as what you’re describing with clock release/lock is what should happen when you insert/remove the jack. have you tried with different clock signal? or what happens when you attenuate the signal?


#31

Is it possible the unusual clocking behavior might be the result of using a bipolar square wave as a clock? I seem to recall weirdness with using bipolar LFO outputs as clocks…

…if you have something like a Maths to scale and shift the signal into positive territory that might be something to test.


#32

Hi @tehn, It’s good to be back! Thanks! I’m loving this module.

You and @ngwese are both onto something there. All the LFO’s in my system appear to clock the monome the same incorrect way. BUT, the external clocking did begin to work correctly when I attenuated it with a VCA ( I had to sort of find a sweet spot on the knob to get it to work)

But ngwese suggestion also worked, to merely offset the pulse into above-negative territory without the need for attenuating got it to clock as advertised as well.

These fixes work for me! Thanks!


#33

I have external clock problems too, from any korg device (sq-1, volca mix etc.) it kinda skips so the sequencers start getting skaty behaviour, this is true also of my expert sleepers disting clockable lfo mode, and some others. i can boost the signal with maths to rectify. the clock out of the keystep works fine - but that’s quite a chunky object to carry around outside of the modular…


#34

I found that a clock pulse of about 25 ms seems to work well. I’m sending clock from a Teletype, so I can fine-tune it. :slight_smile:


#37

Howdy,
I installed the newest ansible firmware(1.6.1) and based on this PR(https://github.com/monome/ansible/pull/30) I thought that setting note durations to max would tie notes together. When I actually try this though by cranking up the durations on 2 neighboring triggers, I still get a double trigger on my envelopes. The ansible trigger lights does appear to remain solid throughout but no matter what envelop I hook it up to(intellijel dual ADSR, Tiptop Z4000), i still get the same behaviour implying to me that voltage is going low if even for a very small amount of time. Am I doing something wrong?


#38

It’s pretty easy to reproduce this behaviour. It doesn’t seem to matter if kria is clocked internally or externally. Just create a small sequence where two neighboring notes have a maximum duration set. I found that the note will NOT tie on MOST devices.

Double Triggers:
Initelljiel Dual ADSR
TipTop Z4000 envelope
Shapershifter
NI Manis Iteratus

Single Trigger:
Make Noise Mysteron.