Ansible Development and Beta Firmware Discussion

Yeah, tbh I don’t find it particularly intuitive, I don’t understand why their steps stay after removing a ratchet. I just expected the entirety of the ratchet to be gone when I disable a ratchet.
Maybe that doesn’t make sense? On the other hand that’s how all my sequencers work.

Also doing triplets doesn’t actually seem to be doing triplets, at least it’s not doing what I’m expecting. Need to try it out a bit more to determine if it’s me misunderstanding something or if it doesn’t work correctly.

I guess with this implementation they probably are not on the beat, but shifted by the length of one tripled?

I have not tried the latest features yet, but from just reading I get a bit worried if the UI is still intuitive and easy to use/play. Hopefully Kria does not get overloaded for some quite specialized use cases as random ranges for features that already are very filigrane like ratchet and note offset.

BTW, I always thought Kria already had an official feature for altering single scale notes without shifting the rest of the scale.I rarely used it - has it gone lost somewhere on the way to the current firmware?

At the latest beta I can’t manage to disconnect notes, triggers and tracks. All config graphs are unlit but still everything is bound together. And the UI ist messed up when the loop wraps around the right end of the grid on note page.

I think this is to make it easier to program one extra “ratchet” trigger for example on substep four of possible five without actual having the five substeps triggered. I have to admit that this is one of the more esoteric features which I am afraid that they make Kria less intuitive and easy to use and I would be fine with just a simple 1 to 4 ratchet.

I guess one would need to be quite smart for intentionally using all this to program interesting sequences. Otherwise it would just come out as the usual pseudo random quantized sequence music. There is nothing wrong with this I am just not sure how heavy featured that would have to be.

2 Likes

Can you describe more of what you mean when you say your UI is messed up when a track wraps at the right side?

Also the scale manipulation behavior you are referring to was in place on the White Whale version of Kria; I don’t believe it got ported over to the Ansible version. Thankfully I find the way the sacle shifting works right now to be pretty intuitive and fun :slightly_smiling_face:


@simonvanderveldt I’ve been thinking about your inability to create triplets the way you want and I had a thought: it sounds like the triplet behavior you’re expecting akin to an “eighth-note triplet” setting on a clocked delay, is that right? If so, this would be a succession of three evenly spaced trigs in the time frame where two trigs would normally occupy. (Please correct me if I’m wrong!)

The ratcheting function creates a succession of evenly spaced trigs only in the space where a single position on the trig page exists. I just checked and confirmed that the speed of the ratchets is tied to the divider setting on the trig page. This makes it so the timing of the ratchets are consistent with the speed of trigs, but will never allow triplets to be programmed like the method I described above.

@csboling maybe it would be worth seeing what happens if the divider setting on the ratchet page itself is what determines the timing of the ratchets? I could see some potential problems with this but It seems like it could be a simple thing to test.

2 Likes

There is a shifted ghost image of the current note sequence appearing on the grid. I think I does not influence the actual behaviour but is a little distracting.

Ah okay, yes that could perfectly be and there is absolutely nothing wrong with your current implementation!

But what bothers me more at the moment is that the config page does not work anymore - it is not possible to disconnect tracks, notes and triggers anymore.

Hm, are the three sub trigs really occuring on the postion of a single step or in the space between two steps? I think that makes a difference for triplets being right. They should still be consistent with the main speed. Anyway, I don’t think one could get real triplets out of a ratchet, but it is also inconsistent and skips substeps every now and then at the moment.

Wait, what exactly are the greyed steps showing then? I though it was deviding the step into 1 to 5 even substeps that can be activated then. Three substeps should then give triplet speed, or what am I missing here? The triplets would just be shifted one third of a beat.

I’ll check this out. The intention is for all existing functionality to remain unchanged from 1.6.1 by default – new timing/sync options should all be opt-in to avoid interfering with any existing usage. The obvious exception to this is the change to ratcheting behavior, which I’ll definitely work on making less confusing. The default sync options ought to behave exactly as before but it’s entirely possible I broke something – the motivation for these features though is to make it easier to (optionally!) keep different components in time with each other if you want to, so that using different loop phases / lengths doesn’t get too chaotic.

2 Likes

It just became inactive as in not outputting gates anymore when I changed the note loop. I reinstalled and powercycled but still can not change config settings and the ratchet is more or less random in how many trigs it spits out per step.

Between is what I meant, thank you for clarifying.

You are correct, I was referring to the divider modifier of the ratchet parameter as a whole, not the subdivisions of an individual step. Sorry for the confusion!

Maybe this is a silly question, but is earthsea included in the most recent beta? Also, I’m wondering if there is going to be an updated official firmware on the new batch of ansibles, because theres a lot of new documentation on the monome official page that I don’t remember seeing before :thinking:

Yes, Earthsea is in this beta, and the documentation pages I think have been mostly tracking the new beta changes as they get merged and docs get written for them.

2 Likes

Ok I’m not going crazy!

The strange thing is I can’t remember updating ansible firmware for a while but something has gone awry

It’s not behaving as it did (but I ca save my work now so something given, something taken away :+1:t3:)

Considering this I might jump into this brilliant new firmware

So I just update the hex file as per normal?
I’m on a Mac

It’s just a normal update, with a few extra steps if you want to back up the presets you have saved now and restore them. Otherwise updating will wipe all presets stored on the module. In fact if your firmware is persistently buggy I would love to have a copy of the ansible.hex file so I can load it up and go bug hunting – if you don’t mind, and you haven’t reflashed it yet, copying ansible.hex off your module’s internal storage is also described at that link, this would be a huge help.

You caught a ghost! Thanks for identifying what the problem was, working on fixing this now. I have confirmed that this was present in the 1.6.1 release. Other weird glitches can happen on the note page when the loop wraps around the end too.

I can’t reproduce this on this build, when I turn Loop Sync to None I’m able to set independent loop points for all tracks, and when note sync is off placing notes no longer activates triggers. Is this misbehaving right after boot/reflash? Possibly there could be some other ghosts corrupting some state somewhere.

2 Likes

New build (f9355d0):

  • Fix the display bug when the loop wraps around on the note page
  • Ability to set grid varibrightness from the leftmost 3 keys on the top row of the Kria config page. From left to right – 1 step, 4 steps, 16 steps. Currently 1 step and 4 step are treated the same but may have additional brightness adjustments in the future.
  • Eliminate behavior where turning off the highest active ratchet gate would keep the higher subdivisions selected. Sorry about including something this confusing! As suggested it is now possible to select the range of subdivisions with a vertical range selection gesture – hold Loop Mod, hold the bottom key on the target step, and then press a key above that for the desired subdivision count. Long pressing the top row will turn on all gates for the currently selected subdivisions. Long pressing the bottom row will clear all gates except the first one.

This is interesting, if this happens again would you be able to post a video? Being able to see what the trigger and note pages are doing would be great, as would any more information about your sequence/Ansible patching, especially whether the external clock or reset are patched. There is a reported bug (with video) showing weird ratchet behavior in the presence of external clock and reset but I have not been able to reproduce this yet. Also still not sure about why you’re not getting any effect from the note sync/loop sync settings. All taken together it sounds very weird. Are other apps (Meadowphysics, Earthsea) working okay?

Thank you very much for fixing this. I was unclear when I mentioned it - it was known and reported many times for firmware versions before but never fixed.

I just went back to 1.6.1. from 2018 that is linked from momome.org and was surprised to find a simple ratchet implementation and also a second note page. I did not notice that before. But anyway, downgrading was to recheck the config page. I can change all settings there but still but still can’t on your newest build. On the grid all options are greyed out but Kria work as if note, trigger and loop were synced over all tracks. I can highlight all graphs as expected but with no effect.

The best way to make sure bugs get on the radar is to make a Github issue. This requires a Github account, but there is also this bug reports thread. I had encountered the ghosts before but didn’t know what was needed to reproduce it. If you have any more tips on how you’re producing weird ratchet behavior that would be great, I tried to follow along with @fourhexagons bug report video but am not able to reproduce the shown behavior where ratchet steps are missed etc. on the latest build.

I just fixed a bug (in the latest build, beb7a60) where moving the trigger loop start would not update the note loop start with note sync on. Other updates, such as placing a note or updating both ends of the trigger loop, were affecting both parameters as expected but this case had been missed.

Otherwise I’m getting the expected behavior from these options. Can you walk me through how you’re testing this? My procedure, from the default state:

  • Hold Key 2 to access the config page. Press the lit group of four keys in a row to turn off loop sync. Release Key 2.
  • On the trigger page, hold Loop Mod, then select a different loop start/end for one or more tracks to see them move independently from each other, because Loop Sync is None.
  • On the note page, program some notes. Go back to the trigger page. The corresponding trigger positions are active because Note Sync is still on.
  • Hold Key 2 to return to the config page, and press the hollow square glyph on the left to turn off Note Sync. Release Key 2.
  • Change the note page loop endpoints. The trigger page endpoints no longer update.

Also it might be useful to know your Ansible board revision? I believe all revisions have used the same processor part but I’m not confident in this.

1 Like

When I power the rack on after having updated the firmware from 1.6.1. and go to the config page by holding key 2, none of the three configuration graphs is lit.

I can not select different loop start/end points for for one or more tracks independently from each other.

This is not possible to achieve - neither with the hollow square glyph lit or greyed out.

I have not tried beb7a60 yet but will as soon as possible, although the issue is not that sync modes are not working correctly but that it is not possible to turn them off. I try to get the Ansible out of the rack and look after the board revision (i2c cabling makes taking modules out a bit cumbersome sometimes…). I guess it’s an early one as I bought it right in the beginning together with the first new Arc4.

I think this should be enough info, I know mine is also a pain to unrack, thanks.

Do you have external clock and/or reset patched in? I think that bug made it into some builds but that was a little while ago, I also thought it only affected the clock config page. It’s really interesting that the glyphs are not lit, but the sync is active. Also do other apps seem to work okay?

there is only one rev of the Ansible board

up until this new batch

1 Like

No external clock or reset patched. On a short glance Earthsea an MP are working correctly, but I have not fully tested all features. (still have an original ES, so I have to dig into the differences). Also when I came back to Kria from ES the grid became unresponsive. Switching through the apps again fixed that. The note wrap loop ghost is gone though, wich is great! :slight_smile:

1 Like

I think my problems to update Ansible to the beta firmware is a cable problem. I lost my USB A-to-A cable, so I’m using a USB A-to-C cable to connect Ansible to my Macbook Pro. I powered up Ansible while holding the button next to it’s USB slot, but when I’m executing update-firmware.command the dfu-programmer says “no device present”, which probably means, that it can’t detect Ansible?

When I updated Ansible to 1.6.1 I used the original Ansible USB A-A cable and a USB A-C adapter and that worked, so I probably just have to get a new USB A-A cable.

1 Like

So as of the last couple builds there are I guess up to 5 separate glyphs on the key 2 config page, depending on how you count:

  • Top left corner: Three “radio button” keys, the rightmost is lit by default. This is for specifying your preferred brightness settings, to adjust for 1, 4, or 16-step (the default) varibright grids. Currently 1 and 4 are the same but more brightness tweaks may be added in the future.
  • Centered on the left side: Hollow square for Note Sync. On by default.
  • 4 keys in a row, collinear with the bottom line of the Note Sync square: Loop Sync = All. On by default.
  • A single key above the Loop Sync = All row: Loop Sync = Track.
  • Bottom right corner, in the key that corresponds to Kria’s key for accessing the Scale page: Go to tuning page.

When key 1 is held for clock config, the existing clock configuration UI is shown unchanged, along with 4 new glyphs along the bottom half:

  • Hollow square in the bottom left corner: Note division sync, for syncing the time divisions of the trigger and note parameters. Off by default.
  • Filled square bottom center: Time division cueing, for waiting to latch time division changes until the loop ends. Off by default.
  • Row of 4 keys bottom right, collinear with the bottoms of the other two squares: Div Sync = All – all tracks will share time divisions for all parameters. Off by default.
  • Single key above the Div Sync = All row: Div Sync = Track – time divisions are shared within each track, but tracks may have different divisions from each other. Off by default.

Do these options have the described effect on time divisions? Do other new features, like direction changes on the scale page, or trigger clocking work? I’m pretty well out of ideas – clearly if I’m grasping for hardware differences. Sorry this has been such a pain.

1 Like