Ansible Earthsea

this is a good point— i agree with your logic

6 Likes

Yeah it seems like generally with Kria and Meadowphysics people just refer to them as “X on Ansible” to distinguish the difference between that and the older module. It’s longer and not as catchy but more in line with the current naming convention.

OK, agreed.

In which case, here’s the latest version of the docs, with some corrections that @scanner_darkly suggested and the appropriate naming:

https://github.com/infovore/monome-docs/blob/aearthsea-docs/docs/modular/ansible/index.md (click through for formatted)

4 Likes

i like aearthsea but agree consistency is important. although i have some plans for making that consistency somewhat redundant… :slight_smile:

as the initial promise of making a polyphonic version of earthsea has been fulfilled i’m going to switch back to teletype development for now to get the next beta ready (so that i have some new stuff for when W/ ops get merged). once it’s done i will go back to working on the rest of the earthsea features.

17 Likes

we appreciate you! this is all very exciting stuff!!!

2 Likes

Here’s an update to my quick reference card, with various improvements, and pulling in new text from @infovore’s updated docs above.

I need to print this out and make sure everything is legible and accurate, and lines up nicely on A3.

All suggestions welcome.

earthsea for ansible quick reference.pdf (908.2 KB)

18 Likes

This is great! Really nice work. Would love to see a Kria and meadowphysics card one day.

1 Like

Thanks. That’s loosely the plan, though only for ansible versions at this stage - I’ve sold on the prior trinity modules.

1 Like

Possible bug report for @scanner_darkly.

Record two simple patterns in both slots one and two.
Enter pattern select mode.
Activate pattern 2. All good.
Then activate pattern 1.
No gates seem to be sent for pattern 1.
Going back to pattern 2, gates appear AOK.

Exiting pattern select mode seems to make things ok again.

Might be operator error. Will fiddle more today.

UPDATE : it appears to be some kind of “stuck note” issue. If you switch patterns at the exact time a particular note is playing, that note appears to get stuck on, effectively taking voice priority, pushing notes in the new pattern to the next voice … if that makes sense.

3 Likes

how was your voice allocation set up?

it’s supposed to kill any pattern notes that are still active when switching patterns (or restarting the same pattern), but possible there is a bug somewhere, and it doesn’t happen. if you can reliably reproduce, could you try stopping playback and see if that clears the hanging note?

if it doesn’t, can you try changing the edge mode between hold and fixed and see if that helps? (it kills both pattern and live notes when you change the edge mode).

I know you aren’t currently adding features to this, but an idea…

What if we could select both the Forward and Reverse runes simultaneously to activate some sort of pendulum playback? At first I was thinking about another rune altogether, but the layout of that page feels nice the way it is.

1 Like

unless it’s somehow really time consuming to implement i’ll consider including it!

3 Likes

Just installed the firmware for this and getting just the slightest semi-hang of it… wow, so much fun! Good job @scanner_darkly scanner_darkly : - )

new build, incorporates the official 1.6.0 release:

ansible.hex (265.6 KB)
ansible.zip (86.4 KB)

there were some merge conflicts so possible some bugs crept in. as i’m concentrating on finishing teletype community help with testing will be much appreciated!

8 Likes

As soon as I can steal another A->A cable from work ill get this up and running!

1 Like

When I try to update my Ansible with this hex/firmware, it seems to just blank out the device. After updating, Grid don’t light up when I connect it to Ansible. Tried several times, switching back and forth between this and the 1.6.0 firmware.

i just tried using both the hex file and the zip file posted above and can update successfully with both.
so the 1.6.0 works fine but this one doesn’t? can you check that it downloaded fully? the hex file size should be 271945 bytes.

the only other thing i can think of, there will be a pause 3-4 seconds when you run it for the first time after installing a new firmware while it initializes blank presets. but you will get that with 1.6.0 as well.

anybody else is not able to install the firmware?

Hm, weird! I’ll give it another try asap.

I am about to install now, will let you know in an edit.

Edit: Everything worked out great for both of my Ansibles. Thanks, @scanner_darkly!
@Plym, I hope it works out!

2 Likes

Oh, great. Sorry for the confusion @scanner_darkly! I’ll give it another try tonight. Thank you for the amazing job with this.

1 Like