Ansible Earthsea


#202

iirc you can use “stop play” to end any hanging notes as a workaround.

there might be other bugs where it leaves notes hanging - at this point i probably won’t be fixing these as my plan is to do a complete rewrite when i get a chance to work on this again, so doing any development in this version will be essentially a throwaway work.

adding an option for rotation is a good idea, i’ll consider adding it.


#203

Yes, after playing the whole evening with it, hanging notes seem to be a thing. Sometimes they sum up in a loop over time to become a steady drone until their voice is getting used again.

Great to hear that you are still onto it though, cause I think it’s great! :grinning:


#204

Can’t thank you enough for this! I was one of the folks that couldn’t get the original earthsea module to behave in my system no matter what I tried.

One thing I notice with this version; however, is that notes/arps are being retriggered/reset when I release a note/button. This makes it difficult to play one note to another with even timing unless I actually time my release before pressing another button (which feels really odd). I’m guessing this is somehow a result of implementing polyphony or note-stealing in earthsea?

I’m running earthsea in arp mode and loop mode with only channel 1 gate and cv active.

I know norns is upon us, but if you could look into this when you get a moment it would be much appreciated! :blush:


#205

not sure i understand correctly, could you list the steps and the desired outcome vs what actually happens?


#206

Sure, no problem:

I record a pattern, activate arp and loop, press a button (notes/gates sound). Depress/release the button, and upon releasing the note/gate pattern sounds again. Normally, if you press down a key (on a keyboard for example) the note sounds and then when you release the key, you hear nothing. That’s not what is happening-I’m hearing the note/arp pattern being triggered again upon release. It may be easily overlooked, but try it and see.


#207

got it, an easy fix, i’ll post a new version tonight.


#208

20 characters of sweeeeet! :pray:


#209

here it is:
ansible.hex
ansible-1.6.1.es.zip

^ this is basically the official 1.6.1 + earthsea

manual
quick reference


#210

thank you so much!!! :heart_eyes:


#211

Just tested and it’s perfect; thank you!


#212

So that includes all the ratcheting stuff and whatnot, too? :mage:


#213

looks like it - it’ll have whatever is in this release:


#214

Im a bit embarrassed to ask you to walk me through this considering how much time and effort you’ve put into this project but… Im struggling with the hex file. I know basically nothing beyond the most basic functions of a computer so i’m most certainly missing something (many things) i’m on a mac by the way.

I did a few quick searches in the forum and the wider internet and it seems (perhaps) a zip file with the flash command would help?

I have successfully updated ansible firmware in the past with a command file.

i’m not confident that im using these terms correctly so again I apologize for asking you to hold my hand through this


#215

I was wondering the same, don’t feel badly


#216

This is how I do it, but checked the forum to make sure this is common wisdom:

You can use another ansible .zip and replace the hex file, then run the update.


#217

if you don’t have a .zip handy, you can grab one here

edit: hope that helps!


#218

sorry - i should’ve posted a zip as well!

give this a try: ansible-1.6.1.es.zip (84.5 KB)


#219

It worked!!! computers are magic!!! thanks again!!!


#220

thanks for confirming! i edited my post to include the zip.


#221

would it be possible to add the TT commands for this version of ES? And maybe a few new ones :slight_smile:
something like this perhaps:

AES.PRESET
AES.PATTERN
AES.TRANS
etc. including all the commands applicable to this version.

then maybe some new ones that address the polyphonic stuff?

AES.TRANS x y (x being the voice 1-4 y being the transposition value)
AES.MUTE x y (x being the voice 1 or 0 for on off maybe?)
AES.START
AES.DIR x (0 for forward 1 for reverse)

i love all the control you get with kria and TT so these thing occurred to me as i use ES all the time as well. :slight_smile: