Ansible for JUST midi/cv conversion


#49

Ofc and thanks for the cv recorder suggestion, being the place this is i throw this function in as a nice potential idea or suggestion for a midi addition as midi additions where earlier said to be welcome to discuss here.
To explain why this would matter to me is simply i need a midi cv for now, i would be interested where the i2c might develop concerning ansible, and the modules future flexibility also with potential addition of a grid or arc later. All this is happening on 56hp so maybe it gets more understandable why i ask?

I dont see a better future save module to take, allready as is, many roles in this context and i wonder if the cv record to its flash would be doable in a not overly time consuming way

I will however see if i can hunt for cv rec in 2hp not sure how easy it would be to implement but maybe you are right and its the best solution


#50

Not so much away from the computer, but without needing to interact with it. Ansible is basically a small chip running software, so it’s not terribly different. Plug your MIDI into Ansible or into your computer and run a program.

Though to be fair, Ansible outputs directly to your modular, and a PD patch wouldn’t do that per se w/o something like an Expert Sleeper’s I/O module that has DC coupled outputs.

Just trying to come up with ways to maybe get what it sounds like you’re describing you’re looking for, given that doing it w/ Ansible would require firmware development and most folks in the community who do firmware development appear not to be working on Ansible at the moment.

What I think you’re describing wanting is custom behavior particular to your setup, which means you’d probably need to do the coding, and PD is much more approachable than firmware development.


#51

Actually thinking about it, you wouldn’t need an Expert Sleepers module, just something that does MIDI-to-CV conversion. There are a lot of modules that do that.

So, in sum:

  1. MIDI into computer running PD. Computer screen can be off :slight_smile:
  2. PD does whatever you want it to do, and outputs MIDI.
  3. MIDI goes to whatever MIDI-to-CV module you have at hand, and drives your CV-speaking modular.

#52

„At the moment „ thats the point. Never asked for it, just showing interest in a sidechain development of ansible midi when one of the devs touches it again.

Iam fine with learning to play Just Friends and loop/resample in audio for my early journy and ansible is on its way;)

I made a custum case with a power bank to be free of any outlets and screens. Happy about trigger box tho, but thats offtopic


#53

Dont have midi cv yet. Ansible just ticks many boxes as we probably all agree


#54

Cool! Just trying to give you options to help yourself. Waiting for an open source developer to do something for you can be a frustrating experience :slight_smile: It might be more rewarding or at least faster to learn to do it for yourself.

PureData can run on a Raspberry Pi, so it could be made very portable and off-grid, and screen-less. Again, I’m only suggesting this because of the lower barrier to entry, compared to firmware dev.

http://www.axoloti.com/ might be another option for setting up something custom, and could be wrapped up in an Axo Control. http://musicthing.co.uk/pages/axo.html

I have not done any of these things…they just seem reasonably possible.


#55

Might be worth looking at the Bela/Rebeltech Salt.


#56

I just recieved Ansible with latest firmware including Earthsea and facing a problem with midi.

At first i tried powering my midi keyboard via Ansible but it wouldnt turn on. So i then tried to power the usb midi keyboard (icon nano demands 12v 100ma) via usb to ipad, works fine powered from ipad usb. I have now powered the keyboard with a wallplug, it powers just fine but inserted to ansible STILL nothing. No mode light up, no reaction.

Whats up with that? I wanted to power it from ansible but it not even being recognized when powered by itself is making me quite confused.

Also i noticed that, when i patch a cable from cv out of ansible to Just Friends v8 in, the pitch gets a little drift to higher. Not sure if that’s supposed to be?

For whatever reason when ansible recieves power TR2 is orange lid and stays lid.


#58

those solder joints are absolutely fine (by which I mean: entirely within normal parameters of functional solder joints.)


#59

Ok. I honetly just didnt know. Have no knowledg of pcb soldering.
I obviously also rather meant the stuff around the joints and the black stuff. But what do i know.

So if this isnt connected to my issue i have no idea whats up


#60

If you think that something is wrong with your Ansible, I would suggest reaching out to info@monome.org.


#61

Just did so and got speed reply.


#62

Just for reference i still have no idea whats up. Anybody has some ideas what could be up, what to test etc?

Nothing happens when plugging in a powered usb midi keyboard.


#63

Are you certain that the power cable is correctly oriented? Red stripe to -12v on both case and module?


#64

Yep sure. Seems backward protected too.


#65

Just tried my QuNexus with 3 ansibles, and the behavior is the same for all. Plug in the keyboard and the mode led turns orange, and I seem to be in “Allocation style 1: POLY”.

If this isn’t the case with you, I would assume that something is up and follow up with monome. Sorry I can’t be more help!


#66

Looks like. Mode led stays off. According to docs should be white tho?

Thanks for checking. I would understand if the usb keyboard just wont get powered. But being powered externaly and still not recognized is pretty confusing


#67

Dumb question: does your Midi keyboard have a built-in hub? (My Korg Microkey 37 does, and as a result, it doesn’t work with Ansible).


#68

Interesting . Is that a common thing? Would it it be visible by for example more than one usb jack?
But since its the big (b?) usb plug i dont think so


#69

yeah, I didn’t think so either. always worth asking, though.