Ansible for JUST midi/cv conversion


#70

Could you post a link to the specific keyboard you have? I quickly tried to search for “icon nano” but wasn’t sure I found the right one. The biggest thing to confirm first is that the keyboard is USB device class compliant (ie it doesn’t require drivers). Hopefully I glean more from looking at the specs of the keyboard.


#71

Thanks for chiming in
http://iconproaudio.com/product/ikeyboard-4nano/

„Class-compliant with Windows 7, 8 & 10 (32-bit & 64-bit), Mac OS X (IntelMac) and iOS“

And theorange lid TR 2 led is normal?
It seems sometimes weak lid sometimes full. Could of course be connected to some mode app since it doesnt go into midi

Just mentioning that i removed its shell and detached the mod/pitch wheels. Its ofc fully functional anyway as tested with the ipad.
I dont think any device would depend on mod wheels to recognize a midi controller? Cant imagine but cant test today


#72

Let’s confirm a few things:

  1. Power off the ansible module and disconnect anything which is connected to the USB port
  2. Power on the ansible module:

Q: Are any of the module lights on? (I’d expect them to be off)
Q: If some of the module’s lights are on which ones? (It sounds like the second trigger TR2 is lit?)

Q: If just the TR2 light is on - does the mode button (down by the USB jack) feel like it moves when you press it? If the mode button doesn’t move can you try gently pulling on it to pop it up. If the button seems like it is no longer stuck down then power cycle the module and try the keyboard again (if the button was stuck it was powering up in firmware update mode)

  1. Assuming no lights are on and your USB keyboard is externally powered (for now), plug the keyboard in. Is the mode light down near the mode button next to the USB jack on and white?

If the light does not turn on do you have another USB cable you can try (I realize this may sound trivial but I’ve seen a large amount of problems report on lines that turned out to be a bad cable).

  1. Assuming the mode light is on/white - does repeatedly pressing one key on the keyboard cycle through lighting up the TR outputs?

  2. If you are able to get activity on the TR outputs, disconnect the keyboard, then disconnect the external power supply (on the keyboard), reconnect the keyboard - if the keyboard doesn’t work then it is possible that the keyboard wants more power from ansible’s USB port than it is capable of delivering.


#73

Thanks so much for taking the time. Working away from home but as soon as possible go through this.

I didnt know about the update mode and a connection to the reaction of the mode button. In my impression it reacted normal but might indeed not push in far/feel a bit stiff. That would be a logical solution as the Ansible was updated right before shipping to me.
i will clarify that first. Fingers crosded.

Yes the tr 2 lights up orange when ansible is powered.

I tried 2 otherwise perfectly working usb cables so can rule that out.

Have to test the other suggestions after exaiming the mode button as for now i didnt get the tr2 light off and the mode light on.

Thanks!


#74

So i can test again now. Sadly i ve to report its not the mode knob. Reacts and clicks just fine.

The tr 2 now isnt lit anymore so whatever goes on is inconsistent from full lit to weak lit to off.
on start up TR 1 and 4 light up for a second. If i power cycle within a few minutes they wont light up again.

I cant test much further since i cant get the mode light on at all.
I am awaiting a 8x8 grid in a few days so i can see what happens with that. But need to get midi running anyway.

Maybe its all an update issue eventho the protocol looked fine, no errors


#75

Yip yip yeah firmware re flash fixed it all. Midi and powered. So glad it was just that. Sry i didnt try before


#76

If i may, just a short Q

I seem to always have some kind of glide/portamento thing going when playinga bit faster. Didnt find a way to have clean note cut when playing the next while still holding the first. For some reason more obvious on non bass oktaves. Can this behaviour be changed?

The poly shift register only is usefull for multiple vcos of the same type right?


#77

The ansible MIDI support is capable of pitch slew (glide/portamento) but that can only be set via teletype - there is no way to enable/disable via the front panel or via MIDI.

Is it possible that the glide/portamento could be coming from your MIDI keyboard or your VCO? Do you only notice this in the mono voice allocation mode?

My recollection was that pitch slewing is turned off by default and a quick check of the code appears to confirm this:

…not necessarily, not every voice has to have the same timbre.


#78

May be really i am fooled by sth. Given how complex a „vco“ Just Friends is. Today it seemed more subtle. Maybe…


#79

So after a great time with learning grid or rather playing it i tried to do some midi key playing again and i always got this glitchy portamento/legato thing going on. Its possible to get a cleaner „tracking“ / transitions by a certain playing style but quite limiting.

I do remeber it from way back 10 years ago when i played a moog prodigy for a while. There i had to switch on some kind of „KB“ i think follower of some kind? Or switch off, to get clean note „cutting off“
At least i think that was conncted to the keyboard tracking.

Its really been a while with mono synths for me so please excuse this basic level stuff. But basically i think thats what causing this legato playing behavior and i have no idea how to get out of it.

Now looking at the moog i only see filter kbd tracking but i am almost certain it is connected to some typical mono synth setting.

Btw tried another vco too, same thing. Really feeling stupid here as it must be sth very basic


#80

If you could post a little audio clip of things glitching along with details of the modular patch being used that would help diagnose what is going on.


#81

Ok will do
But as i said… i think its common mono synth behavior just that on a classical eastcoast synth its on/off switchable and i am not sure how this is handled in modular.

I dont think its a glitch in the sense of any error.

Patch is simply ansible midi 1 cv to vco, gate to lpg/vca, vco out to lpg lpg out to headphones…so to speak

Not much patchwise to go wrong. Tried with envelopes into vca too, its getting more noticable with a slow attack.


#82

I think you might need an envelope to avoid that.


#83

As I mentioned above the pitch slewing functionality is controllable from teletype but by default it is disabled (no portamento). What I’m trying to do is to get sense of how dramatic the portamento effect is that you are reacting then I’ll be more able to tell if this is software related or hardware related.


#84

I noticed this with Kria and Mangrove actually when I first got it, I just assumed it was because I wasn’t patching it into a VCA with an envelope triggered by Kria’s corresponding TR. Now I just always have Pip Slope going into Air on Mangrove and I’ve never worried about it again.


#85

Ok, will make an audio today


#86

Hmmm just have disting ad Env available for now (Jf used as sound).
I tried ansible midi gate into Env to Laurentide LPG cv, Vco sound through lpg. Thats it… with hard envelopes it just stays as is and with soft it gets more extreme


#87

Took me a while sorry.
Was about to record but wanted to test further before.
Turns out with a sampled oscillator played via 1v/oct i can play pretty clean.

With multisample instruments (both, this and the sample vco is disting mk4) i had more problems with missing notes the faster i played.

Wich leads me to either being a latency problem or the waveforms.

So it seems the heavy portamento glitch i only get when playing synths

This includes just friends aswell as wavetable vco

It is very noticeable when playing melodies with more than 2 fast changing notes but can also get weird when played slow as showed in the (sorry! Horrible) test recording. It is mostly dependent on how perfect i play in certain monophonic synth way. So when i have the last bit of a ms my finger on a key or its releasing while playing the next note i get all portamento things going on.

I think for some synth players this is even wanted, but for me its awful :smiley:
I think its a midi /portamento thing. Not a real bug.

I advice nobody to listen to it if its not for research :smiley:


#88

I wonder—note, I don’t have an ansible, so who knows, but I wonder if this isn’t expected behavior. Let me spitball a little

  • I don’t know how the ansible MIDI-to-CV prioritizes notes: since you’re taking a polyphonic domain (the MIDI source) and constraining it to a monophonic range (pitch CV), Ansible has to make a choice about what to do when multiple MIDI notes are active. This will happen when playing legato. My MS-20, for instance, gives the highest note priority, so pressing a lower key while holding down a higher one will not have any effect, but the reverse is not true. This is a design choice and it’s not the only reasonable one to make. I would consult the Ansible manual to see what choice they make.
  • this is definitely not portamento that I am hearing, although I agree with you that the jumping between pitches sounds like it’s not what you are likely to be playing.
  • you aren’t providing any amplitude shaping to your sound, so one possibility is this—again, I just want to reiterate that this is just an idea and is likely best confirmed with the manual rather than here—it could be that ansible sends 0V when no notes are active. This would cause a jump in pitch in your setup since the output of the oscillator is always audible. Frankly speaking this would likely be undesirable behavior for anyone trying to make use of an envelope with a release stage, but it could be expected behavior.

#89

Complicate but makes sense, i ll see what the manual says but i think its rather short on midi. Will see.

Yes the constant voltage and a pitch jump is what i think i am hearing when after powerup i am selecting a midi mode and hit a note. So if this, wich is as you say just logical a constant behavior and gets inbetween if playing isnt exactly precise, the outcome is that uhm…note jumping?