Ansible: Grid/Arc become unresponsive after period of time

After a period of time (as little as 20 minutes/as much as a couple hours) Grid/Arc/Ansible become unresponsive in one or more of the following ways:

  1. Ansible cannot enter preset mode, but the button still functions as an app-switcher on long-press.
  • Ansible becomes unresponsive to any front panel input (all buttons unresponsive) but continues to output whatever it has been outputting.
  • Grid or Arc lights remain normal, yet the devices become unresponsive to gesture. Ansible continues to output whatever it has been outputting.
  • Ansible’s Gate and CV outs freeze while Grid/Arc looks fine. The lights respond to gesture, but the changes are not reflected on Ansible’s outs.
  • Grid/Arc goes dark (no lights)

The issue arises regardless of whether the devices are being interacted with. Disconnecting/reconnecting Grid/Arc resets the behavior of 1-3, but not 4 or 5. Power cycling resets the behavior of all 5 issues.

I’m using two Ansible modules in a case powered by an Intellijel TPS-80w. I tend to clock the Ansibles with a Pam’s New, but other clock sources produce the same behavior. I received the modules just a few weeks ago from Monome, so they’re likely running v1.5.0. I just reloaded v1.5.0 and will continue to test and update this thread. Also, it seems like the issues aren’t present when using Ansible’s internal clock. More testing is required to confirm this.

This new thread is a continuation of:

-I still get no response from the Preset/App switch button, but only from time-to-time. Power cycling the case ‘fixes’ this…

-Grid is still going inactive after a period of time, regularly. Usually 20-30 minutes.

I’ve encountered this several times with Ansible + Grid. I haven’t had it happen yet with Arc, which I recently got. I don’t recall if I was using an external clock when this happened, but I don’t think so. Power cycling fixed it.

it’s very important to note whether or not external clock was being used, as i’m currently suspecting that is the culprit

Indeed.

Update: I’m testing a single Ansible in a case with the same power supply, clocked by a URA. Those are the only two modules connected to the power supply. So far 2 hours in and no problems. As I have more time, I’ll test in the same quarantine using Pam’s New to clock.

1 hour into clocking with Pams in the quarantine case and all is fine. This is going to get tedious adding one module at a time. I’ll report back when I have more data.

1 Like

Sure, definitely - I was not trying to cloud things up. I don’t recall ever clocking my module externally. This happened to me a couple months ago.

I remember that I was switching between Kria and Meadowphysics when it happened. I could perhaps use the debug header on mine to help troubleshoot this further and see if I can reproduce it.

1 Like

I have a similar issue with ansible. When I have it clocked externally from a mutable instruments grid module ansibles’ cv’s eventually freeze. It usually does not take very long for it to happen. I have to powercycle to fix the issue.

I have not experienced this with ansible using it’s internal clock.

I started a previous thread about this so just reiterating in this thread. Definitely looks like an external clock bug.

i can confirm these problems to with external clocking but i have only just started to figure this out so ill take exact notes next and consequent failures (I suspect an easy fix though as its pretty evident now)

Yes, I am experiencing a similiar thing - at the moment trigger outs of Levels are stuck while Arc is still responsive and CV out works accordingly to Arc settings.

I can’t help but feel some of these issues may relate to things we’ve been fixing on the Teletype in the other thread.

I wonder if someone who has been experiencing problems could try the firmware hex in this zip file (you’ll need the update-firmware.command from an existing firmware release).

ansible.zip (79.4 KB)

It comes from here. It might not make any difference, but that’s something useful to know too.

2 Likes

Is this the old new alternative Ansible firmware known from the other thread or a new new one? At the moment I am crosschecking both versions on this issue.

1 Like

It’s the same one from the other thread.

The one you’ve already tested for me. (Thanks for that!)

@tehn

I did a few tests now and what I experience with two Ansibles, the official 1.5 and the alternative firmware proposed by @sam is this:

The trigger outs of Levels always freeze within a few minutes with the firmware 1.5 when Ansble is externally clocked at a rational rate. CV is still responding to changes on Arc, changes are displayed correctly - just the trigger outs stick to “on”.

Every other possible combination of interfaces, modules and firmwares never lead to this (at least not within a short period). Grid is stable on both firmwares and Levels is stable on the new alternative firmware. This is consistent over both Ansible modules. They are connected to tt over the powered i2c bus but teletype is currently empty and nothing is plugged in.

EDIT: Clocking from 4ms DLD

1 Like

yes, in my case. clock coming from a uMidi module.

thanks everyone. will be working on this tomorrow. i have a pretty good idea how it’ll get fixed.

1 Like

FWIW, I added a 5th symptom to the list in the first post. I had forgotten to mention the issue of the Grid/Arc going dark.

I’ll also mention that last night’s patch clocking with Pam’s in the quarantine case (with Grid connected) had no issues for the 3+ hours I left it on.

Freshly purchased Grid and Ansible, external clock from 4ms QCD - been running great for a while, but today, I switched the clocking rate from the QCD, and the grid became unresponsive. Unplug, re-plug of grid does the trick.

please try to reproduce it with 1.5.0 as i spent quite a bit of time working out USB hotswapping, as a separate issue a couple months ago. thanks!

new test version (danger, flashing your firmware erases your presets): ansible-1.5.1b01.zip (79.4 KB)

update command included.

i’ve been running this for quite some time clocked externally at a high rate (TT digital outputs at 10-25ms)

2 Likes