Ansible: help and issues

I think this design has worked for people on the release versions of the firmware, but if I remember right my current beta firmware has a change that works fine with stock Arc but doesn’t with this DIY build. Possibly this could be fixed via a firmware change for this clone if someone who has one is willing to help debug the firmware.

1 Like

Thanks for confirming that and for the welcome. Starting slowly with kria and I anticipate coming back with more questions in due time. :slightly_smiling_face:

I posted this in a different thread but just found this one which may be more appropriate -

I have an older grid 64, and alas an older Arc 2 – does ansible accommodate these more limited options (in terms of buttons and wheels). I’ve been eyeing the monome stuff since more so getting into modular, but I’m not sure if it makes sense to jump in with the 2 monome devices I have…

hi hi!
unfortunately, ansible requires 128 grids and arc 4’s. while there’s alternate LED support for the different generations of 128’s, there’s no support for 64’s.
i’ll make sure this gets in the docs, thank you for the bump!

Are there any good options for connecting my older/smaller devices to a modular set up? (Unfortunately, even most of the Max oriented apps utilize a 128 or arc 4, though they will work in a more limited state, and I haven’t had time to really dig in and develop something for my own use…)

any of the original trilogy (white whale, meadowphysics and earthsea – all discontinued, but pop up on the used market) will work with 64 grid’s, with usability caveats:

no module support for arc 2

however, a norns shield + crow combo would cover all generations of grid + arc and give access to many more applications. a bit of rolling your own will be necessary, but there are tons of resources to begin.

also teletype’s grid ops support 64 grid! no arc support (yet?).

hope this helps a bit!

Yes, thanks! Will dig in some more. I was reinspired by a video I was watching yesterday so started thinking about it again. (in the spirit of “work with what you have”).

So in that suggestion, does norns provide the interface for the grid / arc to connect to crow? Seems like an interesting option, and an excuse to actually get a raspberry pi… :slight_smile:

1 Like

for sure – if you have access to Max and some sort of USB CV interface, that’s where Max would come in most handy. understandably, time is a precious resource – this is a very real bummer.

apologies for forgetting, but multipass is also a very direct way to build alternate firmwares for ansible.

I’m trying to save Kria presets on a USB disk but I can’t achieve it.

My USB disk is formatted with a FAT32 filesystem. I insert the disk and then I press key 2. The white LED turns on to indicate that the device is armed for saving. Then I press key 2 again and I wait about 20 seconds. When I check the USB disk I see the stored file ansible-presets.json on the root of the drive but the file has zero bytes and there is nothing in it.

  1. What am I doing wrong?

From what I read it seems that it is possible to store presets on internal Ansible flash storage. However I can’t find the instructables for this.

  1. Is it possible? How?

EDITED:

I’ve learned how to store presets on internal Ansible flash storage (from the manual: “A short press of the preset key will enter preset mode”). However, I not being able to store my presets on a USB disk; file ansible-presets.json still remains empty. Could somebody help me?

The release version of Ansible 3.0 had a bug that prevented presets from saving to a USB disk, so maybe that’s what you’ve encountered. Mentioned here: (ansible) 3.0.0 release - #36 by csboling

2 Likes

Thanks for the info! Tomorrow I will update the firmware to 3.2 version. Well, first I will check which firmware version currently I have because I have a module from December stock.

Be advised that updating the firmware will wipe any presets you have saved. If you have a bunch of work already saved that you want to carry forward, please make a firmware hex backup as described here and PM me the hex file and I’ll get you sorted.

1 Like

Is there any way to adjust the range of LED lighting for Kria CV? If I’m sequencing over a couple octaves, it seems like they’re all barely lit. I could tune the oscillator lower and bump the sequence up a few octaves, but that feels a little hacky.

If the circuit is the same as Teletype (the processor and DACs are, so I imagine so) then the LEDs are just connected to the analog outputs; they are not digitally controllable except by changing the output voltage.

Oh, thanks, but this won’t be necessary. I don’t have anything that I want to be saved.

Anyway, thanks for the help, guys. This afternoon I will try to update the firmware.

EDIT/SOLVED:

I’ve downloaded the hex file from @csboling that @morgulbee linked a few posts above. I’ve also downloaded the “official” firmware 3.0 from github, because I needed the update_firmware.command file. I’ve replaced the “offical” hex file with the one downloaded at the beginning. Then I updated the firmware successfully. And I’ve checked that now I can save presets on a USB disk (ansible-presets.json isn’t empty!). So problem solved. Thank you, guys! But I have one question more: what’s the difference between hex file from @csboiling and hex file from github? Cheers,

yikes let me check tomorrow if the files are updated

1 Like

Hi all, I’m considering getting an ansible(and grid, and teletype, and just friends, and…) but I’m confused as to whether or not it can do midi2cv w something like an octatrack?

I just don’t want to buy it instead of a midi2cv module and get stuck not being able to sequence anything until I can get a grid.

An Octatrack (or really anything with traditional 5-pin MIDI DIN ports) combined with a basic USB MIDI interface such as a Roland UM-ONE mk2 or iConnectivity mio should work fine.

All the basic MIDI to CV functionality is available from the Ansible front panel but the more elaborate settings require a Teletype in order to send commands over the ii bus.

Hmm ok thanks. So if I wanted to configure ansible to output CCs and clock on some of the outputs I’d need teletype?

I’d recommend reviewing the ansible MIDI mode documentation to get a better understanding of what the different modes offer and decide whether it meets your needs. The FIXED mode has a learning feature which can be initiated from the ansible front panel. FIXED allows 7-bit CCs to be mapped to the module’s CV outputs and specific notes to be mapped to the gate outputs. The MIDI functionality is limited to the various configurations which are built into the firmware. The firmware does not currently support setting up arbitrary mappings of MIDI events to hardware outputs as is found on larger dedicated MIDI to CV modules. The teletype integration does provide access to some settings which cannot be modified via the front panel such as certain arpeggiator features like euclidean rhythms but it does not add any features beyond the existing MIDI modes.