Ansible: help and issues

This time, more installed, the last line reads:

Installing Command Line Tools (macOS High Sierra version 10.13) for Xcode

It didn’t do anything after that, and when I entered “brew install fu-programmer” nothing happened.

EDIT:

wait more is happening now, installing home-brew

EDIT:

The update instructions say:

connect the USB A-A cable to your computer and the module. on the module, hold down the front panel button while powering up to launch the bootloader. the leds may be lit or not; don’t worry.

There are 3 buttons on the front panel, which is the one to hold down while powering up?

Thanks!

I think it’s the one on the bottom right.

Thanks, but I’m hoping that @tehn can provide the definitive answer… I’d hate to inflict some damage on it by doing something ignorant…

Sure…on the original trilogy (Earthsea, Meadowphysics, White Whale) and Teletype, there’s 1 button (the one next to the USB port) , so I think that’s most likely when the docs on firmware updates were written.

correct, button next to the USB port.

if it doesn’t detect, power cycle your modular with the USB cable in

1 Like

Thanks to advice from tehn, I was able to successfully update my Ansible firmware.

When I launched Kria, it seemed to be playing a random note order. Is that supposed to happen?

I assume it’s drunk mode or something, but it was definitely confusing!

Thanks!

That’s very odd on first power-up after updating. The default pattern (loop length of 6) should be unchanged from previous versions of Kria. Is the step order actually set to random for all tracks? This is on the scale page (second key from bottom right). On that page from the top left you should see the following columns in the top half of the Grid, moving left to right:

  • Two columns of 4 lit keys (Teletype clock enables and trigger clocking enables per track)
  • Column of 4 unlit keys
  • Column of 4 lit keys (Forward mode selected for all tracks)
  • Four columns of 4 dimly lit keys (other step modes: reverse, triangle, drunk, random).
  • The rest of the top half of the grid is part of the same scale programming UI from previous versions.

If these are not the defaults and Kria functions normally when you change all tracks back to Forward, then I’m very confused. This is right when you power on after updating and plug a Grid in?

1 Like

It’s got 4 rows of 6 but when I start it playing the sequence wasn’t running in a 1-2-3-4-5-6 order. Which it used to before the upgrade.

Now it’s more like 4-1-6-3-5-2 although that’s just an approximation from memory… I need to finish grading final papers and hopefully I can get back to it tonight.

I’m embarrassed to admit that I’m still so new to using it that I’ve never made it to the point of figuring out the scale page… I must do that !

Thanks!

So for whatever reason it’s working normally now, although all I did was let it sleep overnight in a powered down state… hmmm…

1 Like

My ansible arrived without the usb cable (the importer chose to keep it for himself I guess). I see in the firmware page that Ansible 2.0 came out on July 7 and I purchased mine on July 4. Does this mean that mine shipped with 2.0? Changing programs takes me from Kria (orange) to Meadow Physics (white) to a third light orange option. According to what I read in the docs that should be Earthsea, so I guess it is 2.0. Am I right or is this not sufficient to know?

Secondly. When in a given parameter I press and hold Loop and choose a new loop duration by pressing the beginning and end steps, the new loop duration is applied to all parameters instead to just the parameter I’m on. I went through the docs a few times already and I guess I’m missing something, but I understand that only the loop for the current parameter should change. If I’m wrong please tell me and I’ll go over the docs in the morning cause I’m going crazy! :woozy_face:

You can change the Loop Sync behaviour on the Config page. Sounds like you’re in Loop Sync Track mode, which is the default (all loops of a track are synced). What you want is Loop Sync None mode (all loops can be independent).

Here are the details…

2 Likes

Oh that’s it! I was too impatient to look in the right section. Thanks for the quick reply!

Yeah, if you have Earthsea that is 2.0.0. Another quick indicator is the presence of a top lit row on the Kria octave page (track-wide octave shift). For 2.0 and future versions, it is possible to get version information by making a USB disk backup – the ansible-preset.json file will contain a version number + git commit hash near the beginning of the file.

1 Like

I see, great, the octave page shows a lit top row. I’ll have to get an A-A USB cable eventually.

Isn’t a grid full of possibilities. I’ll have plenty more of nice surprises with ansible that I anticipated. Thanks you for the great job!

You should also watch (and try) the latest Ansible beta versions, which added one bug fix after 2.0 and might add new features in future.

1 Like

Hey everyone. I’m sorry for the dumb questions, but I’ve got two problems. First I have tried, unsuccessfully, to save any presets on my ansible running kria with grid. I read the documents, I press button two, and on grid the save patterns section pops up, but pressing the currently lit pattern and holding it does nothing. If I power cycle, I lose it. This has happened too many times and is really frustrating. I might add that momentarily pressing button 2 does not bring up the pattern section on grid permenantly, it only flashes up as long as I have the button 2 pressed. so I have to hold button 2 down to try and save on the grid, but it does not work.

Second, I’ve tried to update the firmware, and because I have norns, I’ve got homebrew etc on my Mac. I DL the version 2.0 firmware, plug in the usb, power up while holding lower right button and no lights flash or anything. I’ve tried running the script while holding the button, and also while letting go of the button after booting. The script says it runs, but no lights flash or anything on the unit. I then power cycle and it has not changed, still cannot save patterns. So I performed a USB backup to check the version and the json file has no numbers in front of the name, so I’m assuming it’s not upgraded to 2.0. Is this like a norns thing where I have to update to another version first, before 2.0? I did try updating to 1.6 first, and then 2.0, but no good.
Any help would be great. I love ansible but I really wish I could save some patterns.

Sorry to hear you’re having trouble!

To access the Preset page, it should work to tap the preset button next to the USB port, this should not be a momentary switch. Time and Config pages are accessed by holding the buttons labeled KEY 1 / 2 above the bottom set of jacks (clock / reset):

The preset page should initially only have the top-left grid key lit. The right half of the grid is toggles for drawing a glyph to help you remember the preset. Tapping keys in the leftmost column picks a preset slot, and then long-pressing one of these keys will save a preset.

There’s not any visual indication you’re in bootloader mode on the module – no code has run to even configure the LED outputs. On my Windows 10 machine I get a rising chime / harp sort of sound when I’ve started the module in bootloader mode, then after running the script (specifically the dfu-programmer ... start command) I get a falling chime sound because the USB device has disconnected. No idea if there’s any similar kind of device connection indicators you can set up on Mac. But it sounds like you loaded the firmware successfully. It should be fine to update to 2.0.0 from any previous version.

There are a few quick signs you are on 2.0.0, like:

  • You can access Earthsea by holding the key next to the USB port once to go to Meadowphysics, then again to go to Earthsea (orange-white LED)
  • Kria octave page has 6 keys lit on the top left
  • Kria Time page has 3 different glyphs along the bottom, previously this was blank
  • You can do a USB disk backup at all.

I believe that at least some of the most recent batch of Ansibles shipped with 2.0.0, since it was released right about the same time that batch went on sale. When I make a USB disk backup, the resulting ansible-preset.json file starts as follows:

{"meta": {"firmware": "ansible", "version": "2.0.0-9ebf5ec", ...

The file is always called ansible-preset.json and at > 1 MB may be a bit of a pain to open / work with, but the version information should always be at the beginning of the file.

Hope this helps, and I’m happy to update any of the documentation that could be clearer on some of these details.

2 Likes

Oh derp! Thank you. I seem to be able to save patterns now by holding the lit button and then on the left side switch to a new one by pressing a blank button with a double press. This is amazing! As far as the json file, can I open it in notepad on a mac to read if the version is 2.0?

I will try to see if i can bring up earthsea tomorrow when I wake up. I literally passed out just now playing with kria. Haha. I love it.

Seriously, thank you kind friend!

1 Like

Yeah, any text editor should work, just some work better than others with large files. For just opening / viewing them it’s usually no problem. Your version is definitely 2.0.0 though, since the USB disk backup feature didn’t exist before that. Glad you’re able to save!

1 Like

Would love some assistance here. Just bought a second hand Ansible that was previously loaded up to Polyearthsea. At the moment, I do not have a Grid so I have been wanting to use my Digitone or Native Instruments A49 midi keyboard for midi to cv. I got the firmware updated to 2.0 SEEMINGLY successfully but upon rebooting, I get nothing. No orange LED comes up when I plug either device in (I have played with the configuration on the Digitone plenty) and it seems completely unresponsive. Any ideas?