Ansible Kria Pattern Timing When Clocked from Teletype

Hi all, I’m working on a patch being sequenced by Kria which is being clocked by Teletype.

M
KR.CLK 1; KR.CLK 2
DEL.R 4 / M 4: KR.CLK 3
KR.CLK 4

Everything is working fine, except that I can’t seem to get the pattern cuing clock to operate at a tempo that is related to what is being used by the tracks, even after experimenting with the Pattern+Time settings. Each time I switch patterns, it’s as if old pattern is slewing into the new one. Is there a setting I’ve missed which needs to be adjusted? Thanks!

Try making Ansible’s internal clock run at it’s fastest setting and see if your issue goes away. I’ve experienced weird hiccups when Ansible’s internal clock is running slower than TT’s clocking.

EDIT: thinking about it more, it’s possible that the pattern cue tempo is always related to the internal clock which is basically unsync’d when you’re using TT to clock Kria’s tracks in this way. Maybe try sending TT’s metro rate to a trigger output and send that to Ansible’s clock input.

1 Like