Ansible / Kria tempo bug

When I switch apps from Kria to Meadowphysics and then back to Kria the tempo doubles. But the tempo setting iview shows the same as before. To get to in the right tempo again I have to change it to another value and then back.

Also would it be possible that the tempo is saved with the preset?

tempo is saved, yes.

are you proposing some sort of global local tempo instead?

I am not sure what you mean by global local tempo? I would like to save the tempo together with a preset of 16 patterns. Independent from other apps and other presets. So that all presets start in the right tempo when I load them.

I just tried it out and it seems that the whole tempo setting is broken. Tempo is not saved with a preset, or at least it is not recalled when loading a preset. When I load a preset the tempo shown on the tempo page does neither fit the tempo I saved it with nor the tempo it is currently playing in. I have to change the tempo setting to get it working again and then set it where it belongs (as with the bug I reported above).

@tehn, I am not a native english speaker so maybe I am a little clumsy in expressing what I experience here. I did a video to clarify it:

…seems that I don’t understand video embedding either.



thanks for posting this. i understand what’s up now.


there is now a global grid tempo, for both applications. it’s saved to flash whenever any preset is saved.

at this point i’m opting for not saving the tempo inside a preset (as i myself would rather change presets and not worry about tempo shifts).

but i’m also going to add a TT param for tempo, so this should be helpful.

finished v1.2 out later today once i’m done adding/fixing.


Great - thanks for the fix!

While I might not agree with you about tempo saving inside a preset at this point (as in different songs - different tempos) I really do appreciate standing by your design decisions (as in cycles is meant to be slow :relaxed:).

Plus there is still a clock input and tt remote on the horizon…