Ansible MIDI voice mode


#1

I’m having a hard time figuring out what I’m doing wrong.

App LED is white. cv 1 and gate 1 appear to be playing an arpeggio (quite nice, but I can’t seem to change it). Pressing keys on the Keylab that is connected and powered by USB does not appear to have any effect on ansible.

Can’t figure out how to tell which voice mode I’m in.


#2

I just noticed that the published docs have an error, when in standard midi voice mode the mode light is orange (not white as documented, white mode is the arpeggiator). Holding down the mode button changes between the standard and arp modes.

Once a midi controller is plugged in and the mode light is orange - pressing Key 2 repeatedly will cycle through the four allocation modes. Admittedly it is hard to tell which mode you are in without the kind of feedback one normally gets from the arc/grid leds. If I’m lost I usually repeatedly press a note on the controller - if the TR output cycles from top to bottom then you are in the POLY voice mode. Press Key 2 once to get to MONO voice mode.

I have some improvements in the pipeline to the midi modes which should help in this area. In particular I’m trying to work out ways to make the configuration more sticky. On hurdle is naturally the UI…


#3

I just can’t seem to get it into MIDI mode. Kria and Meadowphysics are it.


#4

Do you know if you are running the latest firmware? There was a recent change (unrelated to the midi mode) which increased the amount of current USB devices were allowed to draw. If you have a power adaptor for the controller that might help too.

It is possible that the device you are plugging in is trying to draw more power that the firmware is willing to allow. There is a power negotiation that goes on when USB devices first connect.

I just looked and I couldn’t find any power requirements for the keylab on arturia’s website.

IIRC the max current draw is now set to 500mA in recent firmware, before November it was set to 300mA.


#5

I’m not running the latest. Also tried a Novation SL MkII. Same behavior. We’ll see if upgrading the firmware fixes it, but I might not get to it this weekend.


#6

I’ve tested a Novation SL MK II with earthsea but not ansible. I can give it a quick test today.


#7

I just tried the SL with ansible and while it did go into midi mode it did not work so that at least gives me something to investigate.

I’m 90% sure this is power related.


#8

Both keyboards can use an external power supply. Not a big expense. Thanks for looking into it!


#9

I don’t have a power adaptor for the SL so I can’t confirm 100% that will fix it… I normally run it off and old powered USB 1 hub.


#10

I’m assuming Ansible does not include hub support?


#11

it uses the same libavr32 library so yeah, it doesn’t support USB hubs.

another option could be to use ext5v or Switch if you’ve got them but not sure if they would provide sufficient power, probably best to check with @tehn


#12

Sorry, l realize my comment about a hub was misleading. I only use the SL with a computer normally.


#13

Novation sl mk2 exhibits same behavior whether externally powered or USB powered. Ansible is updated. Has anyone figured this out?


#14

I’ve been using the midi functions of Ansible and was confused about the light to indictate the mode, but I see here that it’s an error.

Something that I cannot seem to figure out is how to activate key hold mode is for the arpeggios. It seems you can issue a command via Teletype (ARP.HLD 1 or ARP.HLD 0) and this is something saved in the preset, but how do you activate it via button press on the front? It works when I use the Teletype command. I had it running via a keypress, but could not recreate it.


#15

I thought the key combo was is the docs but maybe not - from memory I believe you need to hold down key 2 (right) and keeping key 2 held, press key 1 (left).

If that doesn’t work let me know and I’ll go verify in the code and confirm the docs.


#16

That worked, thanks!

Also want to add that I love the midi mode so much that I would recommend Ansible to people without a grid/arc/teletype.


#17

I should add that I did check the docs and that key sequence isn’t documented - sorry about that. I’ll add that to my post norns release todo list.

…and if it isn’t obvious that key sequence toggles the hold function so it will turn hold off if it is currently on.


#18

Ansible got my attention but not really understanding what it actually does. The video on monome page is informative. But for non TT users, what would this give in conjunction with Just Friends?
Is there any any any way that a bit of the „opening up/controlling“ of JF thats possible by i2c Just Type could be used by only ansible and JF?

Just asking this for informatve reasons. Wont jump into complicated new devices until i learned OC and JF


#19

no, Ansible for MIDI is basically an open source MIDI-to-CV device. It can’t do Just Type.


#20

Care to describe what it would do for soemone that has none of the other monome gear like grids etc?
I see some appregio uses i think but i hardly understand what it actually is or can be by being open source