Ansible / Switch Bugs

  1. Since I have Ansible in my rack occasionally the grid does not get recognized when I switch between modules. Firstly I experienced this a few times with Ansible, no with Earthsea too. The module works as it did before (in this case playing patterns nudged from by teletype) but the grid stays dark. No difference when I plug it out of Switch and connect the grid directly to the module.

Of course I have no idea what’s up there but doesn’t Ansble handle the 5V differently?

Would be great if this could be resolved. While Ansible occasionally came back to light by it self after some time, Earthsea just stays uncontrollable then till power cycling. This is a problem cause you have to constantly save your changes, which leads to the other bug:

  1. Sometimes, apparently regularly after switching back to it, Ansible freezes when I hit the save to preset button on the module. A second press unfreezes it and a third press finally gets you on the press page.

are you running the newest earthsea firmware?

regarding ansible, i experienced this for the first time also recently. i’ll be looking into it this week.

1 Like

Yes I am quite sure I do - is there a way to check this apart from reinstalling it?
I’ve read about difficulties to upgrade modules but did not fully understand it. When I did the upgrade there was nothing that suggested any errors.

Great, Thanks!

Also seeing this as reported in this thread:

It seems that there are not many people experiencing this and the broken tempo on preset recall / app switching as described here:

Did I understood it right that at least you noted it on one of yours?

It’s a little frustrating having less access to Earthsea and Meadowphysics cause the grid is bound to Ansible and I hardly dare to switch back and forth. Are there any outcomes of your investigations by now? Is it a hardware issue then? I never had those issues with the trilogy and tried different power supplies, (switched/linear).

it’d be helpful to keep a clear path on the reported bugs.

at issue, highest priority by reporting:

  • ansible USB hotplugging (this thread)
  • ansible preset key hangs
  • TT packet dropouts

adding github issues. i started looking at this on friday but was derailed by manufacturing issues

1 Like

I tried to propose or ask after a single thread for reporting and discussing possible bugs but it wasn’t very successful.

I think the hot plugging USB issue is the biggest problem now compared to preset hangs and timing issues after mode switching or recalling a preset on ansible.

The latter only occur at moments where the flow is interrupted anyway due to the break Ansible takes when saving/loading a preset. And hot mode switching on Ansible might be a pretty unusual move anyway.

here’s a 1.2 beta firmware that i believe should fix hotplugging issues and confusion with the mode/preset key (there was a serious bug that crept in with a feature upgrade) (69.1 KB)


I am afraid it doesn’t…:cry:

@tehn to specify it:

Heavy hut plugging with Arc seems to work, also with a grid. Using switch and a grid seems okay too at a first glance but using switch with an Arc freezes Ansible every sigle time I switch back to it (from nothing in my case since I have only one Arc).

to clarify:

  • arc works perfectly hotplugged directly
  • arc eventually doesn’t reconnect when flipped with switch

Exactly, just that Arc never reconnects when flipped with switch.

(and the case has to be repowered)

upon investigation there is an issue with the arc firmware when using the switch-- i’m sorry to say that the switch is not compatible with the arc.

there is surely a firmware modification that could be made to the arc, though i honestly hadn’t intended on the switch being used with the arc and did not check this prior.

Just found this thread, as I am still getting timing glitches switching between 2 ansibles (currently one running MP, the other Kria) when I switch between them using SWITCH. I really like using SWITCH as I don’t find hot swapping elegant or easy in a cluttered skiff… but reading this - is SWITCH not compatible with arc? I may need plan B…

arc does not work with switch. there’s a firmware issue in the arc.

do you get timing glitches with cable swapping?

I haven’t tried cable swapping without the Switch, but I will and will report back. It seems an inelegant methodology next to the lovely switch using Switch… I worry about using ES in my skiff without Switch because of the current draw…

I’ve tested for timing glitches with and without Switch and Switch is definitely the problem. Hot swapping seems fine.

I’ve found a very odd bug with Ansible Levels and TT, and it isn’t caused by Switch. I have stopped using Switch with Arc.
If I set LV.POS to anything other than 0, then Arc freezes. Levels continues to function but no real time adjustment of the CVs or Notes is possible. If I set LV.POS 0, then the arc is active.

ok, that’s a tricky one, made an issue:

Not so fast, I’m afraid. Playing a Kria sequence today, it glitched every time I plugged the grid into module. Switched to using Switch and no glitches on Kria. Not monitoring the other ansible right now. Will update ASAP with what happens to the other ansible (that’s running MP).
Update - after further testing I’m not seeing hot swapping to cause any more or less glitches than when using switch, with 2 ansibles, kria and MP. Neither set up is without glitches.