App - The Party Van


#524

this is everything I’ve wanted since ordering my 128


#525

It’s presently empty as I can’t get SourceTree (or Github Desktop) to authenticate for some reason, and don’t have the headroom to troubleshoot it, but I plan on putting what I have on a public repo and maintaining it there for those who want to do some testing that way.


#526

:smiling_face_with_three_hearts: the only app that may push me to finish troubleshooting my FDTI driver…


#527

Ok, finally got around to pushing stuff to github. Still not sure what the problem is as I get authentication errors with the github desktop app, but I managed to do it via terminal.

Here is the last version of TPV1 that there will probably be. It has lots of small changes from the last release version, and works fine in Max7/8 finally (on my computer at least):

I wasn’t too tidy on the gitignore, so make sure you don’t add any of the .mxo that may come with it. Also I didn’t do it as a release release since I don’t have the headspace to package it up for that. I may revisit it if that’s something people really want, but for now you can download the v1.1 release and then just replace all the files that are in the last commit.

And here is TPV2 in its current state. Not very much documentation, but it should work straight out of the box for a 128 and arc4. There are probably lots of bugs and stuff. If you encounter some, please report them via the github issues page.


#528

@Rodrigo Does it still require the externals mentioned on the git page? Headed to your website per instructions and didn’t see them?

Just got a grid (fffffffinally) and am excited to get back into TPV!


#529

I literally just discovered The Party Van yesterday and it’s wonderful. Thank you so much for making it and for being such a generous person to give it away for free. Really awesome.


#530

The same externals are still required. If you download the last release from github (v1.1) that includes all the externals, and the manual and stuff. (not the one that says “source code”, but the first link).

edit:
If this version works fine for people in Max8, I’ll wrap it up as a v1.2 release to make it easier for people to download/use.


#531

thanks for that! input effects don’t seem to work for me (v.2) cheers


#532

Do you get errors in the Max window?

By not working, do you mean no audio goes through at all, or that the fx don’t turn on?


#533

@Rodrigo can’t find the externals?:
sugmund
dynamicdsp
entrymatcher
descriptorsrt
descriptors
multiconvolve
morphfilter

I’ve already placed the PV externals to the max 8 externals folder…

so far what I’ve experienced is:
input fx pitch not working and lo-fi mutes the system although indiicators move.

Thanks!


#534

Hmm, do you get red error messages in the Max window about them or does it just say they are missing? It’s likely a 64 vs 32bit problem.

You’ll need to download the HIRT externals as well:
http://eprints.hud.ac.uk/id/eprint/14897/7/HIRT_v1.1.zip

And this it he 64bit sigmund:
http://vboehm.net/2015/06/a-64-bit-version-of-sigmund/

Here are the AHarker 64bit externals (which I don’t think have been publicly released yet):
AHarker_64bit.zip (3.1 MB)


#535

sigmund~: sigmund~: No such object
dynamicdsp~: dynamicdsp~: No such object
sigmund~: sigmund~: No such object
entrymatcher: entrymatcher: No such object
descriptorsrt~: descriptorsrt~: No such object
multiconvolve~: multiconvolve~: No such object
multiconvolve~: multiconvolve~: No such object
multiconvolve~: multiconvolve~: No such object
multiconvolve~: multiconvolve~: No such object
descriptors~: descriptors~: No such object
entrymatcher: entrymatcher: No such object
descriptors~: descriptors~: No such object
entrymatcher: entrymatcher: No such object

waveform~: waveform~: unknown message tickmarkcolor
I’ve added the mentioned, no luck. Shall I go and dnld Max 6/7?
Thank you


#536

It looks like they aren’t being found by Max at all. Where have you put them all?

In Max8 the library should go inside your user folder (User/Documents/Max 8/Library).


#537

ok…progress! I had them in the application folder as per V1.1 instructions.
they are now in shared library. pitch fx input is working now, lo-fi not:
morphfilter~: No such object
waveform~: waveform~: unknown message tickmarkcolor

EDIT
I used the morphfilter from the PV included externals and console seem to accept that
framerank is a new one can’t find…
lo-fi still mutes…

thanks


#538

There we go!

Attached is framerank, though I don’t think it works in 64bit. In TPV2 I just work around it, and thought I did the same in TPV1.

Guess I haven’t been using lofi in a while cuz I hadn’t noticed. I’ll try to update it to the newer framerank-less version.

framerank~.mxo.zip (5.6 KB)


#539

thanks for the support and the amazing TPV :slight_smile:
(confirmed framerank issue…)


#540

…tried to midi map/learn nanokontrol 2 and all it’s faders move the 1st selected/hovered parameter. any solutions? thanks!


#541

Are you learning for individual pairs? (e.g. hover over one, then wiggle the fader, then hover over the next thing, then wiggle next fader, etc…)


#542

yes but the nanokontrol faders just “learn” the first hover, so all of them are mapped to only one parameter, the first chosen. So when I hover teh next one they all follow the next one and forget the first…:thinking:


#543

What happens if you turn learn off and on between each step?

I’ve done MIDI learn with a nanokontrol just fine in the past (though it’s been a while).