Approaching: norns

norns

#2388

I had it on my list to port my old Game Of Life Sequencer from processing (written ages ago) to norns, so glad someone else put one together! This is rad.


#2389

Wonderful work. Looking forward to trying it out.


#2390

Finally getting around to giving this a go!

Excuse my n00b ignorance, but this is my first time trying to add a new script to norns (that isn’t a part of the updates anyway) other than doing a couple of studies. What is the right way to do it?

There doesn’t seem to be a way to download a file or anything, so I tried to copy and paste the code into new scripts on my norns via maiden, which didn’t work. I also downloaded GitHub Desktop and tried to clone the repository based on the URL which didn’t allow me access.

Enough floundering in the dark I thought I’d ask here for some help!

Really want to run kria with my ESQ-1.


#2391

ok - it’s a bit of pain to install manually because there are a number of files - you’ll need the stuff from lib/lua/ansible and lib/lua/junklight as well as the main file - you should be able to paste all of them in via maiden. You’ll have to make each file and paste in the contents from the git repo. There are only lua files so nothing weird to look out for

TBH I don’t use maiden at all (too many years at the command line) and tend to just manage the git repo on the Norns via the serial port (since that’s less effort that turning the wifi on :slight_smile: )

if you are happy ssh’ing or connecting via the serial port - then just putting a fresh copy of the dust repo on your norns will get you all the latest and greatest - that’s likely the least fiddly (but remember to save any local changes you’ve made first and copy them back in)


#2392

This is super inspiring! Very excited to explore this when you release it.


#2393

Has anyone had any trouble with fitment of the 3D printed Norns case after printing it out. I had mine printed at the local library (they have a makerbot) but it doesn’t really want to fit. I pretty much have to force it to get it on. Should I just try having another printed?


#2394

Love this, and thanks for including MIDI out! Does this support custom scales?


#2395

this is awesome, thanks for sharing!

i am having one issue in that i can’t exit the parameters screen once i’m in there - i’m on the latest firmware.
i’ve seen this before somewhere on other apps, but not sure how it was fixed - i think it was something to do with the way the preset system was changed. Maybe something hanging around on my norns between updates. I have to reboot to exit the parameters.


#2396

i could be wrong but seem to remember this being an issue since this change:
[ https://github.com/monome/norns/pull/619 ]

when a script doesn’t define a redraw() function.


#2397

Currently it doesn’t, but it’s a great idea that I’ve added to my backlog.


#2398

Thanks for trying my script and posting on Instagram about it!

I haven’t experienced a lock on the parameters screen but thanks to @zebra’s hint I have a good idea of what might cause it. I recently added a sequence playing indicator that calls screen.update() outside of the redraw-function. This also leads to the indicator being displayed on the parameters screen while a sequence is running (which is also visible in your video).

I just fixed this - screen.update() is now only called from inside redraw(). I’d appreciate if you could try the newest version and check if you still get locked in the parameters screen.


#2399

thanks for looking into it - unfortunately I got a load fail on that new update.


#2400

I just reinstalled the original version again and now it’s working. Not sure what the deal was - after each installation I rebooted. I am using Cyberduck to transfer the files.


#2401

This is takt - parameter locking step sequencer.
I’ve created pull request so you can already try it out.


#2402

Argh, sorry about that. I refactored some other parts and broke something. It’s fixed now in the most recent version on the Github. Thank you so much for your help!


#2403

thanks for the instruction. Sorry for noobism here: But do you refer to serial port as USB?
Is it also possible via USB and sync to disk?


#2404

so yeah - I mean connecting via the charging USB

There is a fair amount of detail elsewhere on here. This post of mine (there are plenty of others talking about it - was just easier to find my own post) describes my workflow give or take

No you can’t sync to disk that way - either connect the wifi and use ssh or sftp (or rsync ) or you can just copy files to a usb stick - use the USB connection above and copy files off of the USB - my wifi connection on the Norns is still kind of flakey and drops out a lot - so I tend to use the USB approach


#2405

Excellent work! :joy: look forward to playing with this.


#2406

some exciting new sequencers coming! Really looking forward to having a play


#2407

No worries, thanks for sorting! - i think this sequencer and others like Loom and Strides could be the tipping point for many people wanting to buy Norns. Somebody already requested this app to be done on Teletype! I see there’s a Chaos 3 OP - Cellular Automata…

Here’s one more…no more, I promise :slight_smile: -