Arduinome: building, troubleshooting, using, etc

Sounds like something is wrong with the new ribbon cables or the cable connections.

Can you test with the old cables? Was there a reason you replaced them? Are you sure the ribbon cables are all oriented correctly?

Hi,
I have just ordered the components to built an arduinome that I would like to use as a sequencer for my eurorack synthesizer.
I was wondering if the Arduinome could work with this


or if it is possible to send CV directly from the arduino to the Modules.

Thanks to everyone for their time!

Hi Okyeron, The old ribbon cables werent very well soldered and were too short for the new enclosure. I am pretty certain the cables are the right way round, after looking on here at some build threads.

I am a little worried removing the pots has caused a problem, Im going to desolder the ribbon headers this weekend and give it another go incase something has worked loose. Thanks again for your hel, will report back here.

1 Like

Hello everyone! About a year ago I traded my old EWI USB for a Monome(?) 64. I had no launch pads or midi controllers at the time aside from a basic 49 key MIDI keyboard, and really wanted one. I’ve tried a good 7 or 8 times to get this thing integrated and working for me but I am always absolutely confused each time I attempt it, so here we go.

I suppose I can start with some basic info. I’m on MacOS Mojave 10.14, I primarily use Ableton and Pro Tools (I’m really curious about getting this to work in Ableton, so if Pro Tools has no support at all I couldn’t care less. Any use is better than it just sitting on my desk for another year). I have Ableton Live 10 Suite (Currently on 10.0.5 build 2018-10-18), Max 8.0.2, (but also I’m contacting their support cause it says I have a trial license and the academic key given to me when I purchased live 10 suite isn’t working ???), and Pro Tools 12.7.0 in the event this does work with Pro Tools.

My Computer is a 15 inch MacBook Pro 2017 model with a Radeon Pro 560 graphics card, 2.9 gHz i7, etc.

And the device I am trying to get to work is (to my new knowledge after getting the furthest I have in Max) an Arduinome.

And I am not a coder at all, I’m just a musician. Multi-Instrumentalist turned Producer/Engineer, so if you can break this all down for me like I’m a dunce I would appreciate it <3

Here are some photos and a gif. https://imgur.com/a/p4TXDsz
I loaded up the meadowphysics presentation (if I did that right?), and brought up an instance of serum. The instance of serum isn’t doing anything. I can’t even click on the keys to produce a sound. I have also tried other synths so I assume I just didn’t load this right in the first place anyways. The other thing I noticed is that no lights are coming on my device. The device does it’s little startup light show when it receives power and then goes dark. About 7 months ago I got it to show a light or two but I have no idea how. I opened something of like 27 things I downloaded to try and make it work in ableton and it worked as an instrument rack controlling some super complicated thing I didn’t understand at all and totally forget what it was. Point is, I assume it’s wired correctly. The previous owner said it worked great for him when we did the trade and there are no signs that it’s a physical issue, I just have no understanding of any of the software.

Ok, so here are my questions;

  • What is the difference between an arduinome and a monome. What do I have to do differently to get this thing working in Ableton and or Pro Tools
  • What would be the easiest process to making a template so this could more or less be plug and play in Ableton. Do I always have to have Max open outside of Ableton for it to open? What Max for Live device do I have to put on an instrument track for it to respond to anything?
  • Why doesn’t anything seem to respond or work at all in Max when I open up a maxpat from the Monome package I got from following this page: https://monome.org/docs/app/package/
  • Is there some super basic tutorial anywhere out there on the internet? This whole device and community seems super neat and dedicated, but I can’t find anything to make an easy entry into this world, and I would really appreciate any help so I can get started and not just use this as a paperweight.

Thank you so much for your time <3

Cheers,
Nick Katz

The arduinome is a clone of a monome grid. Arduinome runs on a arduino microprocessor board.

“Monome” is actually the name of the company who makes grids and other devices, but many people call the grid device a “monome”

If you have a Monome 64, the forget about Arduinome - this does not apply to you.
(Mods may want to relocate this to another thread)

To get a monome grid working on MacOS, you will need to have SerialOSC installed. Testing for connectivity/functionality can be done with Max and one of the monome patches - Monome Home is a very good patch to see if your grid is connecting properly and to test it’s operating. Don’t worry about Ableton at all until you’ve got this part working.

if you’ve already installed SerialOSC and the grid is not connecting, you’ll want to read this thread: MacOS 10.14 (Mojave) and serialosc

EDIT - and read other threads with the keywords “MacOS and serialosc”

for what it’s worth, my thread doesn’t seem super relevant—typically problems have not actually been the fault of 10.14

1 Like

Hi I am putting together a starfire monome project that was collecting dust for ages. Like I am in some sort of time machine here. I was wondering if anyone has the Eagle or .brd file for this so I can diagnose something? I went through the starfire blog and couldn’t find it, although I saw a screenshot of the eagle file on one post.

Hi peeps,

It’s a long shot but while dusting around I found a lost project to make a grid controller based on the livid 64 button grid pcb with the rubber mat and the star gate logic board.

Is this Arduinome software to put in or was it something else.

I have two of these and want to make a 128 grid controller to use with my monome stuff.

All help is welcome.

On the other hand if it is not useful anymore and have to look at other stuff let me know.

Hi there! I’ve made an arduinome using Arduino Duemilanove and Unsped shield + 8x8 Bibo Board. This are my problems:

I solded the unsped shield and the bibo 8x8 board. I connected the ribbon cable to the pins and the leds light up, but not with the intensity they should. My Leds are orange and I think it’s about 20mA and 2V aproximately, so I soldered a 28K ohm resistor.

Another problem is that the buttons don’t work.

The final problem is that arduinome Serial recongnizes arduinome, but if I want to try it in Monome_test 5, I have to use SerialOsc and SerialOsc.maxpat. How can I use Arduinome Serial and Monome test. Is there any aplication that allows Arduinome Serial connect to max?

PD: I checked the position of the cables and the same, sometimes the Leds do not go (because of the orientation of the cable) but the others don’t iluminate as they should, and the buttons don’t work neither.

Expecting for answer!

Maybe you can ask the guys who put together the arduinome project initially? After a Google, they’ve moved to http://flipmu.com/

Hey,

couple of years ago i build an arduinome. used it mostly with molar vst and 7up. i’ve not followed the monome forum for the last 5 years so i have no clue whats going on today.

i tried to connect my arduionome withe the arduinomeserial to M4l apps like terms without any results.

Do i need to flash my arduinome or use another serial osc?

what are you doing with your arduinomes today?

I just tried my old version of Molar vst with the latest arduinoserial and it’s still works…

would be nice if u guys give me an update

i’d potentially suggest sticking with arduinomeserial and the apps you like, as most of the newer apps are variable-brightness and use serialosc, which does not play well with arduinomeserial unless you’re happy disabling/re-enabling serialosc frequently. see the new setup docs.

so, i’ve gotten my arduinome assembled after 4 long years and a few days of free time, ive been doing lots o troubleshooting today and have gotten most of the bugs figured out, as far as i can tell.

only problem now is some of the buttons, one row in particular, will send random numbers (0-7) in monome_home when i press down the pad. obviously this affects functionality when trying to play apps. this doesnt seem to be a problem when the power up led whoosh happens, nor when running monome_home in random mode, or all 1 mode.

i’ve resoldered almost all the diodes in the row (it seems like one bad one affects the whole row), though not replaced them. could i just have a few bad ones? i dont have any more of this type *bought 4 years ago) so im considering replacing all of them.

1 Like

so i’ve got it downto just one row, 3rd (?), in which press any button sends a random x y s message across the board. this must be hardware right? i’ve checked the board for broken traces but i cant seem to find any.

you likely have an issue where the LED pad is exposed enough somehow that a sideways keypress is bridging the key and LED systems together. make sure those LEDs are well seated.

thanks, but i think i figured it out! followed some advice in a long forgotten thread about soldering the ribbon cable wires directly to the button board, it worked!

maybe that means the IDC clamp i was using was bridging two of the wires together.

after 4 years my kit is finally complete!

3 Likes

Recently I’ve dug out my old arduinome 128, which uses two Starfire 40h boards. I’m trying to get it running with serialosc but I’m having problems. It will work at first - tested in monometest and it does everything it should - but it seems to disconnect within 20-30 seconds (of activity - it doesn’t seem to disconnect if just left alone). Sometimes it’ll reboot itself, other times it needs to be unplugged and reconnected.

At first I thought this was a hardware issue but I’ve tried using arduinomeserial and the disconnections don’t happen. So it seems like an issue with the arduinome + serialosc.

Has anyone had any experience of this and could anyone advise please? Here’s my setup:

Windows 10
Arduinome - 2* starfire boards (named a40h-001 and a40h-002)
serialosc 1.4.1a
Max 8

Any help would be greatly appreciated as I’m at a loss!

Does this also happen with 1.4.2 pre-release version of serialosc?

1 Like

omg @artfwo, thank you for your help - I’ve tried installing 1.4.2 as you suggested and it completely eliminates the disconnects. I’m amazed - I’ve spent hours trying to figure this out and you’ve solved it in one sentence!

Out of curiosity - any idea what the problem is with 1.4.1a?