Ash (a small collection)

ash

a small collection.

above: angl and playfair

  • angl — arc grains. use an arc to control pitch and speed granulation of four audio files.
  • earthsea — polyphonic synth, controlled by grid or MIDI. includes grid-based pattern recording and transposition. a super-minimal version of the eurorack module.
  • orbit — loop collector. dual async start-stop loop recorder. controls for rate and volume per voice.
  • playfair — euclidean drummer. four sequences, each with its own sample.

Requirements

  • angl — arc, glut engine, audio files.
  • earthsea — grid. polysub engine. also functions as a MIDI synth given MIDI input.
  • orbit — audio input.
  • playfair — ack engine, audio files. grid optional.

Documentation

angl: arc grains

K3 to switch modes:
  SPEED
    K2 then touch arc to
      set speed to zero
  PITCH
    K2 sets fine control
earthsea: pattern instrument

grid pattern player:
  1 1 record toggle
  1 2 play toggle
  1 8 transpose mode
orbit: loop collector

K2/K3 = toggle rec/play
K1+K2/K3 = stop
E2/E3 = change param value
E1 = change selected param 
playfair: euclidean drummer

E1 select
E2 density
E3 length
K2 reset phase
K3 start/stop

K1 = ALT
ALT-E1 = bpm

Download

v1.0.0 - https://github.com/tehn/ash/archive/master.zip

https://github.com/tehn/ash


several fixes in this version— i recommend updating if you have an old version.

22 Likes

I was up 'till 2am last night playing with my 2.00 Norns and now this… what a treat for the weekend!

Thanks @tehn and all other library contributors for making Norns such an exciting platform :clap:

1 Like

quick check: does playfair have grid functionality? I think there were a few old g.s floating around, but even after adjusting those I only get the top row

also, line 20 needed updated to load on my machine.
original: local ack = require 'ack/lib/ack'
updated: local ack = include 'we/lib/ack'

try pulling it down again. fixed (at least the include) since release. need to check the grid functionality though!

1 Like

hmmm. pulling from https://github.com/tehn/ash/blob/master/playfair.lua, still has require.

Just beginning to explore these.

Angl is awesome: I love the elegant simplicity of the interface.

I am always the one talking about the need for the machines to retain their states through power-cycle. So this is me chiming about this again: wondering if some sort of “freezing” of the state of the device is possible. Even if not preserving the settings of all the params, then at least the sample reference per stream…

With this app especially so much happens through exploration and finding some brilliant moments of convergence between the 4 streams, that finding it all totally wiped next time I turn on the Norns feels somewhat painful.

Pain or not though: it is seriously amazing to work it with the arc!

Many thanks for the great work!
p.

3 Likes

@Dan_Derks i am so confused: https://github.com/tehn/ash/blob/master/playfair.lua#L21

@laborcamp right now you can save the state. it’s an alt-page of PARAMS. see the docs here: https://monome.org/docs/norns/#parameters

if you save to the “default” pset it should start right back up… but i should check it out as well!

no no, it me. ramblings of a madman, disregard. was on 190404. all is well with requirements, grid interaction still missing, goodnight new york.

Thanks for pointing this out @tehn!
I see the function is there, and am super excited about it!

I saved a “default” setting.
BUT
after starting Norns up today, that setting did not load by “default”. OR I should say, it looked like it did: as in inspecting the params all values were there, but it produced no sound.
I messed about with re-setting the arc as a device, loaded the “default” setting manually again, and eventually the sound came out.
SO
It sort of worked, sort of not.
I would be curious to hear how your testing turned out!

I’m getting

SCRIPT ERROR: load fail

cannot open /home/we/dust/code/we/lib/polysub.lua: No such file or directory
when I try to use earthsea. How do I get this mythic polysub and how do I install it? Thanks for bearing with me.

did we get deletd?

seems like you need to (re-install?): We (collection)

be sure to rename the folder we not we-master

1 Like

That was it!! Thanks. I must have gotten a bit finger happy when cleaning up the code folder. :black_heart::black_heart::black_heart::black_heart:

is there a limit on the file sizes for angl ?

ah! and while we’re at it - what files type are allowed?

played with angl last Friday for a couple of hours - just great fun and no problems at all.

today upgraded to 2.0.1 and now some oddities …

  • no interaction between arc and norns
  • with ‘speed’ showing on the screen all 4 rings are on and rotate
  • when selecting ‘pitch’ nothing on arc at all
  • rotating knobs speed or pitch - nothing
  • can adjust speed, pitch, volume etc.via params

most strange. first arc / norns interaction I’ve played with, probably a good idea to try another script - any suggestions to test things out?

ok changing norns via params correctly adjusts the arc both pitch and speed but only in that direction

edit solved
see photos - devices arc all set to arc no go. set singularly ok.

2 Likes

Really enjoying the Ash/Earthsea script, but I am having some trouble with the pattern recorder. Specifically I’ll start recording a pattern and as soon as I loop it, it will transpose from the original pattern. Basically, it’s transposing when I don’t want it to, or haven’t asked it to via the grid. If I reload the script it will work for a few pattern recordings, but will then start automatically transposing to a seemingly random note again. Any ideas? I should say I am new to Norns and have no coding knowledge whatsoever! Thanks for any and all help.

I noticed this too, but got distracted and never investigated.

1 Like

I continue to get a crash when loading Angl & Playfair. The other two work flawlessly. There’s a load init problem with these two. I also have the current version of we in my code folder. Anything I might be missing?

Did you try a reset under system menu after installing we? It might be worth trying…

1 Like

I thought I gave that a shot. I will try again when I’m back home later this afternoon and see if that worked. Thanks for the tip!

I just spent three days troubleshooting my norns, so I can totally relate to the process- if a reset doesn’t work, for whatever reason then download the latest version of we and try that. I’ve had to download the same scripts a few times to get them to work.

1 Like