Awake-mod v1.0.8

nuked it.
did a fresh install and a sleep.
now it goes back to the error:init message.
here’s the maiden data:

Summary

script load: /home/we/dust/code/awake-mod/awake-mod.lua

cleanup

script clear

including /home/we/dust/code/awake-mod/lib/halfsecond.lua

including /home/we/dust/code/awake-mod/lib/keyboard.lua

including /home/we/dust/code/awake-mod/lib/fndtn.lua

including /home/we/dust/code/awake-mod/lib/xplsn.lua

including /home/we/dust/code/awake-mod/lib/mod.lua

script run

loading engine: PolyPerc

reading PMAP /home/we/dust/data/awake-mod/awake-mod.pmap

m.read: /home/we/dust/data/awake-mod/awake-mod.pmap not read.

clock: ignoring resumption of canceled clock (no coroutine)

Engine.register_commands; count: 6

___ engine commands ___

amp f

cutoff f

gain f

hz f

pw f

release f

___ polls ___

amp_in_l

amp_in_r

amp_out_l

amp_out_r

cpu_avg

cpu_peak

pitch_in_l

pitch_in_r

script init

starting halfsecond

pset >> read: /home/we/dust/data/awake-mod/awake-mod-01.pset

pset :: /home/we/dust/data/awake-mod/awake-mod-01.pset not read.

SCRIPT ERROR: init

/home/we/dust/code/awake-mod/awake-mod.lua:337: attempt to call a nil value (field ‘pan’)

stack traceback:

/home/we/norns/lua/core/norns.lua:138: in field ‘pan’

/home/we/dust/code/awake-mod/awake-mod.lua:337: in field ‘action’

/home/we/norns/lua/core/params/control.lua:104: in function ‘core/params/control.bang’

/home/we/norns/lua/core/paramset.lua:437: in function ‘core/paramset.bang’

/home/we/norns/lua/core/paramset.lua:430: in function ‘core/paramset.default’

/home/we/dust/code/awake-mod/awake-mod.lua:351: in global ‘init’

/home/we/norns/lua/core/script.lua:105: in function ‘core/script.init’

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:139: in field ‘try’

/home/we/norns/lua/core/engine.lua:91: in function </home/we/norns/lua/core/engine.lua:89>

That is odd because I didnt touch anything with the engine parameters. Do you perhaps have a different version of the PolyPerc engine elsewhere where pan isn’t specified? It’s not part of my lib because I assume you have the standard awake installed and Norns barks if there are two of the same engine. Maybe try reinstalling vanilla awake since I rely on that engine?

Also - if anyone has suggestions on managing engine dependencies better, I’m interested (though should be fairly safe to assume everyone has vanilla awake/PolyPerc).

Also also - how do I tag this post with ‘Norns’?? It has totally escaped me

1 Like

AH HA!
(not the band)

so i nuked every version of AWAKE that was on norns (there were four) and all of their data folders as well.

did a fresh install of just AWAKE and AWAKE-mod and it’s all working.

note for anyone else running into this:
you need to install the original AWAKE otherwise the MOD version will complain that the PolyPerc engine is missing.

thanks guys for the help!

also…
@zebra could you add the norns tag to the Awake-mod thread?
it’s not appearing in the norns library search.
:slight_smile:

1 Like

Great! I could create a copy of the engine/rename it if this is a common problem.

Updated to v1.0.7

  • remapped K1/K2/K3 on keyboard
  • scale increased to 24 steps above root note
  • added oct up/oct down/delete on keyboard
  • added oct up/oct down/fractal xplsn types

fractal was inspired by the Qu-Bit Bloom documentation. I don’t own one but thought the various types of modifications on a base sequence were interesting.

3 Likes

hey ya!
so i am running into a strange bug. :bug:

just updated to OS 210114

if i launch Awake-mod…i can’t clear it.
it’s just stuck with that script loaded.
if i try to load any other script the screen says loading… and never gets past it.
hitting K2 will back out of that screen.
if i use the RESET feature in the OS it will clear the script after rebooting.

here’s is what maiden displays…

Summary

script clear

lua: /home/we/norns/lua/core/script.lua:65: attempt to index a nil value (global ‘keyboard’)

stack traceback:

/home/we/norns/lua/core/script.lua:65: in function ‘core/script.clear’

/home/we/norns/lua/core/menu/home.lua:25: in function ‘core/menu/home.key’

/home/we/norns/lua/core/menu.lua:140: in function </home/we/norns/lua/core/menu.lua:117>

script load: /home/we/dust/code/arcologies/arcologies.lua

cleanup

script clear

lua: /home/we/norns/lua/core/script.lua:65: attempt to index a nil value (global ‘keyboard’)

stack traceback:

/home/we/norns/lua/core/script.lua:65: in function ‘core/script.clear’

/home/we/norns/lua/core/script.lua:155: in function ‘core/script.load’

/home/we/norns/lua/core/menu/preview.lua:23: in function ‘core/menu/preview.key’

/home/we/norns/lua/core/menu.lua:140: in function </home/we/norns/lua/core/menu.lua:117>

script clear

lua:

/home/we/norns/lua/core/script.lua:65: attempt to index a nil value (global ‘keyboard’)

stack traceback:

/home/we/norns/lua/core/script.lua:65: in function ‘core/script.clear’

/home/we/norns/lua/core/menu/home.lua:25: in function ‘core/menu/home.key’

/home/we/norns/lua/core/menu.lua:140: in function </home/we/norns/lua/core/menu.lua:117>

With the latest Norns update, Im pretty sure there was some kind of collision with my “keyboard.lua” script. After that, I had to change my keyboard command references to use the new format. Should be fixed if you pull 1.0.8!

Updated to v1.0.8:

  • FIX bug with mirror xplsn > save fndtn 1 > fractal xplsn (that was fun to troubleshoot)
  • FIX loading issue with latest Norns update
  • NEW added keyboard upward/downward transposition (Ctrl + number / left ctrl = down, right ctrl = up)

I think with this latest update that you have to install the latest version of Norns (210114) since I now reference the new keyboard.code command.

3 Likes

dove into the MIDI control with the script last night. :smiling_imp:
it’s driving an AFX Novation Bass Station…

1 Like

wondering if it is possible to change the synth to Passerby, I’d like to get an Awake-mod-Passerby version working. I tried just changing a couple lines in the code but no luck, there must be more to it than that I guess (don’t know much about coding)

I changed this:
engine.name = ‘PolyPerc’

to this:
engine.name = “Passersby”
passersby = include “passersby/lib/passersby_engine”

any help is much appreciated.

You could follow my adaptation of the original awake script for passersby - should have enough to get you up and running. You’ll want to compare how the notes are triggered between the two engines

1 Like

thanks, I’ve been exploring Passerby with that script, it is super cool, I like the sounds I get get with it. I’ve also been looking at the code to see what I have to copy over to the Awake-mode script to get Passerby to work with it too, but I have not figured it out yet. I’ll keep trying though.

Can you get passersby to play notes? If not have a look at awake-mod line 230 and compare with line 176 in awake-passersby. The note triggering syntax is different between the engines

1 Like

I have not even been able to get the script to load yet. I get an error

SCRIPT ERROR: init

/home/we/dust/code/awake-mod/awake-mod.lua:318: attempt to call a nil value (field ‘pw’)

try commenting out the lines that cause errors - it seems like its looking for properties of the engine that might not exist

1 Like

I’ll try that. Thanks.

Lines 118-119 from awake-passerby will need to replace the equivalent engine sound parameters in awake-mod. Just look for nearly the same commands in awake-mod and replace.

Plus there is a section for adding controlspecs for the PolyPerc engine in awake-mod that will need to be removed. You should be able to delete any of the controlspec commands from awake-mod - searching for ‘controlspec’ should do it.

In a nutshell, awake-mod has references to specific parameters for the PolyPerc engine (like the aforementioned pw/pulse width oscillator param) that aren’t applicable to the Passerby engine. All in all, if you get the engine parameter issues fixed and change the lines that @nattog is suggesting, you should be pretty close to working @ohm !

Feel free to keep posting questions and I’ll help best I can, thanks to @nattog for jumping in too!

2 Likes

Alright, it is working! I replaced all the polyperc controlspec section with “passersby.add_params” and replaced lines 230, 117 and 118 with the corresponding Awake-Passerby lines. Thanks @nattog and @shoggoth I wouldn’t have had any idea where to even begin looking without your help.

2 Likes

Really glad you got it working!

2 Likes

Awesome! (And in trying to just post ‘awesome’, now I finally understand ‘20 characters of…)

3 Likes

i keep wanting to have the transposing sequencer run at a slower clock, anyone have an idea if that sounds like it might be an easy change in the code ?

1 Like

You can kind of achieve that with longer mod trigs (/6-/8) or having a longer tranposing sequence length… but I get that isn’t quite the same.

Line 198 is where you would need to focus… that’s where the transposing sequence step is advanced. Maybe create something that only advances the step every 2nd, 3rd, etc time the step() function is called.

Id probably create a param for it in init() too.

EDIT: @leescan thinking about this some more, Im intrigued - so I’ll play around with adding it.

2 Likes