@tomw has already shared a fork of Awake that does exactly that - his post on it is here with a link to the modified lua file on his github. You can either overwrite the original or create a new awake.lua with a different name.

I took it out for a spin at the weekend and really like the results!

Edited to add: This mod doesn’t bring up a separate PARAMS page within Awake for you to choose on the fly, you have to set the instrument in the .lua file beforehand - you’ll need to make one further edit to the script in line 124 for the instrument you want, then restart.

In my case, I chose the Tatak felt piano; the new line 124 looks like this:



Thanks Helen. I’ve done this already - I just think it would make a great addition to the regular script, offering different voices as standard.

Awake using the taktak, probability low through a reverb pedal is a great sound!

1 Like

I’m sure you probably could customise your own awake.lua file to add the choice in PARAMS, but I’ve no idea how you’d go about it - I’m not a coder, I’m afraid!

I found I had to change line 162 as well when swapping to a new mx.samples instrument: skeys:on({name="discord_choir",midi=note_num,velocity=120})


Oh! That’s interesting - I must admit I didn’t make that change on mine - it worked okay for me with just the line 124 tweak, but maybe adding that extra one would be even better!
I’ll give it a try later. Thanks! :smiley:

1 Like

Here’s a nicer version that lets you select instrument and exposes some of the mx.samples params - GitHub - tomwaters/awake-mx.samples


Thanks very much for this update - listening now and it’s really good to be able to sweep through the mx.samples instruments, particularly using a fader on an attached midi controller.


Hey guys! I’m a bit of a newbie here. I was hoping somebody could help me sync up my crow running awake on Norns, to my Pamela’s new workout clock.

Norns is running the latest version with the most up to date awake code.

For some reason it is not reading the clock when I patch into input 1.

Any ideas?

awake + prophet 12


Norns shield sequencing Organelle via midi thru with Arturia Keystep 37.


All, a norns newbie here. I am using Awake as my test bed to be sure that I understand most of the basics. Today I have crashed into something that should be a basic issue, hope you can help.

Using MIDI through a Roland UM-ONE Mk2, I am successfully sending notes to, and receiving clock from, a Roland MC-707 (not bad!) However, I can’t get the norns to listen to control change MIDI messages. It just plays and ignores them.

To be sure that the MC-707 is setup correctly, I’ve also hooked it up with a Minilogue XD, so that I could see that the control messages are received and obeyed correctly, and they are: they stop and start the sequencer there.

I’ve searched in the norns’ parameters page if there is something like “enable receive transport” (that’s what it’s called on the Korg) but found nothing. I’ve looked in Awake’s source code, and it seems to be managing start and stop MIDI messages… so my guess is that the norns OS is not handing over those messages to the script.

Any ideas?

Btw how do I just start or stop Awake manually? :confused:Thanks!

you’ll need to map the cc numbers to parameters in the norns script. navigate to the paramter menu and select MAP to get started :slight_smile:

more info here, control + clock | monome/docs, under the MAP section.

not totally sure, but it looks like you can start/stop via midi transport commands.

from awake.lua:

@Justmat thanks but there is something we’re both missing.

I’ve searched in the map parameters and found nothing that seem to refer to transport. There’s a clock section with

  • clock_source and clock_tempo that are working fine already, so I do not need to change anything, and
  • clock_reset that does nothing :confused:

Also at the web page you refer to does not explain how to get transport from an external device.

Is any norns script acting as a simple MIDI monitor, even just to check that I am receiving it correctly?



There is a midi monitor script that might help?


Thanks @JoseQuervo I now have quite an unambiguous confirmation that the start and stop messages are coming into the norns, together with the clock that I knew already :grinning:


Now, the challenge is, why would such explicit code in awake.lua - such as the lines highlighted by @Justmat earlier - do nothing! :thinking:

The awake.lua script that came with the norns distribution is not the one that is online on GitHub! They are both marked as version 2.4.0, but the online one has about 60 extra lines of code, including the start / stop management! Of course I was going crazy!

Thanks to all who helped. I will warn @tehn with pull request.


which section of the params menu can I find the tap tempo please? :blush:

I’ve tried awake with jf through crow+ii yesterday. It works like a charm, but I can’t seem to find a way to put jf back in normal mode after I am done playing with it with awake.

Is there some option that I’ve missed or do I need to modify .lua to send ii.jf.mode(0) somehow?

Very new to Norns and even newer to Mannequins gear. How do I use Awake with Crow and Just Friends? I’m sure this is a ridiculously basic question but I’ve been searching through the documentation and its all very dense and spread out.

I’m assuming I need to connect the i2c ports on the back? Since “There is no standard “i2c cable” (according to this guide) I’m wondering if I can do this with a 6pin ribbon cable I happen to have laying around. Red stripe down?

I’ll be honest I am unexpectedly overwhelmed by this but the lines community has been great so far so here’s hoping you guys can help me out. Thanks.

hi hi! hope all’s well :slight_smile:

connecting the pins

monome recommends grabbing a stash of these jumper wires – that’s what we use in the workshop, totally good cheap solution.

we’re working on surfacing i2c docs wherever folks might look, but for now i’ll highlight @mattallison’s fantastic recent contributions in the ansible docs: i2c / ii | monome/docs

in the script

first, connect your crow to norns via USB.

if you’re running awake version 2.4.1 (it’ll display this in the script info when you go to load it), then there’s an output section in the parameters – press K3 to enter it. toggle the output parameter to crow ii jf and the script will send its notes to just friends via crow :slight_smile:

lmk if you run into any other q’s!



I’ve only gotten back to this just now. I have the i2c wires hooked up in the back correctly, I believe, and the output parameter set properly but I’m not getting anything. What mode does Just Friends need to be in? Is there a particular way I need to have Crow and Just Friends patched (I was assuming that the point of connecting things on the back was so that you did’nt have to patch anything but just thought I’d ask)?

See?! This is why this is the best community. I’ve ordered the cables and bookmarked that doc. I’ll see how everything goes and let you know.