Basic MAX Help

So im trying to learn a little bit more about max and trying to create a simple rotation patch. But i cant even get past sending messages to serialosc. Ive followed the the grid studies but none of my messages change anything or output anything in max console. I dont understand ive followed the instructions. My monome and apps work fine just wish i knew how to do simple max

1 Like

not terribly helpful I know, but it doesn’t look like that patch is the problem. maybe try restarting max/your computer, make sure you’re using an up-to-date serialosc object ? hard to say what’s going on exactly, that looks like it should be working

1 Like

Not sure but,
A space between ‘set’ and ‘2’ ?

Wrong Prefix?
The console says “/midi” but your patch uses “/monome”…

Your patch does not use a print object…I think that’s why nothing gets printed to your max console.

I tried restarting the computer and now i can get messages to the monome. However rotate still does nothing

/sys/rotation i 90

thats the message ive tried

/monome/grid/led/set x y z - this message works now

i noticed the console midi and monome were different too, those messages are from me pushing buttons on the pyhsical device. Not sure why, but the messages for turning on led send now without having to change anything in max. All i did was restart the computer open a new patcher and retype everything i did before

there was a space between set and 2 before but this message is working after i restarted my computer, but cant get a rotate message to work

/sys/rotation i 90


/sys/rotation i <90>
/sys/rotate 90

hard to tell which way the message needs to be entered i feel like i seen several variations of this message

From one max beginner to another - the message box (hit m to make one appear) shows everything that comes into it’s right hand inlet - stick one of those after the monome/serialosc object and see what’s coming out of it? My patches are littered with message objects just tracking what is happening.


This helped me get further but when connecting a message box to the monome/serialosc object ive never seen a message come out of it. Ive been able to construct the gridstudies up to decoupled action, but i dont understand if its really working decoupled it seems to be the same as coupled action. It only lights up if i click in the top matrix but if i press a button nothing happens

I still cant get a rotation message to work

Ah the issue with the message box in that patch is that messages are coming out of the left hand outlet of the monome/serialosc object, but your message box is connected to the middle outlet.

Hmm i tried the left most outlet first but there was nothing there i tired it again but no messages ever come out of the monome/serial osc object

I switched and tried all 4 of the bottom connections but none of them ever sent messages

rotate message still doesnt still doesnt work

the top matrix lights up my grid and all messages to light up the grid work

print doesnt print anything from monome/serialosc but insteads prints the matrixctrl when i switched the connections

Question: Do you have multiple instances of serialosc running at once (i.e. an example patch and the patch you’re working on)? I believe, and please correct me if I’m wrong, but Max can only connect one [serialosc] object at a time. So I only ever have one Max window or app open at once with [serialosc] to ensure that I’m connecting to my grid. I know it has the grid in the dropdown menu, but I’m just tossing out ideas.

In your screenshot from the 28th, you’re using a message box instead of an object for [route]. It’s a tricky distinction because, especially in more recent versions of Max, they look very similar.

Unable to help with the /sys/rotation message but I can look into it.

Also, if it helps, you can give print an argument (ex: [print from_monome]) so that you can see which print object is getting which messages.

Welcome to max… it’s a steep curve but worth it!


Okay, so I got the /sys/rotation message to work on my Grid (which is a 64).

It should look like this:

(/sys/rotation 90) or (/sys/rotation 180)

This will not make any changes to the LEDs that are currently displayed - it will only change the coordinates of any messages received after you rotate. So simply sending the message won’t do anything to your grid; you gotta rotate and then send it another message to check it. I did the following, where all (____) are messages sent into the [serialosc] object:

(/monome/grid/led/set 1 1 1) //light up a button at 1 1
(/monome/grid/led/all 0) //clear grid
(/sys/rotate 90) //reorient grid
(/monome/grid/led/set 1 1 1) //light up the new 1 1

1 Like

Awesome thanks so much the rotation message works now and i see messages coming out of monome/serialosc. Ive been opening random patches with a rotation patch implemented to be able to rotate, and now i dont have to anymore :slight_smile:

So glad to be learning max.

1 Like

I am piggybacking on this thread because it appears to be related to issues I am having. If mods believe it should be its own thread, that’s cool.

I am trying to connect an Arc4 and a Grid 128 to Max 8.1. I have a windows 10 x64 PC. It appears that Max can only detect one serialosc device at a time, meaning that I can’t use both. I only ever have the first one that was plugged in even available in the bpatcher drop-down.

Is that correct, or is there a workaround to get both the Grid and Arc usable in the same patcher? Thanks!

:wave: hi Charlie!
which version of serialosc are you running on your windows 10 pc?

there are a few threads that cover various troubles/fixes for Windows 10 + serialosc comms, but these might be overkill depending on your situation:

Hi @dan_derks

I am currently running serialosc 1.4.1 in the monome github repository.

gotcha. @artfwo has shared this windows 10-specific update in a few threads, can you please give it a shot + report back?: Windows 10 - grid 128 stopped working

I uninstalled 1.4.1a, then did an install of the one that was linked above. I restarted my PC, then booted up Max and I appear to be getting the same behavior.

I didn’t see anything strange in regedit either (no DependsOnService key or Error 1075). The serialosc service appears to be starting appropriately from what I can tell, but I am by no means a whiz at this kind of thing. And it does fairly consistently detect each device individually, though I sometimes have to wait a bit or select and deselect the device in the bpatcher drop-down for it to work.

that’s an issue i’ve never heard of before. are you using a usb hub by chance?