Blank Page on Android

Since recently, accessing lines from my Android device (Fairphone with FPOpen OS) will just show a blank page. I tried both the stock browser and the DuckDuckGo one, but the result is the same.
Is anybody else seeing this?

have you experienced this with other discourse forums? (MI etc)

edit: try now that i enabled sitewide HTTPS

I have checked and I get this with the MI forum as well, but not with other Discourse installs like

Doesn’t seem to have changed anything.

I’ve also emptied the cache and deleted the cookies, but to no avail.

we’re up to date with the discourse system, so perhaps it’s a bug introduced with a recent update (and blokas is behind?)

No problems here.
Chrome, Android 6.01, Nexus 5

Don’t have fair phone, but running Android here. No issues using Brave browser.

I’m having this same issue. running chrome on a OnePlus 5. no dice…

Possibly related? I get this from time to time when loading the site in firefox 61.0.2 on linux:

A shift-refresh loads the site as normal.

Works fine in Chrome and Ghostery on my Galaxy S7 with Android 8.0.0.

this might be related to the recent change of site settings to https. did you get the error repeatedly?

It happens every few days, I can’t remember when it started! A few months ago? (IMHO not worth spending time on! It’s easy to workaround. Just wanted to add a data point.)

just a quick thought: any add-ons active doing their magic? also, tried clearing the cookies? (same to the op)

I’ll see if I can figure out how to reproduce consistently. Just happened again, I haven’t noticed it when visiting other discourse-powered forums yet… it really hasn’t bothered me at all but happy to try to debug.

Update: the problem I’m seeing definitely just happens when the site is loaded from cache. Forcing firefox to make a request to the server loads fine, but anytime it attempts to use the locally cached version, I see that corrupted content error.

This seems like it might be the same issue – problems when restoring session content:

Not sure if this is the issue. I am having this with Chrome-based browsers. Though I did check Firefox Focus (always on Android) and I have the same issues there as well.
Interestingly various Discourse forums work (Elektronauts, so maybe it really is a matter of which version one is running.
Interestingly also the official Discourse forum does not work, giving me the same blank page as lines.
I was looking at where to file a bug report to the discourse team… but I can’t seem to figure that our. I can’t find the “issues” tab on their github page.

I’ve noticed this also on the discourse forum FWIW, if there’s a problem with the way discourse reloads the cached session via service workers, it might not be browser-specific either…

I did re-test recently and there seems to have been an improvement.
Fennec (a Firefox fork) works!
DuckDuckGo (Chromium based, IIRC, but I might be wrong), which previously didn’t work, now works fine.
So maybe the problem has been solved by the recent discourse update?

I also haven’t seen this in quite a while – earlier this year it would happen to me at least a couple times a day.