Boingg

Uuuuugh! That Just Friends sound is NOT helping my GAS for a modular setup and some Mannequins modules…

4 Likes

Haha! Oops :slight_smile: (PS. its totally worth it!!)

Added to the library!

1 Like

@Justmat

I have a request for Boingg. Would it be possible to get midi out? Thanks for this.

3 Likes

I will have a look at it :slight_smile:

2 Likes

Thanks! The script “Awake” has great midi in/out/clock options. If Boingg had the options that Awake has that would be amazing.

3 Likes

Sorry if this is a dumb q as I’m new to norns- this only triggers audio from the internal synth engine and is unable to use external sounds or serve as midi out?

looks like it’s just internal sounds or crow cv/ crow + just friends output. i should have added midi output ages ago, i’ll make it a point tomorrow.

2 Likes

Yes!! That’s awesome, thank you. :slight_smile:

1 Like

just pushed the midi output update!

15 Likes

Hi @Justmat,

Can you see if this works with clock from crow input? Today I sent midi out and was trying to clock from crow with no luck.

1 Like

I’ll add it to my list :sweat_smile:

Hopefully I’ll have some code time this coming week. There’s several things I want to do :smiley:

edit: @jasper_ryder, this script hasn’t been updated to use the norns clock system, so no crow clocking support at the moment. i’ll try to get things moved over to the new systems soon and post an update.

1 Like

I love Boingg! I put together an intro video on the app for folks new to, or curious about Norns:

7 Likes

HI. Since two latest Norns update, Boing ins’t loading. I get error message “missing polySub”. I removed and re installed but no joy.

script clear

script load: /home/we/dust/code/boingg/boingg.lua

script run

loading engine: PolySub

SCRIPT ERROR: missing PolySub

try ‘SYSTEM > RESTART’

reading PMAP /home/we/dust/data/boingg/boingg.pmap

m.read: /home/we/dust/data/boingg/boingg.pmap not read

hi there! sorry to hear that you’re having troubles! it’s working for me here, on norns 220321. are you on the latest norns update?

Hi! Well… something odd is happening. I go to update, it loads the update, shuts down, but then after powering again, it seems to not have updated. So each time I power again, it gives me option to install update 220321.
running update…

From maiden :

needs new disk image, aborting.

update complete.

1 Like

just to confirm — have you done the fresh disk image install for 220306? updates after this version will still show up for previous softwares, but won’t install unless that foundation has been laid. maiden will report that message you shared if installation isn’t possible.

more info here: norns: new image 220306

1 Like

Hi Dan. Philippe here :slight_smile: Errr, no, I’ve not been aware of the need to do a disk image install.

Is it this I gotta do ? :

Use etcher or the official Raspberry Pi Imager to flash your SD card, using these shield-specific instructions. Be sure to use a high quality SD card – if you have any trouble, please try a different card.

If etcher or the Imager do not work for you, or if you prefer to use the command line, see this guide.

After flashing your SD card, you’ll need to expand the filesystem:

  1. Open a terminal on a computer connected to the same network as your shield
  2. Execute: ssh we@norns.local
    Password: sleep
  • if you cannot connect to we@norns.local, try replacing norns.local with your shield’s IP address, discoverable by hitting K2 on the SELECT / SYSTEM / SLEEP screen
  1. Execute: sudo raspi-config
  2. Navigate to Advanced Options and hit RETURN
  3. Select Expand Filesystem and hit RETURN
  4. Lots of activity will happen. When it’s done, power down and reboot. If you get any errors, reboot again.
  5. Connect norns to your network and update via SYSTEM > UPDATE
  6. Consider changing the default password and address

If you have previously connected to a shield (either by this same IP address or simply norns.local) in the past, you may see a warning that the ‘remote host identification has changed’. this is because the shield now has a new host key. The error will give you a filepath to your hosts file, but if you are on MacOS you can simply execute rm -f ~/.ssh/known_hosts in Terminal to erase the previous hosts file and start fresh.

1 Like

hi philippe! wonderful to run into you!! :sparkles:
yeah! a bit more as well, outlined in this post, which i added as an edit before you probably saw it :slight_smile:

Hey hey hey! Yes, I’m getting there thanks. All done :smiley:

1 Like