Bowery: a crow collection

Bowery

A community collection of native crow scripts.

Documentation

scripts can be uploaded with druid or the m4l-based loader.

Download

Contributing

new scripts are welcome!

48 Likes

is @voidstar ok with adding ornithopters?

does @Galapagoose still have the script used on seasonal habits?

1 Like

That one looked like it wasn’t a standalone/native script, but either way, I’d be fun to see it!

I’ll dig it up / i hope i still have it. I wrote it a little before we got to the finalized firmware, so there may be some bits needing an update. Also, I’ll add First.lua to bowery as well, so it’s collected in the same place.

Happy to accept PRs on github, or if you don’t know github at all we can help get things included!

re: Ornithopters- would be great to have it included!

edit: The Seasonal Habits script was unfortunately taken as an offering as I was working on druid. I’ll definitely make some similar scripts though!

2 Likes

I don’t feel comfortable adding ornithopters yet. A few people have mentioned it freezing their crows & druid when attempting to load it, but I haven’t been able to reproduce that once for the life of me.

I wondered if it might have to do with the length of the script (significantly longer than trent’s scripts) and the length of the lines in the script? I tried making the script terser and breaking a few longer arithmetic lines up into multiple calculations - that seemed to help one of the people who saw druid locking up on upload, but not the other two. Have you been using it fine @glia? Really struggling to understand what the issue with the other people loading it is since it is working perfectly for me… but that maybe is discussion for another location, not this thread!

1 Like

Longer scripts were pretty flaky with pre v1.0.0 firmware, so hopefully folks will have better luck after updating. I’m pretty sure Ornithopters wouldn’t have even worked with the r command in druid before 1.0.

1 Like

ah ok

sorry if i came across as kinda forceful…my crow is still enroute so i haven’t tested any of these

just reading the code and it seemed like it will be fun

1 Like

not forceful at all! Glad to hear it looks exciting to you!

2 Likes

Wow! Just a question: if I wanted to add scale quantization to shiftregister.lua, would it be very difficult?

1 Like

i’m having severe issues with shiftregister.lua: it seems that it can’t properly track and output pitches; it’s playing just friends (via i2c) severely detuned. not sure if the issue is the script, crow, just friends, or ansible/kria.

steps to reproduce:

  1. load & run shiftregister.lua on crow.
  2. connect JF outs to mixer; either all six N outs, or mix out. (result will be the same either way). set JF to sound/transient. set JF knobs to something like a plain filtered sine-ish sound; no wild FM or harsh timbres.
  3. setup a sequence of notes within ansible kria. for my test scale, i just used two whole, whole steps, and left the other note slots empty. only root, major 2, major 3.
  4. patch ansible cv/pitch out to crow input 1, and patch any desired gate/trig source to crow input 2. i’ve used kria and teletype pulses; same results.
  5. listen as JF plays the kria notes sent via crow i2c.
  6. result: severely detuned, drifting, repeatedly off-key as time goes on.

attached is an audio clip. this issue has made shiftregister.lua completely unusable for me.

i’m not sure if the crow script is/isn’t doing something, or if just friends is drifting somehow and unable to play the correct pitch, or if ansible kria is unable to output a stable v/8 voltage.

crow-jf-asr-detune.mp3:


further testing:

  1. send only one unchanging kria note into crow input 1, letting JF/JT repeatedly play that same note over i2c
  2. switch JF over to regular RUN mode oscillator, sound/sustain
  3. patch crow output 1 (the first delayed asr) to JF v/8 input
  4. result: tiny, but audible rise in pitch from JF; it goes slightly sharp as long as it is physically patched. unplugging the v/8 cable at the crow output 1 end…immediately slides the frequency back down to “base” from i2c.

addendum: the pitched-up-detune-while-plugged issue is present with every oscillator i’ve tried so far; not only JF. crow’s outputs are noticeably sharp.

Not sure if this might be the issue:

If I understand the script correctly, all ASR outputs are updated simultaneously after a trig in.

EDIT: Can’t wait to try the scripts! My crow is still on its way…

yeah, that was one of the first things i read. that thread deals with max4live and norns, so i’m not sure how to fix it in shiftregister.lua. also, even slowing down the incoming clock, so that JF doesn’t have to deal with and generate so many rapid notes, doesn’t help.

the slightly off-pitch issue is also present in JF sound/sustain when physically patched; though not nearly as severe as in sound/transient over i2c. it’s also present when using mangrove and other oscillators, so i think crow’s outputs aren’t precisely tracking the original pitch.

@ioflow - It might be worth trying to delay the sampling after the trigger just a tiny bit to see if that helps. Perhaps the pitch is still rising or falling when that occurs.

2 Likes

Lorenz Attractors on crow! Chaotic, slow LFOs… plug 'em in to your vector scopes for pretty patterns, or use them as slowly-evolving LFOs!

:slight_smile:

18 Likes

@voidstar The Lorenz could open up a can of worms for the vector synthesis crowd - great idea

5 Likes

cross-post: would love some testing on druid + crow version of Less concepts if anyone’s willing!

nb. please only RUN this script, do not UPLOAD it to the permanent memory of crow. the script seems to be freezing crow if it is the boot script. I’m sorry for any troubles, but it is 100% working as a RUN script

5 Likes

Happy to help but I probably need some initial hand-holding just to get it installed!

awesome, thank you!

if you’ve run bowery scripts before, then you should be able to:

  • plop the file into your established bowery folder
  • use terminal to cd to the bowery folder
  • execute druid inside the folder
  • once in druid, r d_lc.lua

if you haven’t run bowery scripts before, this should help for getting started: https://monome.org/docs/crow/scripting/#bowery. then, just the above :slight_smile:

let me know if I can help with anything else in the less concepts thread :slight_smile:

1 Like

I’ve only used First so far!

I’m a bit wary of overwriting it after seeing some of the comments from folks who are having troubles with Druid… Those may be issues with individual modules and not the system as a whole, but it’s still intimidating given my inexperience with this stuff…

I’m really interested in trying this, and will do so as soon as I can get a little time, maybe this evening with any luck…

I just hope I can get back to First when I need to!

for sure, thank you for the interest + willingness!

if all else fails, First can be easily recalled with ^^f and then use p to confirm. it’ll look like this:

if you run into further trouble, also please feel free to email help@monome.org and we’ll get it sorted directly :slight_smile:

5 Likes