Built my 40h kit today! Having a button repeat press problem

This may be a blast in the past for most of you but…today was the day I finally built my 40h monome! I managed to source all the key parts from Bibo who still (many years after the group buy) had a buttonpad, 40h logic board and ATMega.

After a few hours of soldering I very apprehensively plugged it in and both sum and the monome test seemed to be working fine but with one problem. Repeat presses of the same button don’t register when pressed sooner than about two seconds after the first press.

For example in the monome test I press a button and it lights up, I then have to wait about a second or two before I can press it again to turn it off. The ‘key’ graphic within the test shows a dot when I press the button which stays on for the same amount of time even once I have released the button. The main practical issue this is causing is in apps like MLR, samples can’t be chopped up any faster than about a second.

Anyone got any ideas what this could be? I’m running Mac OS 10.10.4 and have tried the test in multiple versions of Max.

I wanted to say a massive thank you to everyone who has indirectly helped already with all the many solutions and answers to other problems. Hopefully somebody somewhere has a solution for this!

You might try experimenting with different baud rates in the firmware (e.g., 57600 instead of 115200). IIRC I had to lower the baud rate a little to get mine to work reliably…

Is that something I would have to do with hardware, programming the ATMega directly? Or is there somewhere this can be changed in software?

I am talking about reprogramming the hardware. To try my suggestion you would need to modify the firmware and re-upload it to your arduino. There is probably a line in the firmware that reads: “Serial.begin(X);” where X is the baud rate used for the serial communication. You can try changing X to 57600, and uploading the firmware to your arduino to see if it makes any difference with your problem…

Okay thanks for the suggestion! I would have to get hold of a jtag programmer to give this a go so I’ll try some other options first. Currently trying to get everything running on a different computer to see if that solves anything.

Good luck… (BTW, not sure why you would need a JTAG programmer. The arduino runs a boot loader that can be reprogrammed over USB. No special equipment required).

I’m using a monome 40h clone not an arduino and as far as i’m aware from reading other posts the 40h kits can’t be programmed over USB. I’ll look into it though as that would save a lot of hassle!

Ah, sorry. I assumed you were building an arduinome. Should have read your post more carefully (I think the part about using a Bibo button pad confused me). None of my suggestions apply, in that case. Good luck anyway…

this may be difficult to debug. i might suggest first upgrading to 10.11.4 and possibly trying another computer. and make sure the FTDI driver is removed-- see http://monome.org/docs

you may then be able to establish if it’s a computer problem or a hardware/firmware problem

Okay so i’ve just downloaded the standalone sum app on a different (windows) computer and had the same problem. I suppose this suggests a hardware/firmware problem.

I have optimistically tried a different usb cable with no luck. In terms of the hardware I followed the 40h guide as closely as I could, in some cases (I think just the capacitors and resistor) I wasn’t able to buy the exact components on the list but have matched them to equivalents. Is it possible that the um245r could be faulty?

http://archive.monome.org/community/discussion/2900/button-timeout-in-40h/p1

Just found this thread, sounds like the exact problem. I just timed the fade out of the start up pattern as you suggested in the thread and mine takes far longer than one second.

If this is the answer is the solution reprogramming the ATmega32?

you need to flash the fuses, so yes.