C++ wrapper around libmonome

I have used this C++ wrapper around libmonome for a project, now I cleaned it up and I’ve uploaded it to github, maybe it will be useful to someone. Uses CMake and it’s tested just on Mac, but it should work everywhere.
I used it for a standalone sequencer, using Core MIDI… in case there’s interest, it’s a bit complex but I can add it to the repo.


Awesome! I’ll check this out sometime in the near future.

BTW- I have some trouble with building (configure stage) libmonome. It doesn’t find my liblo… Do your build script also build libmonome from source or just include the lib?

it assumes libmonome to be on the system.

check the recent topics about libmonome, I answered how I got past the liblo error. if you don’t find it I will write it again.

btw: I forgot to test the examples on the actual hardware :slight_smile: will test them later tonight!

I haven’t been able to test the (blinded coded but should work) examples because the FTDI driver messed up my El Capitan installation.
I know for sure that the library works, but If anybody can test the examples and drop me a line to say that everything works as it should, would be appreciated. tty.serial doesn’t show anymore after upgrading to El Capitan :’( , no matter what I do. I’ll have time to risk having to deal with another kernel panic just in some days.

uninstall the FTDI driver:


Indeed I have ended up rebooting in safe mode and removed that kext (and other 2, the Prolific one and god knows which one). Still I don’t see the monome though… any advice?

it’s not detected in /dev or in the system profiler?

you need to enable to apple-ftdi driver:

sudo kextload -bundle-id com.apple.driver.AppleUSBFTDI

I’ve tried that, it didn’t change anything… nothing shows up in System Profiler and nothing in dev/ as well…

ah. have you confirmed that the hardware works on another computer? tried the other USB port? etc? you get the startup light pattern?

I tried the other USB port, and I get a random fixed pattern on the LEDs (always the same one).
Now the monome is at home and I’m at the office. I will try on another computer tomorrow