can't see "available" scripts in maiden

Hello,

For the past couple of days, I’ve been having a trouble with my norns. The main problem I have, as shown in the screenshots, is that when I load maiden, the “available” options are blank.

I was getting some errors “polyperc not found?” when trying to reinstall arcologies due to some problems. I think I might have ended up deleting some of the important files from dust’s data folder. I’ve been trying to find those system files I’m missing, but I couldn’t find anything here on the forum. I’d appreciate it if someone could help me troubleshoot this.


maiden doesn’t have any built in knowledge of where to download the base and community script catalogs, it uses some “source” config files. Inside the data directory if you:

Hopefully that will get you up and running again.

2 Likes

Brilliant. Thank you very, very much!

1 Like

Hi all, for some reason I cannot see any of the available scripts on Maiden. I can see my installed scripts, and Norns is running fine. IS there something really obvious that I am missing (probably…) Thanks.

are you online? :slight_smile: have you tried refreshing the catalogs?

3 Likes

Yes, I’m online thanks Matt, but I don’t have a refresh all option, please see the screenshot. I appreciate any help!

1 Like

what version of norns are you on?

on the main menu screen, press key 2. the firmware version number is on the lower right.

1 Like

Thanks Matt: I’m on version 221214

huh! does clearing cache help at all?
otherwise, i’m curious if you connect to your norns via SSH and execute cat maiden/dist/sources/community.json, do you see the following?

2 Likes

I cleared the browser cache and tried another browser but still the same, thanks Dan. I can see that on SSH, here’s what I have:

ah, actually, found this thread:

^ that should do it!

1 Like

Yes!! That got it working, many thanks Dan!!

1 Like

rad! all the thanks is due to the brilliant @ngwese ! i’ll merge this into that thread and get this into the docs since it’s happened publicly more than once :slight_smile:

1 Like

It happened when I was trying to make enough space on my Norns to update. I wish I could update the storage but I know the larger size has been out for a while, do you have any updates ok those? Thanks

i experienced this as well related to the issues discussed here. i had 0 space left btw

1 Like