[cheat codes 2] (rev 220517: LTS6.1)

Thanks for the info, Dan! Amazing app and great support!

I tried the wireless option but it didn’t work because I didn’t know that I have to use the Max for Live device. This afternoon I’m goint to try it again.

Just one question more: so isn’t possible to send back audio from CC2 to Live? I’m thinking in the possibility of sending back three tracks -one per CC2 bank- to Live…

1 Like

Thanks for the info! Do you know if it would be possible to record three tracks separately -one per bank- to tape?

Only way to multi track is to hard pan the banks. But you would only get L/R so two banks works.

2 Likes

hi everybody! first of all thanks again so much @dan_derks for your amazing work, cc is my fav script ever :slight_smile:

I’m experiencing some strange behavior using arc to play live with loop windows:
as soon as I turn the encoder, the lit window leds on arc become one and the encoder doesn’t seem to have anny effect. is anybody else experiencing this issue? is there something incredibly simple that I’m missing?

cheers!

PS
I updated the script this morning. this happens on every clip and every arc encoder.

1 Like

happy to help!

the wireless clock option via Link? or the wireless control option?

the Max for Live device is only required if you want wireless control over cheat codes 2, where notes generated in Live trigger pads.

if you simply want the clock to match:

  • get your computer + norns on the same WIFI network
  • toggle Link on in Live
  • on norns, go to params > CLOCK and set the source to link
  • on Live, you should see this:

    which means norns + Live are communicating clock positions to each other
  • back on norns, you should see that your tempo and Live’s BPM match
  • you can also verify that on the [timing] screen, the counter is pulsing at the exact same rate as Live

otherwise, for control, you need to use the Max for Live device. if you’re using the M4L device, I also recommend using Link, to keep cheat codes 2’s delay in time :slight_smile:


just echoing this – there is no other way to separate the bank audio into discrete audio tracks


that’s exactly right – are things not working as expected? a connected crow should immediately start spitting out triggers with every pad press (bank A -> out 1, etc). if you put a bank into ‘focus hold’ mode, you’ll see a bright LED to the left of the 3rd zilchmo – that’s a toggle for crow pulse on/off per pad :bird:


known bug, apologies for the delay with a fix, but i’m bundling up the 64 grid layout and the alternate [loops] screen as part of the update. should be out today! :sparkles:

5 Likes

Thanks Dan! You’re amazing <3

1 Like

this gave me an idea. got a teletype last week and triggering scripts with pad outs via crow could really integrate cc2 with my eurorack. hmmmm :flashlight:

1 Like

yes exactly!! thanks so much @dan_derks, I just hadn’t found that functionality in the manual. super freekin cool.

1 Like

Dan - CC2 is amazing - spent 3 hours with it last night and only scratched the surface. One thing that I was struggling with was the pattern recorders on the timing menu. Apologies if the question’s been asked already. So you have two pattern recording modes, loose and distro; I only appear to be able to create a random pattern using K3. I can’t seem to record my own pattern. I understand that you use E2 to scroll to Rec Mode and then when you select K3 recording should start…nothing appears to happen. Should K3 toggle recording? In loose mode should the bpm be determined by CC2 based on the pad presses? Is there a way of changing the bpm in either loose or distro mode? The main thing is though that I don’t appear to be able to record my own patterns. Love the script though - very musical results.

1 Like

thanks fo the kind words @joseph_knecht

ah, a caveat to the on-norns controls for recording is that they’re overrode if you have a grid connected, since the grid has its own pattern management controls (see zilchmo row 1 in the docs):

if you’re using a MIDI controller, though, the pattern recording should work as described :slight_smile:

can you please confirm how you’re controlling cheat codes 2?

only if the [timing] screen option Px sets bpm? is set to yes. then the duration of your loose pattern for that pattern will be the base from which the bpm is set.

the bpm you see on [timing] is just mirrored from parameters > CLOCK > tempo, so you can adjust the bpm manually there.

if it helps, you can also affect session bpm via the [loops] screen:

  • bring a single pad into view (so, K2 down to the inner pad control section)
  • set its loops points to a desired snippet of audio
  • hold K1 and you’ll see K2: dur -> bpm at the bottom of the screen
  • with K1 held, press K2 to derive the session bpm from the selected loop

i personally really love finding a nice base loop, setting the bpm from it, and then arpin’ or euclidin’ or patternin’ from there :slight_smile:

Thanks Dan. I was using a grid so that explains it. I’ll try with zilchmo row 1 this evening, and thanks for the tips on bpm control. The euclid mode is great I ended up applying a euclidean rhythm to the random patterns I created last night - this was really effective.

1 Like


Great idea! Thanks!

I was talking about the wireless clock option via Link.

Dan, that’s an amazing script! I’ve spent 2 hours this afternoon truly hypnotized by the very musical results the script produces. And it has plenty of options. I only read the first 20 pages of the manual! Regarding that, I would like to print it. Is there a black over white version instead of white over black?

3 Likes

glad it’s all working out! excited to hear what you’re making!

thanks to @hypnosapien, yes! :slight_smile:

2 Likes

Yeah, I hope I can share something soon.

thanks to @hypnosapien, yes!

This community never ceases to amaze me! Thanks!

2 Likes

@dan_derks, being able to load a loop, slice it to the 16 pads (1/16th length pads Zilchmo), then have it run with rand pattern set to horizontal is just super cool. Thanks so much for implementing that as a feature! Would there be any way to have it jump to/continue the pattern from a pressed pad? That would basically make the bank like a row in mlr with this particular configuration. Everything is already amazing in this version, that would be the sprinkles on the icing on the cake. :slight_smile:

2 Likes

possible :bug: small alt + f does not select pad
arp on bank c not working ( tested with 3 live buffers and arp a and b running simultaneously )
pattern overdub grid light very bright how? can’t seem to make it work ?
many thanks as always :slight_smile:
edit: ok overdub is small alt and pattern record
one more issue I encountered similar to @SPIKE, when all all banks playing patterns, pads on bank c become unresponsive…not quite sure what’s happening…

@hypnosapien, a fantastic idea, thank you!! that’s sorta like how the rené handles these types of patterns, which seems like a good standard for snake movement :slight_smile:

@swhic – sorry to hear about the trouble!! yes, i’ve seen some very random times where this happens. it just seems that the clock in charge of one of the arps quits out. it’s not something i can reproduce reliably (and is only something i’ve run into a handful of times), so i added a manual reset under params > arp (grid only!) > arp reset (k3). if you ever run into trouble where arp pads are unresponsive, please try this function?

i honestly don’t know what to make of the other issue re: patterns clearing and then pads not being responsive…if anybody can create a reliable repro case, that’d be super helpful :sparkles:. maybe i’ll just add a total pattern reboot option to the params, the same as the arp. if it happens again, this will provide good information:

  • do you have any meta patterns running?
  • is this on distro or free? if distro, how many bars?
  • do you have quantization turned on in the params?
  • does the bank’s pattern screen show any indication that a new pattern was playing or being recorded?
  • does k1+k3 on the first line of the bank’s pattern screen clear things when the grid gesture doesn’t?

also, maybe this it: you can get into weird zones if you try to record a pattern while playing arps at the same time. this is because the script won’t take your arps into consideration when it plays back the recorded pattern, so it has a little bit of logic to cancel conflicting processes. i was able to make some weirdness happen if i tried to arp while pattern recording + vise versa, so this might be what’s happening – it’d actually fully explain @SPIKE’s issue the other day, because the cancellation process changes the distro amount, because it’s stopping the recording (and cheat codes assumes the recording being stopped means that should be the new length rather than the originally entered value because rules are meant to be broken). hmmmmm. this is a wild case! :stuck_out_tongue:

sounds like you got the overdub bit sorted! and you’re right that local alt + focus doesn’t do what global ALT + focus does – this was a choice, for some reason, but i’ll examine it next coding session! thank you!!

4 Likes

So I have live record buffer one configured to begin recording on the next bar after press and record for exactly one bar (live rec behavior set to 1-shot, 1-shot sync set to next bar, rec loop enc resolution set to 1 bar). I cannot get record buffers two and three to function the same way, however. They both seem to be recording immediately upon button press and continue recording until a second press. What am I missing?

oh thank you! just took a quick peek and it seems that setting the live rec behavior through params isn’t passing the right values to the record lanes.

while i work on a fix, you can set 1-shot sync and rec loop enc resolution through params, but then please use the [loops] screen for the live rec behavior:

  • with L selected on [loops], hold K1
  • use E1 to select the secondary control set
  • change mode to shot on each Live segment (you’ll notice that there’s now a “focus” function with each Live segment selector, where a grid press on a new segment switches “focus” to that segment and only a second grid press on an already-focused segment starts recording)
    • alternative to a grid press, you can also press K3 on L to come into the loop point section, then hold K1 + turn E1 to change Live segment focus

after that little bit of setup, you’ll be good until i get it fixed :slight_smile:

Thanks so much for the super quick reply, that works perfectly!

1 Like