[cheat codes 2] (rev 221007: LTS9 - more important fixes!)

Thanks Dan for all the good work. I’m quite new to Norns and CC2 especially, so excuse me if I’m missing something obvious –

Whenever I’m recording a pattern, the “stop recording” command is delayed, resulting in an extra long last pad, i.e. the recording stops on the following “beat” instead of whenever I press the button. I’m not sure if this is intended behavior? It’s almost as if there’s latency between the button press and the moment Norns registers it. The rec mode is set to loose, quantization is off, the pattern is question does not set the bpm. Changing the bpm doesn’t seem to affect the delay time.

1 Like

Greetings! just to be safe. Does this happen if you put the norns to sleep and reboot? On the surface it seems something you may have connected to the norns is possibly sludge-ing the cpu. Do you have any mods running in the background?

Also welcome @auumgn !

This also could maybe be something you have set under the “timing” tab? What record mode are you in?

Happy to have discovered this community:)

The issue persists after multiple restarts and sleeps / shut downs. I don’t have any mods, according to the system menu at least (I’m assuming Midigrid doesn’t count?) and my CPU is somewhere around 80% using a Rpi 3b+. The recording mode is set to loose and I don’t think I’ve changed anything else (any changes made would be reverted back to default on restart anyway, right?)

I’ve somewhat adapted and am able to record tight loops after a couple of tries, but I’ve then discovered another odd problem which might be related to the one I mentioned originally – whenever I record a pattern with “P1 sets bpm?” set to “yes”, the loop starts off in sync with the transport, but then gradually goes off rhythm.

Having just done some more testing, I’m now certain that the issues are related, since if I stop recording “on time” (which would lead to the extra beat / delayed trigger I was talking about), the loop goes out of sync a lot faster (immediately obvious after the initial cycle)

Sorry if any / all of this sounds confusing!

edit: the cpu usage does seem a bit high? I’ve tried running it from a 5v 3a power adapter and using a 20000 mah powerbank. Without any script running the screen shows about 11%

edit 2: also tried reinstalling cc2 - nothing

edit 3: I was able to lower cpu usage to about 34% by using another cable - the issues still persist, however

1 Like

confirmed as fixing my request, tyty :slight_smile:

1 Like

This may be because the loop ends not when the record pattern button is pushed but when it is released… if memory serves.

hey everyone ! I don’t like to take up too much space with cross posting about this release, but thought it was worth mentioning in here how this track came about;

all sounds (except one layer of glänta tones (fors fm)) was sequenced with one single bank on cheat codes simultaneously. The same pad sequence send notes out via crow to just friends/three sisters, via midi to glänta in ableton, and gate+v/oct to crow connected to morphagene with a reel of drum sounds i recorded through a marantz tape deck (i think i had v/oct going to organize and gate to play on mg)
I pushed in a pad sequenze and recorded the whole thing in one take. Seriously felt like cheating !

17 Likes

Another lovely album, thankyou!!

2 Likes

Beautiful Hans! Listened whilst cooking rice, vegetable and tofu last night.

4 Likes

this was it, thanks so much, Dan!

Hi everyone! I have a issue with JF and pad to note function. Every time I choose JF in global menu or hit synth mode - module freeze. W/ and crow working without any problems. What can be wrong? Just friends working good with awake, just play, etc

Hey all, sorry if this is bang obvious…

Is it possible to load a different sample to each individual pad of a bank? Like, from a sample pack.

Cheers!

I think you’d need a clip with all the samples in (sorta like how the OP-1/OP-Z handles samples), then you’d chop the clip to each pad. As far as I know, cheat codes supports 3 clips.

5 Likes

Ok, gotcha. Thanks.

Dare i say, it might be a cool feature if one could select a folder for a clip and it would assign the first 16 files to the 16 pads? (Disclaimer: i have no idea what im talking about when it comes to coding, so this could be totally unrealistic!)

totally on the next version’s roadmap, where total clip time is increased to 96 seconds – this will give each pad 6 seconds of individual sample import. cc2 limits to 32 seconds.
it’ll be some time before its out, as i’m wrapping up another script, but for sure coming!

20 Likes

Ace. Thanks Dan. Damn excited for the other script too!

3 Likes

20 characters of aaaaaaaa

Can’t wait for both, Dan :slight_smile:

1 Like

Afraid not:(

Recorded a video of the sync issue(s). You can see that I need to stop recording right on the last triplet before the new bar starts - that’s not too much of an issue, but when I try to sync the 2nd track to the first one - it’s not even close.

I’m clearly doing something wrong…right?

1 Like

I highly suspect (and hope) i am having a massive brain fart here and there is fantasticly obvious solution…

I cannot seem to get CC2 to hear incoming audio. The sound audible and can be recorded by other scripts (eg Reels) but does not register in the live buffer of CC2.

Any ideas?

Hey guys!
@dan_derks I’m just driving into cc2 and I wanted to say that it’s just unbelievable, an absolutely outstanding piece of work - genius.
I’m on 64 grid using launchpad. I was wondering how/if I can adjust the delay send on the grid? I’m not sure how to do it as there’s no option on the delay page adaptation for 64 grid that I can see? Do I just have to do that manually via params?

Thanks again!
Aaron

1 Like

hey all! hope everyone’s well :slight_smile:
apologies for delayed responses and thank you for the kind vibes!

@auumgn, i’m not able to repro this issue with what i have on hand, but if you can pack up your samples and your collection (there should be a folder under data > cheat_codes_2 which collects all the settings after you save), i’m totally happy to investigate!

@swim_tortuga, sound into the script is controlled via the PARAMS > SOFTCUT > input ____ settings, as well as the (L) and (R) settings under PARAMS > loops + buffers > live | incoming audio level. plz lmk if you continue to run into trouble!

@Agraham1987 , the 64 size interface has binary on/off for the delay send, where ‘on’ level is controlled via params the mix section of the delays screen – hold K1 to set for the entire bank. but i can see some room for the level gradient of the 128 on the 64 interface, if bank selection was presented vertically in column 1. when i get the chance to sit with the script again, i’ll investigate!

2 Likes