[cheat codes 2] (rev 230319: LTS11 - nb!)

Hi all! I haven’t used CC2 in a couples months and today when I went to load some collections, they were not pulling in the clip assignment to the respective banks. I even tried saving a new collection and I am observing that when loaded, it sets all the banks to live buffer 1, rather than the clip it was assigned when saved. Has anyone else experienced this issue? In some cases, I am see collections load with one bank having a clip loaded, but the behavior is not consistent. I can see the clips are loaded, just not assigned to the respective banks. I think the sequences from Euclid are also not loading. Thanks for the help in advance!

hey justin! hope all’s well otherwise.

sorry to hear about the trouble – please share any logs + collections (from dust/data/cheat_codes_2) which aren’t loading as expected and i’ll be happy to dig in!

1 Like

Dan! Doing well! Hope the same for you!

I haven’t shared logs before so if you need something else please let me know. Attached are the exported logs. I also included a zip file of one of the collections I am having an issue with, although it seems to all of my collections at this point. Let me know if you need anything else and thank you for your help!

system.log (363.1 KB)

collection-BLEWNITRO5.zip (28.5 KB)

Update: I just did an additional test with a brand new collection and here is what I observed.

Load CC2 from start.
Load 3 clips and assign each clip to a different bank. Clip 1 to Bank A, Clip 2 to Bank B and Clip 3 to Bank C.
Create a pattern in Euclid.
Save new collection.
When new collection is loaded, bank A has clip 1 loaded as input source and Bank B and C have live buffer 1 selected for input source.

When loading an older collection, it is also loading Bank A with clip 1 as input source and Bank B and C have live buffer 1 selected for input source.

rad, thanks justin!
just to confirm, when you hit K2 on SELECT / SYSTEM / SLEEP, what version number does norns report?

Hey Dan! System is showing 221214 as the version. When I check to see if there is an update available, it says up to date, but I could have missed something since its been a while for me.

I also realized the log I attached seems to be from a while ago, so I ran through another test and copied the logs from matron into this doc attached. Hopefully that will be of more use.

cc2 collections issue (4.2 KB)

collection-TEST2.zip (37.9 KB)

1 Like

oh! yeah, looks like you’ve maybe got an old version of cheat codes running and the loadup is stalling out – the latest is 230105 - LTS10.2. a quick update through maiden should solve it!

1 Like

Hmm, odd. When I try and update it says I am on the current version. Should I try and uninstall and reinstall?

yeah, that might kick it into gear.
essentially, if you’re seeing those sprocket-related messages, then you’re not running the latest version.
lmk if that persists tho!

1 Like

That fixed it! Doh moment on my end, didn’t even think to check the CC2 version when loading it up! Thanks for the quick response and resolution, greatly appreciated! Now time to make some new sounds :slight_smile: <3


Ay up… I’m really interested to know how people are using a 16n with cheat codes?

I have one and am sure that i would compliment performing CC2 beautifully, but my brain is always frazzled at the endless MAP options so would love to hear how others are using it for some ideas…


1 Like

@dan_derks did an amazing Instagram video using a 16n (or something similar) to control end point etc. Sounds really granular and awesome


Me too! Still not really got my head around CC, but I know when I do then it’ll be wonderful. And using my 16n would surely extend the possibilities even wider…

@swim_tortuga - let me know if you have any “Aha!” moments

1 Like

I just wanted to ask here - I’ve started using the nb mods and all of that wizardry…Not that I have a huge grasp on it yet.
I was wondering if we could use Emplaitress as our synth in CC2?
I’ve tried to configure but I’m not having much luck.
So for example using bank C to send midi to play Plaits instead of an external synth.
Any help os much appreciated!
Much love,


I’ve been wanting to try this out as well. I’ll try and get it running today and see if I can share any tips.


Hey guys!
So I just wanted to come and express my love for CC2 once again - Most recently I have been using it a lot for work and I’m really finding it to be my most useful tool when arranging music and designing sounds.
It can be used in so many styles and is just so adaptable as a tool.
As an example, I’m writing some electronic dance music at the moment with a client in mind and I wanted to share a version of one of the tracks that is almost entirely CC2 -

Thank you again to @dan_derks for creating this behemoth of a script and I look forward to learning more and more and exploring different ways of incorporating it into my process!
Much love


I have an incredibly stupid question…
Just got a Grid so am enjoying finally being able to play with CC with my Shield.
However, nothing i do seems to be able to make pattern recording work. I’m following the manual, but on the Page for whichever bank i’m trying to record for, “press k3 on rec mode” does nothing at all. On “loose” setting, pressing pads also doesnt start recording.

If it helps, the other weird thing is that contrary to the manual, the two options for record seem to be “loose” and “bars: 2” with no option to change the parameters for the bars setting either (ie no Distro option anywhere)

AFAIK i have the most up to date version - 230105 LTS10.2 from the boot screen, same as the thread. Am i doing something extremely stupid as I suspect I may be?


Heya - try this:


Also - to change the bars hold k1


Is the transport playing? Sometimes i forget I have to play it and get tripped up when my patterns dont take.

On the main menu press k2 to enter the metronome and transport menu.


yeah actually that had been my first thought too! But no, still not working. Cheers though!


Changing bars is kinda hidden. When you have bars selected in that menu. Hold k1 and change the number of bars with E3.

1 Like