Compass

Amazing! Lovely video, terrific sounds and awesome process — thanks for sharing your notes on this!

2 Likes

Thanks for sharing your script. It really glued it all together for me.
My favourite thing to do with the sp is to build up sounds, get lost in resampling. It is quite fun to then loosely sequence it with a looper and compass adds that extra magic.

1 Like

This is lovely, and the visuals are very fitting! Did you take the photos yourself? And how are you liking the Ar Merc’het Brao? :slight_smile:

I have to try this approach myself, i.e. the idea of using one module sent to Compass for processing and then reprocessing in itself.

1 Like

Thanks! I took these photos a while ago in Japan, only added the “set up” picture.
The Ar Merc’het Brao really shines late in the signal process due to its stereo output or in the send of a mixer, it is simply a module in a box with external power, TouellSkouarn offers it as module as well. It has some slight overlap for me to my beloved Oto Boum which I would always take with me when playing live as it is such a headache saver with the low/hi cut and compression capabilities, the Ar Merc’het Brao is probably more lively in the filter department (can be pinged as well) or be used serial, etc.
I cannot really use a supercomplex set up in one session but often love to layer/reprocess material over and over again, be it with the laptop (Argeiphontes Lyre + Soundhack), Norns, or the modular (ER 301 and various filters and fixed filterbanks). I love to arrange these “layers” then in a sampler. I really like the MPC One for that. Of course I could do the same with a laptop or on an iPad.

2 Likes

This is truly gorgeous - both sonically and visually! It also shows off something I love about Compass - it somehow has a characteristic sound whilst still being very flexible in its uses. Like all great instruments I think!

2 Likes

3.0

Really, really excited to share v3.0, a major update I’ve been working on for the last few weeks, and even more excited to hear what you all do with it!

Grid Control

Back in September, @swhic, @kasselvania and @yobink started offering some amazing grid-centric ideas for the script, but I felt that my coding chops just weren’t up to the task. Well, with a ton of help from the inimitable @dan_derks, I’m thrilled to say grid control is now reality.

With a grid connected, you can now:

  • Move the read/write heads around in the buffers.
  • Trigger commands by hand
  • Toggle the internal clock on/off
  • Quickly adjust the length of the command sequence

In addition, there are two banks of pattern recorders to capture all of your gestures.

Reference

Up until 3.0, a few in-app pages were included to give brief descriptions of commands. The approach to in-app reference was completely re-designed for 3.0, focusing on a single interactive page.

As you scroll through the commands with E2, a brief description of each one is printed to the screen. Simple!

But this page isn’t just there for informational purposes – it has a little trick up its sleeve. Here, you can toggle commands on or off to exclude them from your command sequence (scroll to a command and press K2). For instance, if you rarely use the rate-based commands (like me), or the crow commands, you can simply turn them off. Less scrolling!

Note: I recommend setting up your command list at the start of your session, as toggling any command on/off will reset your command sequence.

Manual

Documentation has been completely re-written and re-designed, and is hosted at compass-manual.glitch.me. Please do check it out for a much more detailed overview of the new features, especially grid control.


Changes

New command: /

I’ve included a new (kinda weird) command in 3.0 – / – that simply toggles softcut’s level up (full volume) or down (silent). It’s completely independent of recording. There’s a new associated param – LEVEL (slew) – that you can adjust from 0s (for hard cuts) to 10s for slow fades in/out. Think of it like opening or closing a VCA. If you like it, great! If not, no worries – you can exclude it :slight_smile:

Removing the decimator engine (for now)

During my extensive testing of this new version, I encountered some weird audio issues that took me a while to isolate. Whereas audio sources sounded fine in previous versions of Compass, I was suddenly hearing some kind of clipping/distortion/ducking issue (albeit faint) as of v2.0. Phasing also seemed more pronounced. Lo and behold, disabling the recently added decimator engine fixed things.

As a result, I’ve decided to disable it for this version. I have zero supercollider skills, but if I can work with someone to identify or fix the underlying issue, I’ll officially re-introduce the engine in a future update.


Have fun, check out the new manual, and let me know if you’ve got any questions!

51 Likes

Wow! Cannot wait to dive in!! Amazing work. And documentation looks ace.

2 Likes

@Olivier, this looks incredible! Wowee, I cannot wait to dig in :heart_eyes:

2 Likes

Looks amazing! Thanks a lot :heart:

2 Likes

oh my goodness! Thanks so much for this - the ability to disable commands is genius in particular… can’t wait to get stuck into it with the grid. (Now I really must figure out a better switching solution for my grid to norns/ansible.)

2 Likes

I had to dip my toes a little. The water felt nice.

6 Likes

Really great job - the documentation is superb :+1:

2 Likes

The Easter bunny is real! thanks @Olivier can’t wait to give this a go!

1 Like

I been drooling over the docs!

Great re-design and very well thought out changes

2 Likes

Thanks for the kind words, everyone! Super eager to hear your creations. Stay safe and be well :v:

2 Likes

holy frack!
i wish i had this for last night’s broadcast!
:stuck_out_tongue:

THANK YOU for the amazing update!!!

2 Likes

hey ya @Olivier.

ran into a couple of issues…
:stuck_out_tongue:
2 out of 3 norns gave me an error when trying to update through maiden.

using maiden: i had to delete the old install and then do a new install of 3.0

other problem is with audio play through.
sometimes audio will not play through norns until i get back out of recording in Compass.
note: i’m recording mono signals into Compass. i did set the mono setting on the parameters page)

on one norns…it just will not play audio through at all.
in fact i was recording into it and it wouldn’t produce any sound even after recording.
(i double checked levels on the main screen to see if there was audio coming in)

i originally recorded with only “}” in the sequence and i turned off the “softcut slash” function just to make sure it wasn’t in the sequence as well once i randomized things.

rebooted twice and finally got some audio playback but still no monitoring of the incoming signal.

2 Likes

Don’t know if it’s relevant, but I’ve once had an issue where I’ve had no input monitoring despite the levels being apparently set correctly after a reboot of Norns (not using compass 3). Turning the monitor level down and then up again on the levels page fixed it. Maybe try that?

2 Likes

thanks!

i tried that while i was trouble shooting everything.

even loaded another script just to make sure something else wasn’t going on.

Thank you, @Olivier, this is wonderful - so much easier to use now!

1 Like