Corrupted Content Error – Firefox v.60.0

Sometime when accessing this site With Mac Firefox (v.60.0) I get the following error:

The site at has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

Please contact the website owners to inform them of this problem.

After some quick initial research, It’s possible it has something to do with:
lines missing the Content-Length in the response headers.

This could also have to do with plugins installed in FF perhaps, but It’s really unclear what’s going on…
I’ve got uBlock, PrivacyBadger and HTTPS everywhere installed.

Does anyone else ever get this error?

1 Like

upon further inspection, I get this in the console:
Failed to load ‘’. A ServiceWorker passed a promise to FetchEvent.respondWith() that rejected with ‘TypeError: NetworkError when attempting to fetch resource.’.

1 Like

I get this, all of the time. I have learned that opening a new blank tab, and then navigating here works. But, coming from any other website seems broken.

edit: I also use uBlock and PrivacyBadger, but just tried it with both disabled and got the same error.

1 Like

same. i just ctrl+shift+r and silently yell at firefox every time. but i guess that sort of user-friendly error message is needed in an era where the browser is an OS which purpose is to enable people to buy stuff.

1 Like