cranes

Can anyone help me please?

Cranes doesn’t record my audio - I’m not sure if the paper crane should animate as it records, but it doesn’t.

Other scrips (oooooo, reels, barcodes etc) all work fine and will sample from my incoming audio. Cranes seems to be the only one not doing so.

I have uninstalled/reinstalled
Reset
Deleted psets (there were none)
Updated norns

Anything else I should be trying? I’m really keen to use Cranes!

hi! it’s likely because the input parameters for softcut were reset to -inf with the latest norns update (cranes doesn’t set these levels directly)

navigate to PARAMETERS > SOFTCUT and adjust to taste. hold K3 while adjusting for fine-tune intervals :slight_smile:

1 Like

Thanks Dan - will check this!

edit: inexplicibly, after trying Wrms for an hour or so, I went to try Cranes again and it worked without changing any settings.

Thanks for your quick suggestion @dan_derks

1 Like

Hello! Just got my Norns shield in the mail yesterday and I am loving it so far! I am running into trouble with cheat codes and cranes, as well as wrms. I have been running an op1 through the Norns audio input with a stereo 3.5mm cable and I can get an audio level detected at all times through whatever script. But cranes although it will let the audio pass through it it doesn’t seem to loop it, same for wrms. And to my understanding cheat codes is kinda crazy without a grids (I was trying TouchOSC) so I probably screwed something up with that one but as far as Wrms and Cranes I’m confident I’m getting audio in correctly. Need help! Also the script reels gives me an error int. I assume I need to learn how to reinstall a script in that case? Thank you folks I appreciate the help!

2 Likes

make sure the CUT level is turned up on the LEVELS page

1 Like

Just tried that still no looping :frowning:

did you try checking the input levels to softcut as well, as discussed just above?

do other softcut scripts work? e.g. the delay in awake? the Otis looper?

1 Like

I am not getting an input signal through the cut channel of the main levels page, only an audio signal through input and output, even through I have cranked the soft cut gain levels to 6db… all other scripts seem to be sampling incoming audio. Delay does not work on awake it appears… Otis is working as is oooooo

hi! apologies, there’s a slightly obscure softcut input level menu which also comes into play:

  • navigate to PARAMETERS > EDIT and press K3:
  • scroll down to the SOFTCUT option, press K3 (not the LEVELS option, which is for outgoing audio only)
  • you’ll see three input levels which are specific to softcut – make sure all of these are at least 0.0dB

this process is demonstrated in this video (which’ll also introduce you to cheat codes without a grid!):

confirm success or further trouble?

4 Likes

That’s weird, I had the same audio issue with Cranes today, never had it before.

:\ was it fixed by addressing the softcut parameters mentioned in the video?

1 Like

Sorry Dan, I’m at a cabin with a horrible wifi so apparently the latest posts hadn’t loaded so I missed your video link :slight_smile: I’ll check that, thanks a ton!

2 Likes

hmmm, did you check the ‘over’ setting in cranes main window? if set to something like 50% that should give you overdub

This has solved every problem I initially ran into my first couple days. Thank you :pray::heart:

1 Like

I was just thinking of the main window of the script

1 Like

My new cranes tattoo!

28 Likes

:sob: omg :hugs:
totally beyond
really lovely lines, looks incredible
such a deep honor, thank you :revolving_hearts:

3 Likes

Hello all,

New Norns Shield owner and I don’t know if missing something but I can’t seem to find controls for midi loop start and end, is this something that’s mappable?

hi hi! welcome :slight_smile:

cranes was written a few years ago (insane!) and does not support MIDI mapping loop start and end points, as those parameters’ ranges are not predictable – loops can be as long as 60 seconds and as small as a few hundred milliseconds.

i have some ideas on how to tackle this now, but it’s just a balance of time – i’m hoping that once i’ve wrapped the final version of another (much larger-scoped) script i’ve made called cheat codes will help free up some brainspace + i can give cranes a meaningful rewrite :rainbow:

so, tl;dr: those are not currently mappable!

15 Likes

Thank you Dan, that’s awesome.

I’ll have a dive into cheat codes definitely.