Critter & Guitari Organelle & Organelle M

@rdfm @glia The Organell supports wifi just fine! I SSH into it to update my scripts from my main dev computer. In fact, I have it mounted as an SSH share at this very moment…


I am not utilizing my Organelle to it’s full potential…

I know what I’m doing this holiday weekend!

1 Like

oh ok cool
I ran thru the specs in my head and didn’t recall wifi capability built-in

kinda unfortunate that there’s only one usb port…I feel like I need it for everything!
all good tho

It’s got two USB ports actually! And you can just plug in a USB hub to add more ports. :thumbsup:

Also, wifi is not “built in” persay, you need to get your own adapter and make sure it’s compatible. The Organelle is running Arch linux and it’s not too tricky to get wifi up and running.

Edit: If you don’t have a usb wifi adapter yet, I’ve had great success with the RaspberryPi “Canakit” adapter.

1 Like

[quote=“quilime, post:44, topic:1570”]
It’s got two USB ports actually! And you can just plug in a USB hub to add more ports.
[/quote]yeah I have one but there’s so much I haven’t tried yet

I was under the impression that patch storage is taking up one slot, no?
if the other one can be addressed with a hub that’s great news

did not realize that

1 Like

Yup! They are just standard USB ports. The patch-storage is just a USB flash drive. You can plug it into any available USB port.

1 Like

I’ve got direct serial messages to/from my grayscale128 on the organelle with comport. It’s looking very promising!


OK i have a few questions here:

  1. the organelle runs arch??
  2. I am seeing more and more reports of these weird segfaults in serialoscd. they make me very uncomfortable, because I’m not sure what’s causing them. this is not a question, in hindsight. my question is: does anybody know of a devboard that is close hardware-wise to the organelle (for testing purposes)?

@quilime you should be able to run serialosc-device directly.

./build/bin/serialosc-device /dev/ttyUSB0


Great! That works marvelous.

the organelle runs arch??

Yes, here’s some relevant output from the console:

$  cat /etc/issue
Arch Linux \r (\l)

$ uname -a
Linux organelle 3.14.14+ #7 SMP PREEMPT Wed Nov 4 14:51:27 EST 2015 armv7l GNU/Linux

$ cat /proc/version
Linux version 3.14.14+ (owen@owen-vbox) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #7 SMP PREEMPT Wed Nov 4 14:51:27 EST 2015

Not sure what the closest devboard would be, though. (RaspberryPI? Beagleboneblack?)

When I run serialosc-device directly, I get the following

$ ./build/bin/serialosc-device /dev/ttyUSB0
serialosc [m128-489]: connected, server running on port 17939

Still figuring out how to talk to it with OSC from PureData. Currently trying packOSC and updsend/receive.

Organelle running (some form of) MLR would be amazing.


in theory, @wrl’s mlr-like app rove just needs to be compiled for the organelle’s cpu, assuming that it also has jack and a few other libraries ported and installed. rove is much more limited than mlr, but it has the essence of its functionality; i used it for all of my monome+linux shows.

rove is abandoned at this point, but there is a puredata port of mlr that the organelle could run as a native app. there was even a tutorial on how to create pd_mlr as an intro to monome+Pd patching on the old monome wiki. it’s archived on the wayback machine.

@murray did a lot of work setting up a scripted environment that autostarts a bunch of headless apps (like rove) that would otherwise need config file editing, so some of that knowledge could be used with the organelle. a true port that can make use of the organelle’s screen and other onboard capabilities would be the way to go. though at that point it would be easier to setup a <$500 linux laptop that does the same things.

i, too, want to get away from an obvious computer, but i haven’t seen any standalone hardware, organelle or otherwise, that approaches the DSP horsepower and audio i/o needed for mlr-like functions. in modular, maybe the ER301, but that’s also still in beta.


Still cracking on this – so,while serialosc-device appears to runs when calling it directly, I still haven’t successfully sent/receive OSC to/from serialosc. I’ve tried added the user to the uucp group as per some other discussions, and still digging a bit deeper into it. Are there any tests to ensure that serialosc is working as expected?

FWIW, oscsend and oscdump are working just fine.

Copied this from the product page:
“1GHz ARM Cortex A9 with 512 MB RAM”
probably a Rasperry Pi v3. I have been able to make my monomes work with the Pi, but if i remember correctly serialoscd wasnt super stable (had to reboot if i unplugged my monome or stopped the daemon after initial detection)

Edit: ill test it on my hw when im back home from my winter camping on the coast

i have an rpi2 at home I can test with. rpi3 are cheap as well. will order one when i’m back in town after the holidays.

“working just fine” as in "sending and receiving OSC messages to and from serialosc-device using oscsend and oscdump"?

in that case, are you still struggling to make it work with pd, then?

Sorry – to clarify – oscsend and oscdump are working with eachother, but not with serialosc. I can run oscdump in one terminal window which receives messages sent with oscsend.

I haven’t yet been able to receive/send messages via serialosc.

So at this point, PD is able to send/receive bytes to/from the monome via [comport], but haven’t gotten osc via serialosc working.

Ok, the problem was all me. It was just how I was sending osc messages. I didn’t realize you needed the /monome/ prefix, but I learned that now that I browsed the source ofserver.c in the serialosc repo. SO serialosc is actually working fine. Apologies for the false alarm!

oscsend localhost 10145 /monome/grid/led/all i 1

oscsend localhost 10145 /monome/grid/led/all i 0

So, now I’m trying to get it working with PD!

EDIT: It’s working! Main discussion thread. Thanks for the help!


great news! thanks for sharing!

I wonder how the power situation is… did you already ran tests with a large amount of leds on?

(scary how I didn’t notice the domain change first :sweat_smile:)

So far I’ve gotten some of the monome grid-studies working. Fun stuff!

re: power
Haven’t run into an issues yet, but I suspect it should be fine with the organelle’s DC adapter. I also just got a battery pack I’m going to test it out with, though.

The last steps are getting serialosc to run when starting the patch. Shouldn’t be too hard. Very promising!