^^ crow 1.0.0

With the monome eurorack firmware there was none of these issues. Once hombrew was installed you double click on the flash file and away it went. I think that’s why I ran into so many issues as in my mind I was doing the same thing yet nothing was working.
Extremely grateful for all the help here.

1 Like

on macos we could make a flash.command file (ie tt is attached below, requires some extra bits)

cd "$(dirname "$0")"
dfu-programmer at32uc3b0256 erase
dfu-programmer at32uc3b0256 flash kria.hex --suppress-bootloader-mem
dfu-programmer at32uc3b0256 start

Ah yes, I was thinking of ‘.command’. We’ll get that rolled into the next firmware release.

1 Like

This seems helpful, but when I actually type ./flash.sh after getting into the right directory, it says:
sudo: dfu-util: command not found
SCOTTs-MBP:crow-v1.0.0 scottburton$

any idea why?

Nevermind—I had not fully installed a JDK which had stalled out my dfu-util and Homebrew install. Anyway, I just successfully installed crow 1.0.0!

1 Like

Still having trouble updating my crow with my PC and cmd!

After I cd to the folder containing the .zip file, in this case running:

cd C:\Users\Jacob\Desktop\Hardware\Firmware\crow\crow-v1.0.0

And then typing “./flash.sh”, it comes up with:

“.” is not recognized as an internal or external command, operable program or batch file.

I try removing the “.” and the same message appears.

I try holding shift, right clicking, copying as path, and pasting it into cmd with cd, as this:

cd “C:\Users\Jacob\Desktop\Hardware\Firmware\crow\crow-v1.0.0.zip”

And it then tells me that the directory name is invalid.

I’ve tried removing the quotation marks but it still comes up with the same message. I’ve tried unzipping, but then I’m back to the “not recognized message” after trying to run the “./flash.sh” command…

Can someone help me?

Those instructions are Mac/Linux specific. Open the sh file in a text editor and copy the text, paste into the command prompt opened at folder. Delete ‘sudo’ and run the command.

Need to update that update doc


Great, thank you! I thought it could be something along those lines. Will try it when I get a chance tonight :slight_smile:

Okay, I’ve opened the sh file in notepad and tried copy pasting the text in the command prompt, without sudo, yet I’m still getting the same “is not recognized as an internal or external command, operable program or batch file.” message.

This is the text, if it’s any help:

dfu-util -a 0 -s 0x08020000 -R -D crow.bin -d ,0483:df11

You need to install dfu-util. If you’re on windows 10, you’ll need the 64bit version. There is a link on the update page - “windows binary”.

I already have dfu-util, and have used it plenty of times to update my ansible without issue. Unless there’s something different about its use with crow?

Ansible uses dfu-programmer :wink:

Aha, okay, I’m obviously confusing dfu-util with dfu-programmer :upside_down_face:

See how I go with this then…

Thanks all!

Edit: I DO have dfu-util already too… Ugh what am I doing wrong?

Given the error message it just sounds like you need to either

A) add dfu-util to your system path


B) copy the crow.hex into the same folder that dfu-util is in, and run the command from that folder

crow.bin but otherwise I was going to suggest the same thing!

1 Like


I figured it out! Problem was I accidentally changed the path only for my login, not for the system. Silly mistake. But woohoo! Finally!

Hi all, still having no luck with this at all!

I have tried copying the crow.bin file to the dfu-util folder but the same thing happens.

I have also tried adding dfu-util to my system path, following this guide:

Which isn’t getting me anywhere either.

I’ve also tried following this:

That didn’t do much for me either.

Now when I double click the windows-update_firmware.bat file in the latest firmware download brings me this text:

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
No DFU capable USB device available

Where to go from here?

Thanks heaps to everyone for their help.

Also, @tehn, please feel free to merge my above attempts and subsequent advice offered to the ^^ crow help: general (connectivity, device q's, ecosystem) thread in case it may help someone else.