^^ crow 1.0.1

crow 1.0.1

We’ve been learning a lot about USB connections & Python package management, but also some subtle enhancements to ASL and the library of slopes. Many bug fixes, and better communication from crow as to what it’s doing from time to time. crow & druid are getting along great, and crow is able to keep up with norns when it speaks really quickly.

To update crow, follow the instructions on the update page.

To update druid, type pip3 install --upgrade monome-druid into terminal and run it from the bowery folder (or anywhere else!) by typing druid.

The Scripting tutorial has been updated if you run into issues or want to double-check that everything is working ok.

crow 1.0.1

  • NEW crow announces what script it’s running on boot
  • NEW clearer confirmations when using ^^clearscript, or ^^First
  • NEW .command and .bat files to run firmware-update from Finder / Windows Explorer
  • NEW output has a new event when a slope completes, redefine output[n].done() to use it
  • NEW output has a new state variable to query if it’s running: output[n].running
  • NEW code is now licensed with GPL3 @tehn
  • NEW asllib slopes accept generator-functions as arguments: asl.runtime() @voidstar
  • FIX asllib functions could crash if time was set to 0 @voidstar
  • FIX default input.change threshold increased to 1V to support Make Noise gates by default
  • FIX uploads while running a script with active input.streams could crash @csboling
  • FIX boot messages from crow would never appear

Plus numerous stability improvements with thanks to @csboling, and @simonvanderveldt.

druid 0.2.0

  • FIX running & uploading scripts could crash crow on win & mac @csboling @simonvanderveldt
  • FIX druid can be opened without crow currently connected
  • NEW on startup, druid will print whether it is connected to crow @csboling
  • NEW upload & download from the command-line @simonvanderveldt
  • NEW query your druid version with druid --version @simonvanderveldt
  • FIX text input is far more responsive

crow max & m4l update coming later this week.

38 Likes

Can an admin please tag this crow so I know to come back to it? Otherwise I will forget to update :slight_smile:

3 Likes

i’m impressed

just to confirm these instructions worked quickly and flawlessly on osx

downloaded + updated druid dfu-util and two ^^s within minutes

3 Likes

Is there a way to check which firmware version of crow your running? My update looks like it worked but I usually double check these things by running a command.

1 Like

See https://monome.org/docs/crow/technical/#environment-commands

2 Likes

After upgrading to 1.0.1 I’m getting an error when using n2v():

attempt to perform arithmetic on a function value

Can you show the script where you’re using it? n2v is really just intended to be used inside an ASL description.

In general, if you want to convert a note number to a volt, you can just divide it by 12 (because 1V = 1 octave = 12 semitones).

@j4ustin
Specifically you’ll want to send the ^^version command and crow will tell you which version it’s running.

Got it! Everything worked out well. Need to read through the documentation more.

The simplest test is entering this in druid:

print(n2v(60))

That used to return a float, but now it gives this:

function: 0x2002c300

Ah, of course. So perhaps this is moot, I can probably handle that much math. :crazy_face:

1 Like

I didn’t have a cable long enough to connect my iMac to my Crow, but this upgrade was easily done from my Norns.(I got Druid up and running on my Norns fairly easily as well.)

1 Like

do you mind sharing how?

1 Like

How do we do this?! very cool…

Norns is a Linux machine, all the same instructions for setting up druid on Linux should apply if you access a terminal over SSH.

3 Likes

I just SSH’d into my Norns, followed all the “Linux” instructions and it basically just worked! I had to use sudo everywhere the docs said it might be necessary.

(Edit: I will say that messing around with apt-get-ing software and whatever is kind of opening a Pandora’s box where continued tinkering could end up using up a bunch of disk space, turning off a necessary process, etc. In general I try to treat Norns as a dedicated music machine.)

FYI, some infos here, in case you run into issues when trying to run Druid on Norns : ^^ crow help: general (connectivity, device q's, ecosystem)

ahhh i thought he built a wrapper which contained druid on norns w/o involving another computer (as a lua script or something)

Trying to update Crow. I ran the home-brew installer and got this:

Press RETURN to continue or any other key to abort
==> /usr/bin/sudo /bin/mkdir -p /usr/local/Caskroom /usr/local/Frameworks
Password:[image of a key]

What is "Password? I tried giving my Mac password, to no avail.

I’ve searched this thread and can’t find anything about negative voltages on outputs. I can’t seem to set outputs to anything less than 0.

> output[2].volts = 5
> get_out(2)
^^output(2, 5.0)

> output[2].volts = -3
> get_out(2)
^^output(2, -3.0)

But looking at a scope on output 2 I get 0 Volts. Any ideas? I ran a crow.reset() to make sure nothing in the script was interfering.

how do i get the full “16bit [-5V,10V] range?”

I also tried a output[2].action = lfo() and after calling it, I get a LFO that moves from 0 to 5V.

1 Like

When I double click the installer on Mac it asks for a password but won’t let me type anything?

You won‘t see the cursor moving in the terminal or see any typed *** (that‘s how in works).
Make sure you type your password correctly in one go and hit enter.

1 Like