^^ crow 2.0+ help: general (connectivity, device q’s, ecosystem)

My crow just came in and it seems that the “first” script didnt came on it while the manual on the box states so… Is this a error? also where can i find the lua file for first?

See the bottom of this section https://monome.org/docs/crow/first/#next-steps
There’s also a link to the source on that page, although you don’t need it to get it on crow.

Thx to both of you i have played with first now :slight_smile:

I have just received my Crow and I tried setting my i2c rack and I am running into some issue when trying to make it play nice with Ansible. My setup is: (Fates) Norns > Crow + Just Friends + Ansible

I am able to:

  • run the Just Friend ii studies script (sending ii play_note commands from norns), Just Friends outputs the expected notes
  • use Just Friends as a device on Kria (Grids + Ansible using ii)

The issue seems to be with Ansible as a follower (leader seems fine since I was able to send commands to JF).

All the modules/devices are on the latest firmwares.

I tried the following:

  • trying to write voltage to the ansible CV outputs (nothing happens, no error in maiden)
  • running Kria and reading crow.ii.kria.get("preset"), which returns nil

(I played with the pullup instruction and using a powered bus or just connecting directly to the crow, and this worked well for JF but not for ansible).

Any suggestions?

This sounds like an Ansible or Fates issue rather than a Crow one. You need to set Ansible to ‘follower’ mode.

Further, I don’t know if Fates has pulled in the most recent changes to the norns libraries. The ‘get’ commands were not working up until this most recent norns release (200712).

Is there a way to flip to a different script on a stand-alone crow? Like a multi script where you could use an attenverter on the input to change scripts?
Also a way to clear a script without a computer or norns. The reason I am asking is for live performance. I have several simple scripts that I would like to use and switch between.
Also a way to reset / clear - so I can use for example Just Friends with a different sequencer in Teletype / or Ansible without it interfering with a preloaded script on Crow.
I currently reset Just Friends using Teletype by sending it a blank script of default / reset values. Would it be possible to get Teletype to send blank values to clear a Crow script?
Is Norns or a laptop the only option to do this?

3 Likes

I only have crow for one day now but what i started doing was checking how just friends is set and if certain inputs are getting used to launch a certain script. So:
Input 2 is not used:
script part 1
Input 2 is used and just friends is in sound mode:
script part 2
Input 2 is used and just friends is in shape mode:
script part 3

Kind of dirty but it works for now.

2 Likes

I have just received my crow and have had fun playing with first, but I came across a strange anomaly , the v/8 outputs worked fine patched into Rings, Plaits and Nebulae, but did not work when patched into Q-bit Chord2, I checked Chord by plugging bloom into its v/8 and everything was fine but as soon as Crows v/8 goes back in there is no response, anyone had a similar problem or is able to shed some light on this?
Also does this latest batch of crow ship with the version 2 software? thanks!

Oh this is a cool idea. Maybe detect binary gates at the inputs during init to choose between four sub scripts? The need for a power cycle is a bit obnoxious for live use though. Maybe you could code a “panic” routine for one of the inputs, like 20 high-low gate transitions within 5 sec, to reset the script.

1 Like

Dead Crow?

I’m getting ‘Crow not connected’ in druid. I’ve forced the bootloader by strapping pins 1 and 2 on the I2C connector. Crow does not show up when running dfu-util -l. Other dfu devices on my USB bus do show up. The update_firmware and erase_userscript scripts fail when run reporting no found dfu device.

Does anyone have any ideas what I should try next or do I have a dead crow?

Thanks!

Some quick questions to help us debug:

  1. Is it a brand new crow?
  2. Was the crow working correctly at some point?
  3. Plug a cable to output 1. Is the voltage ~0V or ~10V?
  4. What OS are you running?
2 Likes

all new crows ship with 2.0 installed, fully tested.

if for some reason first is not running, connect via druid and type ^^f to restart it

1 Like

Hi all, a couple of questions. I have a W/ and I’m interested in the possibilities that could come with adding a Crow to the mix. Only thing is, I know absolutely nothing about coding, I2C, none of that stuff.

I’ve been watching Trent’s streams on youtube trying to wrap my mind around it. But I’m curious if Crow comes with some sort of tutorial, like how W/ when u first turn it on has a hands on tutorial, as well as a lovely scroll and cheat sheet.

If not, is there a particular thread or site anyone can point me to, to learn the basics. I’m wanting to get crow for I2C control of W/ as well as using the front facing inputs/outputs for quantization and/or rhythmic gates and envelopes.

Any advice would be greatly appreciated.

3 Likes

the monome docs are extensive & wonderful ! this page goes over uploading existing scripts with druid (from bowery, a collection of scripts), some of those scripts might cover what u want to do

druid looks a bit like coding, but uploading existing scripts is a simple task, you can back track a bit from that page to get a handle on setting it up

descriptions of some of the bowery scripts live on this page !

4 Likes

Thank you for this, time to study!

1 Like

same here :sunglasses: newly crow’d

1 Like
  1. Yes. First time installation
  2. No
  3. 0.53v at output 1
  4. Mac OS 10.15.5

Thanks!

I’m wondering about this too. I’m thinking about DIYing something with one of the years-old ATTinys I found laying around with a couple of LEDs and tactile switches.

1 Like

I’m updating Crow to 2.0 and everything went well until my Terminal appears to be stuck here:

File downloaded successfully

dfu-util: can’t detach

Resetting USB to switch back to runtime mode

logout

Saving session…

…copying shared history…

…saving history…truncating history files…

…completed.

Deleting expired sessions…11 completed.

[Process completed]

Edit:

I can’t go any further, Terminal is frozen. Any ideas?